Project

General

Profile

Actions

coordination #121876

closed

[epic] Handle openQA review failures in Yam squad - SLE 15 SP5

Added by JERiveraMoya about 1 year ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
2022-03-25
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)

Description

Motivation

With this epic we will track all those fixes required in our test found during openQA review that do not require a complete redesign, but only some modification. It can also track tickets where we need some additional work to provide info in a bug.
Small improvement can also be tracked here.

Acceptance criteria

AC1: Test are fixed/enhanced according to bug recommendation/squad code standards.


Subtasks 153 (0 open153 closed)

action #108995: test fails in yast_users- timeoutResolvedrainerkoenig2022-03-25

Actions
action #115487: Unschedule from test suites in Migration - Regression job group all test modules unrelated with migrationResolvedzoecao2022-08-18

Actions
action #115622: Install kdumptool where needed and fix synchronization failure in yast kdump moduleResolvedleli2022-08-22

Actions
action #116767: Move test suite rmt_server_install from 'YaST' to 'Migration: Milestone' job groupResolvedjgwang2022-09-19

Actions
action #117100: Adjust bootloader_start on s390x to new YaST start messageResolvedshukui2022-09-23

Actions
action #117211: Add sync after dd in snapper_cleanup_timelineResolvedcoolgw2022-09-26

Actions
action #117949: Apply workaround to force screen refresh on YaST Qt windowResolvedrainerkoenig2022-10-11

Actions
action #118336: Enhance code to make sure boot_to_desktop work for ppc64le Resolvedgeor2022-10-31

Actions
action #118993: Split register_extensions_and_modules to handle separately additional registrationResolvedtinawang1232022-10-18

Actions
action #119515: Wrong entry selected in grub menu after migration with AutoYaSTResolvedtinawang1232022-10-28

Actions
action #119581: Track: how to distinguish these tags(bootloader, grub, inst-bootmenu) in needlesResolvedgeor2022-10-31

Actions
action #119584: Improve workaround for processing the last item for pattern selectionResolvedgeor2022-10-31

Actions
action #119656: [Timebox: 8h] Try to increase RAM to settle the loadResolvedjgwang2022-11-01

Actions
action #119662: openldap_to_389ds module failed because of dependency issueResolvedsyrianidou_sofia2022-11-01

Actions
action #120013: Install open-iscsi package in iscsi_clientResolvedgeor2022-11-07

Actions
action #120049: Adapt openqa test setting for SLES 15 SP3 LTSS in MigrationResolvedzoecao2022-11-08

Actions
action #120079: test fails in ibft as it is expecting an IPv4 address where a hostname is provided after #109241Resolvedgeor2022-11-08

Actions
action #120100: Change validation for verifying secure boot after jsc#PED-1409Resolvedgeor2022-11-08

Actions
action #120142: Ensure access to console in s390x kvm instance over sshResolvedgeor2022-11-08

Actions
action #120354: Move case rmt_server_install to a milestone flavorResolvedzoecao2022-11-14

Actions
action #120411: Apply firewall restart after each command that change configuration only in SLEResolvedtinawang1232022-11-14

Actions
action #120429: Increase timeout when checking if YaST logs can be uploadedResolvedgeor2022-11-15

Actions
action #120444: Revisit wrong settings for HA migrationsResolvedtinawang1232022-11-15

Actions
action #120450: Call conditionally systemd-vconsole-setup before accessing virtual consoles to avoid wrong visualization with ncursesRejected2022-11-15

Actions
action #120639: Fix check for network restart in yast2_lan_restart* test modulesResolvedzoecao2022-11-16

Actions
action #120711: Move the "disable_installation_repos" ahead of registration for online migration casesResolvedzoecao2022-11-18

Actions
action #120714: [Research 24h] Investigate test fails in iscsi_client with wrong exit codeResolvedcoolgw2022-11-18

Actions
action #120831: [Research: 16h] Research recent iscsi failuresResolvedcoolgw2022-11-22

Actions
action #120838: Move autoyast_create_hdd_gnome from Functional to YaST groupResolvedtinawang1232022-11-22

Actions
action #120852: Move ssh-X@ppc64le-hmc-single-disk to YaST development job groupResolvedtinawang1232022-11-22

Actions
action #120858: Configure all PowerVM test suite to use `START_AFTER_TEST` with some chosen basic PowerVM test suite per flavorResolvedzoecao2022-11-23

Actions
action #121021: upgrade_snapshots fails in post_run_hook due to no promptResolvedJRivrain2022-11-28

Actions
action #121618: Fix the unexpected return value for dhcp-server of install_serviceResolvedrainerkoenig2022-12-07

Actions
action #121648: Make stable 'yast2-keyboard-ui' in YaSTResolvedtinawang1232022-12-07

Actions
action #121912: Create test suite to configure support server for SLE 15 SP4Resolvedzoecao2022-12-13

Actions
action #121948: yast2_rmt not build for i586Resolvedgeor2022-12-14

Actions
action #122020: Try if spvm console can help with the sporadic issues found for PowerVMResolvedhjluo2022-12-15

Actions
action #122167: Move all svirt-xen-pv scenarios booting in graphical mode to Develpmet job groupResolvedhjluo2022-12-19

Actions
action #122206: Avoid booting from snapshot in PowerKVM for migrationsResolvedsyrianidou_sofia2022-12-20

Actions
action #122224: yast2_lan_restart_vlan fails due to change in devices orderResolvedrainerkoenig2022-12-20

Actions
action #122227: Clean up 'Migration: HA' job groupResolvedzoecao2022-12-20

Actions
action #122794: Add yast log error 'Invalid path .value."eth0".NAME' as known errorResolvedsyrianidou_sofia2023-01-06

Actions
action #122851: Increase timeout in yast2_clone_system for aarch64Resolvedsyrianidou_sofia2023-01-09

Actions
action #122977: Adapt SLE 15 SP3 for LTSS in YaST MaintenanceResolvedtinawang1232023-01-12

Actions
action #123067: In text mode, send_key home cannot work at s390xResolvedleli2023-01-13

Actions
action #123076: Unify qam-yast_self_update+15@uefi for sle15sp3 and sle15sp4 using single test module for registrationResolvedtinawang1232023-01-13

Actions
action #123145: [Research 8h] Ensure screensaver is not trigger in yast2_software_managementResolvedJRivrain2023-01-16

Actions
action #123394: Fix the hibernation_enabled issue on aarch64ResolvedJRivrain2023-01-19

Actions
action #123418: Use IP instead of WORKER_HOSTNAME when expanding variables with AutoYaST in iscsi scenarioResolvedsyrianidou_sofia2023-01-20

Actions
action #123424: Adapt AutoYaST logic to run with ncurses in powervmResolvedleli2023-01-20

Actions
action #123427: Avoid erasing disk in modify_existing_partition in PowerVM or remove scenarioRejected2023-01-20

Actions
action #123460: Provide workaround for iscsi failure bsc#1207157Resolvedgeor2023-01-20

Actions
action #123646: Run statistical investigation regarding RAM/CPU for Installer regarding bsc#1207284ResolvedJRivrain2023-01-25

Actions
action #123691: Add installation in staging with VIDEOMODE text modeResolvedzoecao2023-01-26

Actions
action #123739: Default config now written to /etc/chrony.d/poolsResolvedshukui2023-01-27

Actions
action #123924: Drop yast2-soundResolvedrainerkoenig2023-02-03

Actions
action #124038: Provide correct schedule for test suite guided_ext4Resolvedhjluo2023-02-07

Actions
action #124047: Switch to backend spvm backend for YaST and Migration job groupsResolvedJRivrain2023-02-07

Actions
action #124140: Handle additional popup for non-free license in SLE 15 SP4Resolvedsyrianidou_sofia2023-02-08

Actions
action #124158: open-iscsi now uses /var/lib/iscsi, no longer /etc/iscsiResolvedshukui2023-02-09

Actions
action #124361: Add YAML_SCHEDULE_DEFAULT per test suite instead of as defaultResolvedhjluo2023-02-13

Actions
action #124367: Need update 'YAML_SCHEDULE' file, it should be used with 'YAML_SCHEDULE_DEFAULT'Resolvedtinawang1232023-02-13

Actions
action #124418: License screen in s390x is using different UI controls now that SUMA is not thereResolvedhjluo2023-02-14

Actions
action #124421: Unschedule test modules after sapconf in SAP migrationResolvedJRivrain2023-02-14

Actions
action #124427: Need update autoyast profile as bsc#1208174Resolvedshukui2023-02-14

Actions
action #124433: drop test yast2_http: yast module has been removedResolvedleli2023-02-14

Actions
action #124511: License agreement only showed once for migrations SLE 15 SP5 for s390x due to not SUMA displayedResolvedleli2023-02-15

Actions
action #124514: Fix msdos_partition_table providing reasonable test dataResolvedJRivrain2023-02-15

Actions
action #124574: Fix PowerVM incomplete job and disk selection with correct configurationResolvedrainerkoenig2023-02-15

Actions
action #124583: Ensure to press next in nis_serverResolvedtinawang1232023-02-15

Actions
action #124586: Update test data due to spvm worker seems to have less disk sizeResolvedJRivrain2023-02-15

Actions
action #124592: Increase timeout for yast2_software_managementResolvedhjluo2023-02-15

Actions
action #124610: Catch regression when sending right key when switching to tab Bootloader Options in ncursesResolvedtinawang1232023-02-15

Actions
action #124676: Ensure all test modules in staging are using libyui-rest-apiResolvedrainerkoenig2023-02-16

Actions
action #124781: Fix "DESKTOP" : "textmode" after moving to spvmResolvedleli2023-02-20

Actions
action #124787: Address some refactor for the workaround issue bsc#1207157Resolvedleli2023-02-20

Actions
action #124811: Add an offline AutoYast scenario (full media no registration) in YaST job groupResolvedzoecao2023-02-20

Actions
action #124856: Need set MIGRATION_METHOD correctlyResolvedleli2023-02-21

Actions
action #124862: Fix check_system_info related issuesResolvedrainerkoenig2023-02-21

Actions
action #124874: Update 'Migration: other test' job group and trigger with PublicBetaResolvedtinawang1232023-02-21

Actions
action #124889: Avoid removing official repos and add openQA repos twice in aarch Leap 15.5Resolvedleli2023-02-21

Actions
action #124916: Resolve conflicts for SMT cases in migration milestone groupResolvedrainerkoenig2023-02-22

Actions
action #124964: Replace the leap cases with leap15.5 in Migration: Others job groupResolvedhjluo2023-02-23

Actions
action #124967: Remove the continuous migration cases starting from 15GA in Migration: others job groupResolvedtinawang1232023-02-23

Actions
action #124985: Workaround refreshment issue poo#124652 with existing workaround or using libyui-rest-apiResolvedleli

Actions
action #125018: Fix mismatched parameter error in bootloader parametersResolvedgeor2023-02-24

Actions
action #125024: Check migration with AutoYaST which never workedRejectedleli2023-02-24

Actions
action #125036: Remove soft-failure for bsc#1083486 in yast2_nfs_serverResolvedshukui2023-02-24

Actions
action #125069: Remove soft-failure bsc#1195046Resolvedshukui2023-02-27

Actions
action #125078: Bypass collecting logs where we fail doing network checkResolvedgeor2023-02-27

Actions
action #125099: Update cases to use RMT server instead of SMT server to do register at milestone job groupResolvedleli2023-02-28

Actions
action #125105: Remove additional test modules scheduled by main.pm after regression migrationResolvedleli2023-02-28

Actions
action #125348: No bounce back then display manager can't be shownResolvedtinawang1232023-03-03

Actions
action #125351: Need update test code to select option and close dialog of language-change-required-update-folderResolvedleli2023-03-03

Actions
action #125717: [sporadic] test fails in openldap_to_389dsResolvedtinawang1232023-03-09

Actions
action #125741: Apply workaround and unmount first before ending iscsi session (only for SLE 15 SP5)Resolvedleli2023-03-10

Actions
action #125753: Retry command in iscsi_configuration to list the iscsi disk before wiping itResolvedcoolgw2023-03-10

Actions
action #125777: Fix HA mapping in check_system_infoResolvedrainerkoenig2023-03-10

Actions
action #125786: Fix ONLINE_MIGRATION on job group levelResolvedshukui2023-03-10

Actions
action #125804: [sporadic] Increase timeout execution in the Continuos migration scenariosResolvedhjluo2023-03-11

Actions
action #125807: Try out if error in orphaned_packages_check goes away using fresh interactive installationResolvedsyrianidou_sofia2023-03-11

Actions
action #125849: Duplicate AutoYaST job to create gnome image for SAP horizontal migrationResolvedzoecao2023-03-13

Actions
action #125891: Apply workaround of bsc#1195046 for all archesResolvedleli2023-03-13

Actions
action #125894: Bypass collecting logs where we fail doing network check - Part 2Resolvedzoecao2023-03-13

Actions
action #125927: Need wait more time for grub2 during continuous migration testResolvedzoecao2023-03-14

Actions
action #125933: Update setting to fix test fails in reboot_to_upgrade for continuous migrationResolvedleli2023-03-14

Actions
action #125954: Workaround refreshment issue poo#124652 in iscsi_server for SLE 15 SP5 onlyResolvedleli2023-03-14

Actions
action #125957: Bump timeout in yast2_kdump_use_fadumpResolvedleli2023-03-14

Actions
action #125963: Correct wrong settings DROPPED_MODULES in Misc. scenarioResolvedtinawang1232023-03-14

Actions
action #125969: Wrong setting in Misc. scenario in boot_to_desktop for spvmResolvedtinawang1232023-03-14

Actions
action #125999: Ensure to select bond port yast2_lan_restart_bondResolvedshukui2023-03-14

Actions
action #126107: Remove RETRY in power KVM jobs for Yam job groupsResolvedhjluo2023-03-16

Actions
action #126125: As disk space limit, we need reduce modules for regression migration cases at powerVMResolvedhjluo2023-03-17

Actions
action #126128: Move online_sles15sp2_pscc_basesys-srv-desk-dev_rmt_all_full from Migration Misc to Migration Milestone job groupResolvedhjluo2023-03-17

Actions
action #126143: Try out different ipmi machine in Yam job groupResolvedsyrianidou_sofia2023-03-17

Actions
action #126227: Wrong mount point for swap in autoyast_home_encrypted.xmlResolvedshukui2023-03-20

Actions
action #126293: Change WORKER_CLASS from 390-kvm-sle{12,15} to s390-kvmResolvedsyrianidou_sofia2023-03-21

Actions
action #126344: Fix failures on force_scheduled_tasks on s390xResolvedsyrianidou_sofia2023-03-22

Actions
action #126599: Adapt oudated soft-failure bsc#1097111Resolvedleli2023-03-24

Actions
action #126602: Verify workaround for bsc#1129504 is not needed anymoreResolvedleli2023-03-24

Actions
action #126605: Replace record_softfailure by record_info in zypper_lifecycleResolvedleli2023-03-24

Actions
action #126608: Adapt oudated soft-failure bsc#1163000Resolvedsyrianidou_sofia2023-03-24

Actions
action #126611: Remove soft-failure in force_scheduled_tasks for bsc#1178761Resolvedleli2023-03-24

Actions
action #126617: [sporadic] Investigate exportfs in yast2_nfs_serverResolvedshukui2023-03-24

Actions
action #126620: Add stop_timeout_system_reboot_now after perform_installation for svirt-xen-pv Resolvedhjluo2023-03-24

Actions
action #126770: [sporadic] Investigate what trigger authentication screen in first_bootResolvedtinawang1232023-03-28

Actions
action #126788: Change soft-failure to record_info if still needed in iscsi_serverResolvedcoolgw2023-03-28

Actions
action #127103: test fails in yast2_system_settingsResolvedshukui2023-04-03

Actions
action #127202: KDE desktop runner not match, suspect needle issueResolvedrainerkoenig2023-04-04

Actions
action #127451: Enable lvm-encrypt-separate-boot, lvm-full-encrypt and lvm_thin_provisioning in Tumbleweed and Leap for aarch64Resolvedcoolgw2023-04-10

Actions
action #127463: Handle additional popup for non-free license in SLE 15 SP4Rejected2023-04-11

Actions
action #127499: Fix code for apply_workaround_poo124652Resolvedrainerkoenig2023-04-11

Actions
action #127583: Errors on validation of AutoYaST profile, need to fix to /mount instead of mountResolvedleli2023-04-13

Actions
action #127604: Ensure installing packages finishes in yast2_software_managementResolvedsyrianidou_sofia2023-04-13

Actions
action #127607: Ensure we click on Add button in Network SettingsResolvedleli2023-04-13

Actions
action #127715: Need wait more time for 'startupdate'Resolvedleli2023-04-17

Actions
action #127856: test fails in yast2_cmdline: yast2-http-server has been removed from TW in FebruaryRejectedleli2023-04-18

Actions
action #127976: Bump timeout for mediacheck in aarch64Resolvedcoolgw2023-04-19

Actions
action #128024: Create autoyast installation testsuite to publish uefi image SLES-15-SP3-aarch64-uefi-updated.qcow2Resolvedtinawang1232023-04-20

Actions
action #128054: Move continuous migration scenarios of 15SP1 to Development: Migration: SLE15-SP5 job groupRejected2023-04-20

Actions
action #128150: Fix the wickedd.service checking issueResolvedtinawang1232023-04-21

Actions
action #128609: Adapt raid_gpt to not expect chunk size screenResolvedsyrianidou_sofia2023-05-03

Actions
action #128621: [sporadic] Ensure to process grub from tianocoreResolvedleli2023-05-03

Actions
action #128645: SAP migration tests need to stop using cirrusResolvedleli2023-05-04

Actions
action #128648: [Timebox:8h][sporadic] Investigate export failure in yast2_nfs_serverResolvedleli2023-05-04

Actions
action #128687: Apply workaround yast2_security due to graphical glitchResolvedJRivrain2023-05-04

Actions
action #128690: test fails in check_migration_features due to python310 missingResolvedtinawang1232023-05-04

Actions
action #128693: [sporadic][timebox: 24h] autoyast zVM test fails in installationResolvedleli2023-05-04

Actions
action #128981: Run comparable test for the YaST glitch passing in O3 in OSDResolvedsyrianidou_sofia2023-05-09

Actions
action #129017: Create temp schedules for staging C to pass without betaRejected2023-05-10

Actions
action #129020: Prepare for GMC removing of beta popup in interactive installation Resolvedzoecao2023-05-10

Actions
action #129547: Set networking section with explicit eth0 defined in autoyast profile to avoid complicated output issue for wickedResolvedcoolgw2023-05-18

Actions
action #129997: Increase timeout in yast2_expert_partitioner for sle 15 sp5Resolvedtinawang1232023-05-29

Actions

Related issues 1 (0 open1 closed)

Related to qe-yam - coordination #121957: [saga] Consolidation of test coverage in Yam squadResolvedJERiveraMoya2022-03-25

Actions
Actions #1

Updated by JERiveraMoya about 1 year ago

  • Description updated (diff)
Actions #2

Updated by JERiveraMoya about 1 year ago

Actions #3

Updated by JERiveraMoya about 1 year ago

  • Tags deleted (qe-yam-refinement)
Actions #4

Updated by JERiveraMoya 10 months ago

  • Parent task set to #121957
Actions #5

Updated by JERiveraMoya 10 months ago

  • Parent task deleted (#121957)
Actions #6

Updated by JERiveraMoya 10 months ago

Actions #7

Updated by JERiveraMoya 9 months ago

  • Subject changed from [epic] Handle openQA review failures in Yam squad to [epic] Handle openQA review failures in Yam squad - SLE 15 SP5
Actions #8

Updated by JERiveraMoya 9 months ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF