Project

General

Profile

Actions

action #121948

closed

coordination #121876: [epic] Handle openQA review failures in Yam squad - SLE 15 SP5

yast2_rmt not build for i586

Added by dimstar about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
2022-12-14
Due date:
% Done:

0%

Estimated time:

Description

Observation

With the split of i586 to be its own port, the test suite is being aligned to be a bit more realistic for that userbase.
During the test phase we have identified that the yast2_ncurses test suite unconditionally includes yast2-rmt, even though this package does not build on i586.

We should thus only load the module on supported architects.
For reference, the yast2-rmt.spec contains

ExcludeArch synced with our main dependency: rmt-server

ExcludeArch: %{ix86} s390

openQA test in scenario opensuse-Tumbleweed-LegacyX86-NET-i586-yast2_ncurses@32bit fails in
yast2_rmt

Test suite description

Maintainer: qsf-y Test for yast2 UI, ncurses only. Running on created gnome images which provides both text console for ncurses UI tests as well as the gnome environment for the GUI tests.
riafarov set TIMEOUT_SCALE to improve stability of the test.

Reproducible

Fails since (at least) Build 20221213 (current job)

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

Actions #1

Updated by maritawerner about 1 year ago

  • Project changed from openQA Tests to qe-yam
  • Category deleted (Bugs in existing tests)
Actions #2

Updated by dimstar about 1 year ago

  • Status changed from New to Resolved
Actions #3

Updated by dimstar about 1 year ago

  • Status changed from Resolved to New

Need to re-open this.. the previous provided fix is not wrong - but does not apply to the test referenced here. That one actually uses a yaml schedule: https://openqa.opensuse.org/tests/2955359/settings/schedule/yast/opensuse/yast2_ncurses/yast2_ncurses.yaml

Actions #4

Updated by JERiveraMoya about 1 year ago

  • Status changed from New to Workable
  • Target version set to Current

We could use:

settings:
  # yast2-rmt not build for i586
  EXCLUDE_MODULES: yast2-rmt
Actions #5

Updated by JERiveraMoya about 1 year ago

  • Subject changed from test fails in yast2_rmt on i586: yast2-rmt does not exist there to yast2_rmt not build for i586
Actions #6

Updated by JERiveraMoya about 1 year ago

  • Parent task set to #121876
Actions #7

Updated by geor about 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to geor
Actions #9

Updated by geor about 1 year ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF