Project

General

Profile

Actions

action #124140

closed

coordination #121876: [epic] Handle openQA review failures in Yam squad - SLE 15 SP5

Handle additional popup for non-free license in SLE 15 SP4

Added by vsvecova about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Urgent
Target version:
Start date:
2023-02-08
Due date:
% Done:

0%

Estimated time:

Description

Observation

This issue had already been reported in the past as https://bugzilla.suse.com/show_bug.cgi?id=1206560, but it had been greenlit by Marcus as intended and the update pushed back in the testing queue.

openQA test in scenario sle-15-SP4-Server-DVD-Updates-x86_64-qam-yast_self_update+15@64bit fails in
confirm_installation

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. self update test for Maintenance Updates under test

Reproducible

Fails since (at least) Build 20230207-1

Expected result

Last good: 20230206-1 (or more recent)

Further details

Always latest result in this scenario: latest


Files

Screenshot from 2023-02-10 13-44-08.png (41.2 KB) Screenshot from 2023-02-10 13-44-08.png Requests of incident 27240 in Smelt vsvecova, 2023-02-10 12:45
Actions #1

Updated by JERiveraMoya about 1 year ago

  • Project changed from openQA Tests to qe-yam
  • Category deleted (Bugs in existing tests)
  • Status changed from New to In Progress
  • Assignee set to syrianidou_sofia
  • Target version set to Current
  • Parent task set to #121876
Actions #2

Updated by syrianidou_sofia about 1 year ago

The last build doesn't include the java license popup. it seems that the update here was revoked: https://smelt.suse.de/request/286827/
It seems though that we should expect it to reappear so putting the fix on hold, until further updates.

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/16346

Actions #3

Updated by vsvecova about 1 year ago

Hi Sofia, the old one (S:M:27240:286827) was revoked in the past, but there is a new one (S:M:27240:289508) which is still in the testing queue at the moment:
https://build.suse.de/request/show/289508
https://smelt.suse.de/request/289508/

It doesn't explain why the dialog window disappeared, but the reason is not because it would be revoked.

Actions #4

Updated by JERiveraMoya about 1 year ago

  • Status changed from In Progress to Workable
Actions #5

Updated by JERiveraMoya about 1 year ago

  • Tags set to qe-yam-refinement
  • Target version deleted (Current)
Actions #6

Updated by JERiveraMoya about 1 year ago

  • Target version set to Current
Actions #7

Updated by JERiveraMoya about 1 year ago

  • Target version deleted (Current)
Actions #8

Updated by JERiveraMoya about 1 year ago

  • Subject changed from [qe-yam] test fails in confirm_installation - new license pop up for java-1_8_0-ibm to Handle additional popup for non-free license in SLE 15 SP4
  • Status changed from Workable to In Progress
  • Priority changed from Normal to Urgent
  • Target version set to Current
Actions #9

Updated by JERiveraMoya about 1 year ago

  • Tags deleted (qe-yam-refinement)
Actions #10

Updated by JERiveraMoya about 1 year ago

PR: <branch-deleted-pr-to-be-recreated>

Actions #12

Updated by syrianidou_sofia almost 1 year ago

  • Status changed from In Progress to Resolved

tests pass and there is follow up ticket : https://progress.opensuse.org/issues/127529

Actions #13

Updated by syrianidou_sofia 12 months ago

  • Status changed from Resolved to In Progress

new failure for sp4 tests with legacy and minimal pattern

Actions #14

Updated by rainerkoenig 12 months ago

We now have 4 failures in Maintenance Updates:

The problem in this case is that we don't even have PATTERNS defined. So maybe the assumption to determine if a license popup should apperar or not can't rely on PATTERNS. Maybe we should just check_screen if we see a license popup and if so handle it, if not just proceed.

Actions #15

Updated by syrianidou_sofia 12 months ago

  • Status changed from In Progress to Resolved
Actions #16

Updated by JERiveraMoya 12 months ago

  • Status changed from Resolved to In Progress
Actions #18

Updated by syrianidou_sofia 12 months ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF