Project

General

Profile

Actions

coordination #42854

closed

[functional][y][epic] Introduce relevant installation validation test modules

Added by riafarov over 5 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2018-10-24
Due date:
2021-10-26
% Done:

100%

Estimated time:
(Total: 138.00 h)

Description

Motivation

We have a lot of different scenarios, where we validate the setup using same or similar set of test suites, which indirectly assure functional properties of the system, but is not most efficient way.
For example, in INSTALL_ONLY test suites we only check that system can boot, which is already good, but misses validation of the part of the system which is different to the "default".
Could of examples: GPT test suite doesn't check partitioning table,
USBintstall should validate the only difference which is repo from mounted usb

Acceptance criteria

  1. All INSTALL_ONLY scenarios have relevant validation test module(s) for specific scenario enabled
  2. Default set of test modules (x11 and console tests) is executed only for some scenarios and relevant test modules are implemented to assure functional properties of the system

Subtasks 35 (0 open35 closed)

action #42848: [sle][functional][y] Do not trigger not relevant user space tests in lvm_thin_provisioningResolvedriafarov2018-10-242018-11-20

Actions
action #42917: [sle][functional][y] Introduce only relevant tests modules for USBinstall test suiteResolvedJERiveraMoya2018-10-252018-12-03

Actions
action #52418: [functional][y] Validate setup in lvm+RAID1 test suiteResolvedybonatakis2019-05-312019-10-08

Actions
action #57794: [functional][y] Validate crypt_no_lvm test suiteResolvedJERiveraMoya2019-10-082019-11-19

Actions
action #58909: [functional][y] Validate ext4 installationResolvedsyrianidou_sofia2019-10-312019-12-17

Actions
action #58912: [functional][y] Validate gpt installationResolvedJRivrain2019-10-312020-02-11

Actions
action #63328: [functional][y] Enable validation for cryptlvm+activate_existingResolvedybonatakis2020-02-102020-03-24

Actions
action #64911: [functional][y] Validate only relevant parts of lvm+resize_rootResolvedybonatakis2020-03-272020-05-05

Actions
action #65349: [functional][y][timeboxed:16h] Add validation module for nis mm testsResolvedsyrianidou_sofia2020-04-062020-06-02

Actions
action #67126: [functional][y] Add validation module for nis mm testsResolvedsyrianidou_sofia2020-05-212020-06-30

Actions
action #67579: [functional][y] Add validation for addon-module-http and addon-module-ftpResolvedriafarov2020-06-022020-06-30

Actions
action #68386: [functional][y] Add validation for cryptlvm+activate_existing+import_users ResolvedJERiveraMoya2020-06-242020-07-14

Actions
action #68398: [functional][y] Add validation for autoyast_lvmResolvedJRivrain2020-06-242020-07-28

Actions
action #68773: [functional][y] Add validation for autoyast_miniResolvedJERiveraMoya2020-07-082020-07-28

Actions
action #68803: [functional][y] Add validation for autoyast_reinstallResolvedsyrianidou_sofia2020-07-092020-07-28

Actions
action #68962: [functional][y] Add validation to cryptlvm+activate_existing scenarioResolvedoorlov2020-07-142020-07-28

Actions
action #69040: [functional][y] Add validation to cryptlvm+cancel_existing scenarioResolvedybonatakis2020-07-162020-08-25

Actions
action #69043: [y] Enable validation for dud_development_toolsResolvedoorlov2020-07-162020-08-11

Actions
action #69046: [y] Add validation to lvm+cancel_existing_cryptlvmResolvedJRivrain2020-10-01

Actions
action #69049: [y] Add validation to minimal+role_minimal scenarioResolvedriafarov2020-07-162020-08-25

Actions
action #69196: [y] Add validation to multipath scenarioResolvedJERiveraMoya2020-07-162020-08-25

Actions
action #69199: [y] Schedule only relevant checks for remote_ssh_target_ftp test suiteResolvedybonatakis2020-07-222020-08-25

Actions
action #69217: [y] Add validation to nvme scenarioResolvedybonatakis2020-07-222020-08-25

Actions
action #69220: [y] Validate ftp mirror repo in remote_ssh_target_ftp scenarioResolvedybonatakis2020-07-222020-08-11

Actions
action #69223: [y] Add validation to remote_vnc_target_nfs scenarioClosedsyrianidou_sofia2020-07-22

Actions
action #69226: [y] Add validation to xfs scenarioResolvedybonatakis2020-07-222020-08-11

Actions
action #69229: [y] Add validation to zfcpResolvedJERiveraMoya2020-07-222020-09-22

Actions
action #69238: [y] Add validation for yast_self_update and yast_no_self_update Resolvedriafarov2020-08-042020-09-08

Actions
action #69583: [y] Create repository for 'self_update' featureResolvedybonatakis2020-08-042020-08-25

Actions
action #72061: [y] Add validation to autoyast_multipathClosedriafarov2020-09-292021-10-26

Actions
action #72172: [functional][y] Make sure we are validating the right device in validate_encrypted_partition_not_activatedClosedJERiveraMoya2020-10-01

Actions
action #80780: Add validation to ssh-X scenarioClosedJRivrain2020-12-07

Actions
action #80784: Add validation to repo_inst scenarioResolvedsyrianidou_sofia2020-12-07

Actions
action #80786: Add validation to offline_install+skip_registration scenarioClosedriafarov2020-12-07

Actions
action #88045: Add validation to skip_registration scenarioClosedJERiveraMoya2021-01-20

Actions

Related issues 1 (0 open1 closed)

Related to openQA Tests - coordination #42494: [epic][functional][y] Split/adapt scenarios to move installer related part to YaST specific job groupResolvedriafarov2018-10-252019-11-19

Actions
Actions #1

Updated by okurz over 5 years ago

  • Category set to New test

Please try to always assign a category

Actions #2

Updated by riafarov about 5 years ago

  • Is duplicate of coordination #42494: [epic][functional][y] Split/adapt scenarios to move installer related part to YaST specific job group added
Actions #3

Updated by riafarov about 5 years ago

  • Is duplicate of deleted (coordination #42494: [epic][functional][y] Split/adapt scenarios to move installer related part to YaST specific job group)
Actions #4

Updated by riafarov about 5 years ago

  • Blocked by coordination #42494: [epic][functional][y] Split/adapt scenarios to move installer related part to YaST specific job group added
Actions #5

Updated by riafarov about 5 years ago

  • Target version changed from Milestone 22 to Milestone 25

We should proceed with split first as already address same motivation for the test scenarios. After that we should check if anything still remains.

Actions #6

Updated by okurz about 5 years ago

  • Due date changed from 2018-12-04 to 2018-12-18

due to changes in a related task

Actions #7

Updated by JERiveraMoya about 5 years ago

  • Due date changed from 2018-12-18 to 2018-12-03

due to changes in a related task

Actions #8

Updated by riafarov about 5 years ago

  • Blocked by deleted (coordination #42494: [epic][functional][y] Split/adapt scenarios to move installer related part to YaST specific job group)
Actions #9

Updated by riafarov over 4 years ago

  • Target version changed from Milestone 25 to Milestone 27
Actions #10

Updated by riafarov over 4 years ago

  • Due date changed from 2019-07-09 to 2019-07-30

due to changes in a related task

Actions #11

Updated by riafarov over 4 years ago

  • Due date changed from 2019-07-30 to 2019-08-13

due to changes in a related task

Actions #12

Updated by riafarov over 4 years ago

  • Due date changed from 2019-08-13 to 2019-08-27

due to changes in a related task

Actions #13

Updated by riafarov over 4 years ago

  • Due date changed from 2019-08-27 to 2019-09-10

due to changes in a related task

Actions #14

Updated by riafarov over 4 years ago

  • Due date changed from 2019-09-10 to 2019-09-24

due to changes in a related task

Actions #15

Updated by mgriessmeier over 4 years ago

  • Target version changed from Milestone 27 to Milestone 28
Actions #16

Updated by JERiveraMoya over 4 years ago

  • Due date changed from 2019-09-24 to 2019-10-08

due to changes in a related task

Actions #17

Updated by riafarov over 4 years ago

  • Related to coordination #42494: [epic][functional][y] Split/adapt scenarios to move installer related part to YaST specific job group added
Actions #18

Updated by riafarov over 4 years ago

  • Due date changed from 2019-10-22 to 2019-11-05

due to changes in a related task

Actions #19

Updated by riafarov over 4 years ago

  • Target version changed from Milestone 28 to Milestone 30+
Actions #20

Updated by riafarov over 4 years ago

  • Due date changed from 2019-11-19 to 2019-12-03

due to changes in a related task

Actions #21

Updated by riafarov over 4 years ago

  • Due date changed from 2019-12-03 to 2019-12-17

due to changes in a related task

Actions #22

Updated by riafarov about 4 years ago

  • Due date changed from 2019-12-17 to 2020-01-28

due to changes in a related task

Actions #23

Updated by mgriessmeier about 4 years ago

  • Target version changed from Milestone 30+ to Milestone 30

bulk moved to M30 for revisiting

Actions #24

Updated by riafarov about 4 years ago

  • Due date changed from 2020-01-28 to 2020-02-11

due to changes in a related task

Actions #25

Updated by riafarov almost 4 years ago

  • Due date changed from 2020-04-21 to 2020-05-05

due to changes in a related task: #64911

Actions #26

Updated by riafarov almost 4 years ago

  • Due date changed from 2020-05-19 to 2020-06-02

due to changes in a related task: #65349

Actions #27

Updated by riafarov almost 4 years ago

  • Status changed from New to In Progress
  • Assignee set to riafarov
  • Target version changed from Milestone 30 to SLE 15 SP2
Actions #28

Updated by riafarov almost 4 years ago

  • Parent task deleted (#40475)
Actions #29

Updated by riafarov over 3 years ago

  • Due date changed from 2020-06-02 to 2020-06-16

due to changes in a related task: #67579

Actions #30

Updated by riafarov over 3 years ago

  • Due date changed from 2020-06-16 to 2020-06-30

due to changes in a related task: #67579

Actions #31

Updated by riafarov over 3 years ago

  • Due date changed from 2020-06-30 to 2020-07-14

due to changes in a related task: #68386

Actions #32

Updated by riafarov over 3 years ago

  • Target version changed from SLE 15 SP2 to SLE 15 SP3
Actions #33

Updated by riafarov over 3 years ago

  • Due date changed from 2020-07-14 to 2020-07-28

due to changes in a related task: #68773

Actions #34

Updated by riafarov over 3 years ago

  • Due date changed from 2020-07-28 to 2020-08-11

due to changes in a related task: #69040

Actions #35

Updated by riafarov over 3 years ago

  • Due date changed from 2020-08-11 to 2020-08-25

due to changes in a related task: #69046

Actions #36

Updated by riafarov over 3 years ago

  • Due date changed from 2020-08-25 to 2020-09-08

due to changes in a related task: #69229

Actions #37

Updated by JERiveraMoya over 3 years ago

  • Due date changed from 2020-09-08 to 2020-09-22

due to changes in a related task: #69229

Actions #38

Updated by riafarov over 3 years ago

  • Status changed from In Progress to Blocked
Actions #39

Updated by riafarov over 3 years ago

  • Project changed from openQA Tests to qe-yam
  • Category deleted (New test)
Actions #40

Updated by riafarov over 3 years ago

  • Project changed from qe-yam to openQA Tests
Actions #41

Updated by szarate over 3 years ago

  • Tracker changed from action to coordination
  • Status changed from Blocked to New
Actions #43

Updated by riafarov over 3 years ago

  • Project changed from openQA Tests to qe-yam
  • Status changed from New to In Progress
Actions #44

Updated by riafarov about 3 years ago

  • Status changed from In Progress to Resolved
Actions #45

Updated by riafarov almost 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF