Project

General

Profile

coordination #9576

[epic][opensuse][sle][functional][y] VNC+SSH Installations

Added by RBrownSUSE about 6 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
New test
Target version:
Start date:
2019-05-29
Due date:
2020-03-24
% Done:

100%

Estimated time:
(Total: 18.00 h)
Difficulty:

Description

Motivation

I as a RM would like to be assured that remote installations using VNC and ssh are possible and work.

Acceptance criteria

  1. VNC and ssh remote installations are covered by automated test in openQA

Adding following settings should work for MM:
NICTYPE=tap
WORKER_CLASS=qemu_x86_64,tap


Checklist

  • SLE
  • TW
  • Leap

Subtasks

action #52310: [functional][y] Enable remote installation over VNC for openSUSEResolvedybonatakis

action #62096: [functional][y][opensuse][timeboxed:16h] remote intallation doesnt communicate correctly after rebootResolvedybonatakis

action #62498: [functional][y][opensuse] Update support_server on o3 for remote installations ResolvedJERiveraMoya

action #63247: [functional][y] File a bug regarding remote VNC installation on TW and enable in the main job groupResolvedriafarov

action #56006: [functional][y][Timebox:24] Fix remote installation over ssh for openSUSEResolvedriafarov

action #63910: [functional][y][sporadic] test fails in remote_controller - ends up on unexpected gdm screenResolvedriafarov


Related issues

Related to openQA Tests - action #7614: sle12 - figure out/impliment ssh+X, ssh+noX, and vnc installationsResolved2015-05-22

Related to qe-yast - coordination #66394: [epic][y] Enable VNC+SSH Installations on aarch64Closed2020-07-072020-10-20

Blocked by openQA Tests - action #30892: [opensuse][tools]multi-machine worker setupResolved2018-01-29

History

#2 Updated by okurz about 6 years ago

  • Subject changed from VNC+SSH Instalaltions to VNC+SSH Installations

#3 Updated by coolo almost 6 years ago

I don't see any blockage by that other issue - you can do VNC+SSH even on localhost

#4 Updated by coolo almost 6 years ago

IMO you have 2 ways to do implement this with KVM:

1) extend qemu backend to allow -kernel, -append and -initrd being passed. The rest looks like bootloader_zkvm.pm
2) fake the headless and use qemu's VNC to type install=.... into the isolinux screen and after that select_console('remotessh')

in both ways you don't need multi machine support. MM only gets into the play if you wanted PXE or alike.

#5 Updated by RBrownSUSE almost 6 years ago

coolo wrote:

IMO you have 2 ways to do implement this with KVM:

1) extend qemu backend to allow -kernel, -append and -initrd being passed. The rest looks like bootloader_zkvm.pm

I like this solution because it sounds simple and is closer to what people do with PXE servers (and as we don't provide an 'official' PXE solution, I'd rather test the 'core' functionality works by loading -kernel -initrd, etc)

2) fake the headless and use qemu's VNC to type install=.... into the isolinux screen and after that select_console('remotessh')

I like this idea also - and I wouldn't call it 'faking' if we used the mini-ISO (aka NET ISO) as for that ISO you NEED to supply install= in order for it to work

And right now we have no coverage on the mini-ISO

in both ways you don't need multi machine support. MM only gets into the play if you wanted PXE or alike.

Yeah I see that now

#6 Updated by RBrownSUSE almost 6 years ago

  • Checklist item changed from to [ ] SLE, [ ] TW, [ ] Leap
  • Target version deleted (154)

#7 Updated by mkravec over 5 years ago

  • Assignee set to mkravec

#8 Updated by mkravec over 5 years ago

  • % Done changed from 0 to 80

#9 Updated by mkravec over 5 years ago

TODO - Fix: Test is not waiting for response long enough
https://openqa.suse.de/tests/384581/modules/welcome/steps/3

#10 Updated by mkravec over 5 years ago

  • Checklist item changed from to [x] SLE

#11 Updated by mkravec over 5 years ago

  • Checklist item changed from to [ ] SLE

#12 Updated by mkravec over 5 years ago

Working on SLES

#13 Updated by mkravec over 5 years ago

  • Status changed from New to In Progress

SSH remote installation works only in text mode, because window decorations are applied from local system.
Can be fixed by copying solution from s390 (using xdotools)

#14 Updated by okurz over 5 years ago

maybe not "copying" but using the same solution, see the change we did in https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/1418/files to call "fullscreen" if videomode is ssh-x independant of architecture. Of course, it has to be ensured this works for all backends.

#15 Updated by mkravec over 5 years ago

sure, I meant "copying = using the same solution" - sorry for confusion

#16 Updated by mkravec over 5 years ago

  • Checklist item changed from to [x] SLE

#17 Updated by okurz over 5 years ago

  • Related to action #7614: sle12 - figure out/impliment ssh+X, ssh+noX, and vnc installations added

#18 Updated by okurz over 5 years ago

mkravec, what are your current plans on this? can you try if it works on opensuse, too? what about the ssh+X way based on what has been done for s390x? With https://github.com/os-autoinst/os-autoinst-distri-opensuse/commit/f6d05152f6a3cb24fb5b3931569e340d05dfbdb3 there is a generic approach to set windows to fullscreen which could be used also for non-s390x tests, e.g. on openSUSE.

#19 Updated by mkravec over 5 years ago

I plan to add this test also to opensuse, hopefully next week. When it is finished I can look into changing ssh remote installation test to use ssh+X.

#20 Updated by mkravec over 5 years ago

I tried to reproduce (https://openqa.suse.de/tests/471731#step/remote_slave/8) on my local openqa instance, but everything was working fine (http://dhcp91.suse.cz/tests/overview?distri=sle&version=12-SP2&build=1974&groupid=3).

My guess is that it is openqa-network issue, but I am still searching for source of the problem.

#21 Updated by mkravec over 5 years ago

worker3 update fixed issue with inaccessible repository.
Now there is mutex problem where parent test finishes before child notices unlocked mutex - working on it.

#22 Updated by mkravec over 5 years ago

Issues fixed.
I don't have permissions on openqa.opensuse.org to add TW & Leap, please fix or change assignee.

#23 Updated by RBrownSUSE over 5 years ago

You have permissions now, use them carefully :)

#24 Updated by okurz over 5 years ago

  • Priority changed from High to Low

we have tests for SLE, openSUSE ones would be great but less important. Reducing priority. Other ideas that have been mentioned to be followed on: Test on other architectures, e.g. ppc64le and maybe also aarch64

#25 Updated by mkravec over 5 years ago

  • Status changed from In Progress to Feedback

We don't have workers with 'tap' class on opensuse - Richard?

#26 Updated by RBrownSUSE over 5 years ago

Probably not - we can make them though - ask ludwig?

#27 Updated by okurz over 5 years ago

according to coolo's answer in opensuse-factory just before you answered was that worker4, the one openSUSE got from SUSE just recently, has this set up so bind to that.

#28 Updated by RBrownSUSE over 5 years ago

Workers.ini from worker4

openqaworker4:/home/rbrown # cat /etc/openqa/workers.ini

This file is generated by salt - don't touch

Hosted on https://gitlab.suse.de/openqa/salt-pillars-openqa

[global]
HOST=http://openqa1-opensuse
WORKER_HOSTNAME=192.168.0.7

[1]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[2]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[3]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[4]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[5]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[6]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[7]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[8]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[9]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[10]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[11]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[12]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[13]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[14]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[15]
WORKER_CLASS = qemu_x86_64,pool_is_hdd

[15]
WORKER_CLASS = qemu_x86_64,pool_is_hdd


What do people want changed?

#29 Updated by mkravec over 5 years ago

  • Status changed from Feedback to In Progress

Thanks okurz, I missed coolo's answer.

#30 Updated by okurz over 4 years ago

  • Subject changed from VNC+SSH Installations to [sles][functional][opensuse] VNC+SSH Installations

mkravec: Any update on this for opensuse?

#31 Updated by mkravec over 4 years ago

No update, network setup was not working for me on o3 last time I tried - which was some time ago, I did not work on this..
I will look at this after I finish poo#18492

#32 Updated by mkravec over 4 years ago

  • Assignee deleted (mkravec)

I will re-assign after I get time to work on this, now Kubic/CaaSP have priority, so maybe somebody else would be interested in this multimachine test.

#33 Updated by sebchlad about 4 years ago

  • Subject changed from [sles][functional][opensuse] VNC+SSH Installations to [opensuse] VNC+SSH Installations

okurz: I struggle with justifying why should we have this item in the product backlog for SLE Functional team as this is done for SLE and it seems we struggle to work on this in regards o´to TW and Leap.

I would rather remove it from the backlog for the QA SLE Functional as of now and revisit it once we are done with the issue: 25614. Then we could work on "cross-checking test matrix among SLE, TW and Leap"

#34 Updated by okurz about 4 years ago

  • Subject changed from [opensuse] VNC+SSH Installations to [opensuse][sle][functional] VNC+SSH Installations

Please let's talk about this offline.

#35 Updated by okurz about 4 years ago

  • Target version set to Milestone 13

#36 Updated by okurz almost 4 years ago

I don't see why #25614 should stop us to work on this. We have VNC+SSH installation tests for SLE and we should have the same for openSUSE as we want to use the same on both if we can. And here I see that we can. We might need changes to the worker setup of openSUSE workers but besides that I don't see a problem.

#37 Updated by riafarov almost 4 years ago

  • Status changed from In Progress to Workable

#38 Updated by okurz almost 4 years ago

  • Blocked by action #30892: [opensuse][tools]multi-machine worker setup added

#39 Updated by okurz almost 4 years ago

  • Status changed from Workable to Blocked
  • Target version changed from Milestone 13 to Milestone 16
  • % Done changed from 80 to 0

blocked by not having openSUSE multi-machine capable openQA workers.

Removing the "done" assesment in percentage because of 90%-lie in project management.

#40 Updated by okurz over 3 years ago

  • Assignee set to okurz

#41 Updated by okurz over 3 years ago

  • Target version changed from Milestone 16 to Milestone 18

I doubt that o3 infrastructure will support multi-machine tests that soon

#42 Updated by okurz over 3 years ago

  • Subject changed from [opensuse][sle][functional] VNC+SSH Installations to [opensuse][sle][functional][y] VNC+SSH Installations

#43 Updated by okurz over 3 years ago

  • Target version changed from Milestone 18 to Milestone 18

#44 Updated by okurz over 3 years ago

  • Target version changed from Milestone 18 to future

… if ever ;)

#45 Updated by okurz over 2 years ago

  • Assignee changed from okurz to riafarov

Move to new QSF-y PO after I moved to the "tools"-team. I mainly checked the subject line so in individual instances you might not agree to take it over completely into QSF-y. Feel free to reassign to me or someone else in this case. Thanks.

#46 Updated by okurz over 2 years ago

  • Status changed from Blocked to Workable

#30892 fixed, multi-machine tests are possible on o3

#47 Updated by riafarov over 2 years ago

  • Subject changed from [opensuse][sle][functional][y] VNC+SSH Installations to [epic][opensuse][sle][functional][y] VNC+SSH Installations
  • Description updated (diff)

I will split this to smaller chunks to handle.

#48 Updated by riafarov over 2 years ago

  • Due date changed from 2019-07-02 to 2019-07-30

due to changes in a related task

#49 Updated by riafarov over 2 years ago

  • Due date changed from 2019-07-30 to 2019-08-13

due to changes in a related task

#50 Updated by riafarov over 2 years ago

  • Due date changed from 2019-08-13 to 2019-08-27

due to changes in a related task

#51 Updated by riafarov over 2 years ago

  • Due date changed from 2019-08-27 to 2019-09-24

due to changes in a related task

#52 Updated by riafarov about 2 years ago

  • Due date changed from 2019-09-24 to 2019-10-22

due to changes in a related task

#53 Updated by riafarov about 2 years ago

  • Due date changed from 2019-10-22 to 2019-12-10

due to changes in a related task

#54 Updated by riafarov about 2 years ago

  • Due date changed from 2019-12-10 to 2020-01-14

due to changes in a related task

#55 Updated by riafarov almost 2 years ago

  • Checklist item changed from to [x] TW

#56 Updated by riafarov over 1 year ago

  • Status changed from Workable to Resolved

There was no confirmation from Lubos to enable these scenarios on Leap, so we keep it for TW only for now. Once there is a request from leap RM, we will simply enable those scenarios.

#57 Updated by ggardet_arm over 1 year ago

#58 Updated by szarate about 1 year ago

  • Tracker changed from action to coordination

Also available in: Atom PDF