Project

General

Profile

Actions

action #63910

closed

coordination #9576: [epic][opensuse][sle][functional][y] VNC+SSH Installations

[functional][y][sporadic] test fails in remote_controller - ends up on unexpected gdm screen

Added by dimstar almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-02-27
Due date:
2020-03-24
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-remote_vnc_controller@64bit_cirrus fails in
remote_controller

Tests needs validation to see why we end up on a GDM screen; we could be switching to the wrong VT - or in worst case, we have a product bug and GNOME crashes (which would be a bit surprising, as basically no other test shows any such issue)

Test suite description

Controller performs remote installation via vnc to the target

Reproducible

Fails since (at least) Build 20200221

Expected result

Last good: 20200220 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 1 (0 open1 closed)

Related to openQA Tests - action #63643: [opensuse] test fails in consoletest_finish and exiv2 due to failure in x11 console switchResolvedggardet_arm2020-02-20

Actions
Actions #1

Updated by okurz almost 4 years ago

  • Related to action #63643: [opensuse] test fails in consoletest_finish and exiv2 due to failure in x11 console switch added
Actions #2

Updated by okurz almost 4 years ago

  • Subject changed from test fails in remote_controller to [functional][y] test fails in remote_controller - ends up on unexpected gdm screen
Actions #3

Updated by JERiveraMoya almost 4 years ago

  • Status changed from New to Resolved
  • Assignee set to JERiveraMoya

test succeded once removed cirrus references in setting that were not needed anymore: https://openqa.opensuse.org/tests/1199136

Actions #4

Updated by JERiveraMoya almost 4 years ago

  • Due date set to 2020-03-24
  • Status changed from Resolved to Workable

Seems sporadic, I could reproduce it with tw support server as well.

Actions #5

Updated by JERiveraMoya almost 4 years ago

  • Subject changed from [functional][y] test fails in remote_controller - ends up on unexpected gdm screen to [functional][y][sporadic] test fails in remote_controller - ends up on unexpected gdm screen
Actions #6

Updated by JERiveraMoya almost 4 years ago

  • Assignee deleted (JERiveraMoya)
Actions #7

Updated by riafarov almost 4 years ago

  • Parent task set to #9576
Actions #8

Updated by riafarov almost 4 years ago

  • Status changed from Workable to In Progress
  • Assignee set to riafarov

So here are 2 things. First, original issue is resolved as new image has autologin enabled, so we don't see login screen anymore. Second part is that our code used alt-f7 key press instead of proper method for console switching, this will be fixed by PR I will provide after getting VR.

Actions #9

Updated by riafarov almost 4 years ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF