Project

General

Profile

Actions

coordination #49244

closed

YaST Command Line Options TRACKER

Added by pcervinka almost 5 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
2019-03-14
Due date:
% Done:

100%

Estimated time:
(Total: 16.00 h)
Tags:

Description

Create new EXTRATEST group for yast command line options.

Start with verification of yast itself:

  • yast -h
  • list available module using yast

Create regression test for each module in subtasks.

Reference:
https://www.suse.com/documentation/sles-15/singlehtml/book_sle_admin/book_sle_admin.html#sec.yast.cli.options


Subtasks 25 (0 open25 closed)

action #49250: [qam][newt][yast2-network] Regression test for yast lan command line optionResolvedvpelcak2019-03-14

Actions
action #49253: [qam] Regression test for yast add-on command line optionRejectedjgwang2019-03-14

Actions
action #49256: Regression test yast audit-laf Rejected2019-03-14

Actions
action #49259: Regression test yast dhcp-serverRejected2019-03-14

Actions
action #49262: [qam][newt][yast2-dns-server] Regression test yast dns-serverResolvedtonyyuan2019-03-14

Actions
action #49265: [qam][maint][yast2-storage][yast2-storage-ng] Regression test yast diskResolvedmgrifalconi2019-09-02

Actions
action #49268: Regression test yast firewallRejectedJERiveraMoya2019-03-14

Actions
action #49271: [qam][newt][yast2-ftp-server] Regression test yast ftp-serverResolvedshukui2019-03-14

Actions
action #49277: [qam][newt][yast2-http-server] Regression test yast http-serverResolvedshukui2019-03-14

Actions
action #49280: Regression test yast kdumpRejected2019-03-14

Actions
action #49283: [qam] Regression test yast keyboardResolvedsimonlm2019-05-27

Actions
action #49286: [qam][newt][yast2-lang] Regression test yast languageResolvedmgrifalconi2019-03-14

Actions
action #49289: Regression test yast mailRejected2019-03-14

Actions
action #49295: [qam][newt][yast2-nfs-client] Regression test yast nfsResolvedjgwang2019-03-14

Actions
action #49298: [qam][newt][yast2-nfs-server] Regression test yast nfs-serverResolvedsimonlm2019-07-03

Actions
action #49304: Regression test yast nisRejected2019-07-29

Actions
action #49307: Regression test yast nis-serverRejectedriafarov2019-03-14

Actions
action #49310: Regression test yast proxyRejected2019-07-02

Actions
action #49313: [qam][newt][yast2-rdp] Regression test yast rdpResolvedjgwang2019-03-14

Actions
action #49316: [qam][newt][yast2-users] Regression test yast usersResolvedjgwang2019-03-14

Actions
action #49319: [qam] Regression test yast timezoneResolvedklorenzova2019-03-14

Actions
action #49322: [qam][newt][yast2-tftp-server] Regression test yast tftp-serverResolvedshukui2019-03-14

Actions
action #49325: [qam][newt][yast2-sysconfig] Regression test yast sysconfigResolvedjgwang2019-05-13

Actions
action #49328: Regression test yast soundRejected2019-03-14

Actions
action #49331: Regression test yast securityRejected2019-03-14

Actions
Actions #1

Updated by pcervinka almost 5 years ago

  • Target version set to QAM tests - future
Actions #2

Updated by pcervinka almost 5 years ago

  • Description updated (diff)
Actions #3

Updated by pcervinka almost 5 years ago

  • Description updated (diff)
Actions #4

Updated by riafarov almost 5 years ago

Just a small comment, there are quite some parts already implemented, and would be beneficial to reuse those + extended part. Here is the list:

./tests/console/yast2_cmdline.pm
./tests/console/yast2_http.pm
./tests/console/yast2_lan_hostname.pm
./tests/console/yast2_rmt.pm
./tests/console/yast2_vnc.pm
./tests/console/yast2_bootloader.pm
./tests/console/yast2_nis.pm
./tests/console/yast2_i.pm
./tests/console/yast2_proxy.pm
./tests/console/yast2_clone_system.pm
./tests/console/yast2_dns_server.pm
./tests/console/yast2_nfs_client.pm
./tests/console/yast2_ntpclient.pm
./tests/console/yast2_scc.pm
./tests/console/yast2_ftp.pm
./tests/console/yast2_snapper_ncurses.pm
./tests/console/yast2_apparmor.pm
./tests/console/yast2_lan.pm
./tests/console/yast2_nfs_server.pm
./tests/console/yast2_samba.pm
./tests/console/yast2_tftp.pm
./tests/console/yast2_xinetd.pm
./tests/x11/yast2_snapper.pm
./tests/x11/network/yast2_network_use_nm.pm
./tests/x11/yast2_lan_restart_devices.pm
./tests/x11/yast2_lan_restart.pm
./tests/yast2_gui/yast2_bootloader.pm
./tests/yast2_gui/yast2_control_center.pm
./tests/yast2_gui/yast2_datetime.pm
./tests/yast2_gui/yast2_firewall.pm
./tests/yast2_gui/yast2_lang.pm
./tests/yast2_gui/yast2_network_settings.pm
./tests/yast2_gui/yast2_users.pm
./tests/yast2_gui/yast2_hostnames.pm
./tests/yast2_gui/yast2_software_management.pm

Note that qt/gtk version behaves exactly in same way as ncurses, 99% of the time shortcuts also match, so no sense to test functional part in both UIs.

Actions #5

Updated by pcervinka almost 5 years ago

@riafarov this activity is about testing of command line use of yast modules, not about ncurses/gui versions.

Actions #6

Updated by pcervinka almost 5 years ago

Added @vpelcak. @rodion if you think that we have some overlap/concurrent work, please align with Vit(test product owner) to avoid any confusions.

Actions #7

Updated by vpelcak almost 5 years ago

@rodion http://deva.suse.cz/tests/12#

Example of yast lan cli tests I implemented.
To show what we mean by these tests.

Actions #8

Updated by riafarov almost 5 years ago

vpelcak wrote:

@rodion http://deva.suse.cz/tests/12#

Example of yast lan cli tests I implemented.
To show what we mean by these tests.

Ah, now I got it. I'm not aware of anything like this, so we are safe. But I would recommend to talk to YaST team, as they might have some tests already, which can be simply triggered in openQA. AFAIR, they had some cli integration tests.
Thanks for the explanation!

Actions #9

Updated by vpelcak almost 5 years ago

YaST team just confirmed that the test coverage from their side is minimal and we can proceed.

Actions #10

Updated by mloviska almost 5 years ago

Most of yast2 modules have some TAP bash scripts included testing CLI.
For instance network module:

Actions #12

Updated by pcervinka almost 5 years ago

This is really bad approach to run upstream test within openQA by using rpmbuild. If it is enabled during the build in obs, it is not needed to be done again in openQA(in the same way).

It runs tests for yast lan module only and other yast modules are not covered.

Actions #13

Updated by mloviska almost 5 years ago

pcervinka wrote:

This is really bad approach to run upstream test within openQA by using rpmbuild. If it is enabled during the build in obs, it is not needed to be done again in openQA(in the same way).

It runs tests for yast lan module only and other yast modules are not covered.

Checking the code. I can see that rpmbuild is executed with option -bp.

-bp    Executes  the  "%prep"  stage  from the spec file. Normally this in-
              volves unpacking the sources and applying any patches.

Therefore from the network package, it would particularly execute only this part.

%prep
%setup -n %{name}-%{version}

Thus, we can omit the rpmbuild call if it is the only problem what we can see. TAP tests are directly invoked using prove https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/tests/console/yast2_cmdline.pm#L36.

TAP tests are not executed in OBS, AFAIK they are executed in openQA, or end users can run them on their own.

Actions #14

Updated by pstivanin almost 5 years ago

  • Due date set to 2019-05-10

due to changes in a related task

Actions #15

Updated by pstivanin almost 5 years ago

  • Due date changed from 2019-05-10 to 2019-05-24

due to changes in a related task

Actions #16

Updated by pstivanin almost 5 years ago

  • Due date changed from 2019-05-24 to 2019-05-13

due to changes in a related task

Actions #17

Updated by simonlm almost 5 years ago

  • Due date changed from 2019-05-10 to 2019-05-27

due to changes in a related task

Actions #18

Updated by pstivanin almost 5 years ago

  • Due date changed from 2019-05-10 to 2019-06-10

due to changes in a related task

Actions #19

Updated by pstivanin almost 5 years ago

  • Due date changed from 2019-06-10 to 2019-05-27

due to changes in a related task

Actions #20

Updated by vpelcak over 4 years ago

  • Subject changed from [qam] YaST Command Line Options to [qam][high] YaST Command Line Options
Actions #21

Updated by simonlm over 4 years ago

  • Due date set to 2019-07-02

due to changes in a related task

Actions #22

Updated by simonlm over 4 years ago

  • Due date set to 2019-07-03

due to changes in a related task

Actions #23

Updated by tonyyuan over 4 years ago

  • Due date set to 2019-07-29

due to changes in a related task

Actions #24

Updated by simonlm over 4 years ago

  • Due date set to 2019-09-02

due to changes in a related task

Actions #25

Updated by vpelcak over 4 years ago

  • Subject changed from [qam][high] YaST Command Line Options to [qam][feature] YaST Command Line Options
Actions #26

Updated by brhavel about 4 years ago

  • Subject changed from [qam][feature] YaST Command Line Options to [qam] YaST Command Line Options TRACKER
Actions #27

Updated by tjyrinki_suse almost 4 years ago

  • Due date set to 2019-09-02

due to changes in a related task

Actions #28

Updated by tjyrinki_suse over 3 years ago

  • Status changed from New to Workable
Actions #29

Updated by tjyrinki_suse over 3 years ago

  • Project changed from 119 to qe-yam
  • Target version deleted (QAM tests - future)
Actions #30

Updated by riafarov over 3 years ago

  • Subject changed from [qam] YaST Command Line Options TRACKER to YaST Command Line Options TRACKER
  • Status changed from Workable to New
  • Target version set to future

@tjyrinki_suse COuld you please set status of the ticket to New when adding items to qe-yast backlog? We didn't refine those tickets, so they are not workable when just moved and should not be worked on before it happens.
When status is set to workable, they appear in the kanban board, which is wrong. Thanks!

Actions #31

Updated by riafarov about 3 years ago

  • Tracker changed from action to coordination
Actions #32

Updated by JERiveraMoya over 1 year ago

  • Tags set to YaST

Not planning to extend test coverage for yast modules. We are more focused in other areas in the next year.

Actions #33

Updated by JERiveraMoya over 1 year ago

  • Status changed from New to Resolved
Actions

Also available in: Atom PDF