Project

General

Profile

action #46190

[functional][u] test fails in user_settings - mistyping in Username (lowercase instead of uppercase)

Added by dimstar over 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 30
Start date:
2019-01-15
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:

Description

Observation

Very frequently, the name 'Bernhard M Wiedemann' is mistyped in openQA, most commonly with a lower-case M for the middle name. In many cases, this 'could be ignored', but often there are modules further down the line that have a login mask where the name then mismatches

openQA test in scenario opensuse-Tumbleweed-KDE-Live-i686-kde-live_installation@32bit fails in
user_settings

Tasks

  1. Check if we need to reduce the number of workers per machine.
    yes, see: https://progress.opensuse.org/issues/60833

  2. Check if increasing minimum memory is necessary.

Reproducible

Fails since (at least) Build 20181231

Expected result

Last good: 20181224 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #45650: [functional][u][aarch64] test fails in first_boot because of username letters not written in capital case during installation user_settingsResolved2019-01-02

Related to openQA Tests - action #48572: [sle][functional][y] test fails in welcome - wrong url sent to worker because of mistypingResolved2019-03-012019-04-09

Related to openQA Tests - coordination #43889: [qe-core][epic][functional][virtio][wayland] openQA makes spelling mistakesBlocked

Related to openQA Tests - action #53795: [functional][u] oomath: frequent mistyping of the formulaResolved2019-07-03

Related to openQA Tests - action #60833: [qe-core][sle][functional] performance issue of aarch64 worker: Stall detectedRejected2019-12-10

Has duplicate openQA Tests - action #57944: shift key gets pressed on arm workers while typingRejected2019-10-10

Has duplicate openQA Tests - action #58799: test fails in user_settings: MisstypingRejected2019-10-29

Has duplicate openQA Tests - action #58847: False positive in user_settingsRejected2019-10-30

History

#1 Updated by mgriessmeier over 2 years ago

  • Related to action #45650: [functional][u][aarch64] test fails in first_boot because of username letters not written in capital case during installation user_settings added

#2 Updated by mgriessmeier over 2 years ago

  • Subject changed from test fails in user_settings to [functional] test fails in user_settings - mistyping in Username (lowercase instead of uppercase)

#3 Updated by okurz over 2 years ago

  • Subject changed from [functional] test fails in user_settings - mistyping in Username (lowercase instead of uppercase) to [functional][u] test fails in user_settings - mistyping in Username (lowercase instead of uppercase)
  • Priority changed from Normal to Urgent
  • Target version set to Milestone 22

mgriessmeier please assign always at least [u] for [y] or both. As you know, we do not have a query for "[functional] but not [u] nor [y]" so we could miss according tickets for a long time.

#4 Updated by dimstar over 2 years ago

We from the product side also looked further into this issue: interesting points are that neither Leap (same openqa instane) nor SLE (different instance) seem to show this kind of issue - which in turn seems to point towards a product issue.

Lately, the issue shows up much more often, as I removed ungeneric needles (matching all of the user_settings screen_ against one matching also the name explicitly. By digging through history, this issue seems to have started around snapshot 1214 - which co-incides with the checkin date of Qt 5.12

Qt 5.12 is thus a suspect for this failure, BUT this theory somewhat is disproven by the fact that Krypton does not show the issue

#5 Updated by dimstar over 2 years ago

Turns out Krypton is not free from this error: https://openqa.opensuse.org/tests/822087#step/user_settings/2 (one suspicion was that Krypton would not see it due to the higher memory availability)

#6 Updated by okurz over 2 years ago

  • Status changed from New to Workable

#7 Updated by zluo over 2 years ago

  • Status changed from Workable to In Progress

take over and check.

#8 Updated by zluo over 2 years ago

  • Status changed from In Progress to Resolved

#9 Updated by zluo over 2 years ago

  • Status changed from Resolved to In Progress
  • Priority changed from Urgent to Normal

since the test is still failed, will work on this anyway. but no urgent issue anymore.

#10 Updated by zluo over 2 years ago

  • Subject changed from [functional][u] test fails in user_settings - mistyping in Username (lowercase instead of uppercase) to [functional][u] test fails in user_settings - doesn't match inst-userpasswdtoosimple

need to investigate this issue with needle match.

#11 Updated by okurz over 2 years ago

  • Subject changed from [functional][u] test fails in user_settings - doesn't match inst-userpasswdtoosimple to [functional][u] test fails in user_settings - mistyping in Username (lowercase instead of uppercase)
  • Status changed from In Progress to Workable
  • Priority changed from Normal to Urgent

but no urgent issue anymore.

And why did you come to this conclusion?

need to investigate this issue with needle match.

zluo please do not make this ticket something completely different. If currently "inst-userpasswdtoosimple" does not match then it's a different issue. Btw, where did you see this?

#12 Updated by mgriessmeier over 2 years ago

okurz wrote:

but no urgent issue anymore.

And why did you come to this conclusion?
I also think it is still an urgent issue until we have statistics about this

need to investigate this issue with needle match.

zluo please do not make this ticket something completely different. If currently "inst-userpasswdtoosimple" does not match then it's a different issue. Btw, where did you see this?
it is a different issue, please check the labeled bugref... https://bugzilla.opensuse.org/show_bug.cgi?id=1122181

#13 Updated by mgriessmeier over 2 years ago

hmm there is already a softfail needle for this: https://openqa.opensuse.org/tests/831713#step/user_settings/2
question is if this is acceptable as urgency removal or not - the two builds afterwards looked fine though
okurz your take on this?

#14 Updated by zluo over 2 years ago

  • Status changed from Workable to In Progress
  • Priority changed from Urgent to Normal

https://bugzilla.opensuse.org/show_bug.cgi?id=1122181

this is clear now. So this should fix the problem.

#15 Updated by zluo over 2 years ago

if low characters don't appear now, it mean we have a different issue, right. so this is not urgent anyway.

#16 Updated by mgriessmeier over 2 years ago

zluo wrote:

if low characters don't appear now, it mean we have a different issue, right. so this is not urgent anyway.

anyway, following #note-4 I would try to check statistics on Builds before Qt5 submission and compare it to the ones after the Qt5 submission

#17 Updated by okurz over 2 years ago

  • Status changed from In Progress to Workable
  • Priority changed from Normal to Urgent

mgriessmeier wrote:

hmm there is already a softfail needle for this: https://openqa.opensuse.org/tests/831713#step/user_settings/2
question is if this is acceptable as urgency removal or not - the two builds afterwards looked fine though
okurz your take on this?

No, not enough as urgency removal because as you can see the tests still fail.

I crosschecked with dimstar and ggardet in #opensuse-factory:

[21/01/2019 11:21:04] <okurz> DimStar, guillaume_g: btw, what's the current situation regarding mistyping of the username in the installer? I did not find related failures in the recent snapshot results. Can you help me?
[21/01/2019 11:21:40] <DimStar> okurz: they have all been retriggered until succeeded
[21/01/2019 11:22:15] <okurz> I see, so still current. And the main ticket is https://progress.opensuse.org/issues/46190 ?
[21/01/2019 11:22:16] <|Anna|> [functional][u] test fails in user_settings - mistyping in Username (lowercase instead of uppercase)  in openQA Tests (action for unassigned) [Workable] Created on: 2019-01-15 | 0% done.
[21/01/2019 11:22:57] <DimStar> see for example https://openqa.opensuse.org/tests/832047#step/user_settings/1
[21/01/2019 11:51:36] <guillaume_g> okurz: same as DimStar, occurs but retrigger until it passes. (for ARM, the gic_version=host improved things thought)

zluo again, this ticket is not about boo#1122181 . Please only set ticket to "In Progress" with an assignee.

#18 Updated by mgriessmeier over 2 years ago

I've triggered 50 jobs overnight to get some statistics...

#19 Updated by mgriessmeier over 2 years ago

also trying with type_string_slow

#20 Updated by mgriessmeier over 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to mgriessmeier

mgriessmeier wrote:

I've triggered 50 jobs overnight to get some statistics...

5/50 failed -> 10%

I will trigger another 50 with type_string_slow to see if it improves things

#21 Updated by mgriessmeier over 2 years ago

  • Priority changed from Urgent to Normal

so far 0/40 jobs failed with using type_string_slow - I don't expect any job of the last 10 to fail.
imo this really reduces urgency if not resolves the ticket (for now)
created PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6604

okurz: please state what you think regarding definition of done or if we e.g. should move it to the tools team to have a closer look on the backend implementation where this most likely comes from

#22 Updated by okurz over 2 years ago

For further reference because I know that all of us will have forgotten in some months what you or we did here: Please also reference the commands you used to trigger tests and provide links to the openQA test overviews from which you gathered your observations.

This has nothing to do with the "tools"-team and you know that they would not be able to look into this anytime soon given that the team consists of just one guy that actually has openQA experience and he works on the webUI mainly.

#46190#note-4 already points in the direction of Qt submission within openSUSE Factory/Tumbleweed as we did not see this problem yet in Leap nor SLE AFAIK. There should be a corresponding product bug but most likely this will not be fixed without our help in regards of having openQA showing the error and only then providing a workaround.

#23 Updated by mgriessmeier over 2 years ago

  • Priority changed from Normal to Urgent

#24 Updated by mgriessmeier over 2 years ago

  • Status changed from In Progress to Feedback

updated PR with detection of mistyping as soft-fail and retry with slower typing
-> https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6604

#25 Updated by okurz over 2 years ago

Created bug report https://bugzilla.opensuse.org/show_bug.cgi?id=1122804 which you can use now in all needle references or the record_soft_failure.

#26 Updated by okurz over 2 years ago

  • Status changed from Feedback to Workable
  • Assignee deleted (mgriessmeier)
  • Priority changed from Urgent to Normal
  • Target version changed from Milestone 22 to Milestone 23

https://openqa.opensuse.org/tests/841493#step/user_settings/3 shows the mistyping detected and corrected. Thanks mgriessmeier.

Down to "Normal" for further investigation, log file gathering, etc.

#27 Updated by okurz over 2 years ago

  • Status changed from Workable to Blocked
  • Assignee set to okurz
  • Target version changed from Milestone 23 to Milestone 24

let's focus on #45650 first

#28 Updated by okurz over 2 years ago

  • Related to action #48572: [sle][functional][y] test fails in welcome - wrong url sent to worker because of mistyping added

#29 Updated by okurz over 2 years ago

  • Target version changed from Milestone 24 to Milestone 26

#45650 resolved. I guess we can wait until M25 for https://bugzilla.opensuse.org/show_bug.cgi?id=1122804

#30 Updated by okurz about 2 years ago

  • Assignee changed from okurz to mgriessmeier

Move to new QSF-u PO after I moved to the "tools"-team. I mainly checked the subject line so in individual instances you might not agree to take it over completely into QSF-u. Feel free to discuss with me or reassign to me or someone else in this case. Thanks.

#31 Updated by okurz about 2 years ago

  • Status changed from Blocked to Workable
  • Priority changed from Normal to High

https://github.com/os-autoinst/os-autoinst/pull/1174 might help as a workaround on the openQA side which makes it feasible to test this without waiting for the stale bug.

mgriessmeier I suggest for any engineer taking this to try to reproduce the problem locally and then apply https://github.com/os-autoinst/os-autoinst/pull/1174 to see if this fixes our problems from openQA test side. One should monitor https://openqa.opensuse.org/tests/latest?machine=64bit-2G&distri=opensuse&test=krypton-live-installation&flavor=Krypton-Live&version=5.12.80&arch=x86_64#next_previous

#32 Updated by okurz about 2 years ago

  • Related to coordination #43889: [qe-core][epic][functional][virtio][wayland] openQA makes spelling mistakes added

#33 Updated by okurz about 2 years ago

  • Related to action #53795: [functional][u] oomath: frequent mistyping of the formula added

#34 Updated by mgriessmeier almost 2 years ago

  • Target version changed from Milestone 26 to Milestone 27

#35 Updated by mgriessmeier almost 2 years ago

  • Status changed from Workable to Blocked
  • Target version changed from Milestone 27 to Milestone 28

blocked by #43889

#36 Updated by okurz almost 2 years ago

  • Related to action #57944: shift key gets pressed on arm workers while typing added

#37 Updated by riafarov almost 2 years ago

  • Related to deleted (action #57944: shift key gets pressed on arm workers while typing)

#38 Updated by riafarov almost 2 years ago

  • Has duplicate action #57944: shift key gets pressed on arm workers while typing added

#39 Updated by okurz almost 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: minimal+role_minimal
https://openqa.suse.de/tests/3462442

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#40 Updated by okurz almost 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: minimal+role_minimal
https://openqa.suse.de/tests/3462442

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#41 Updated by JRivrain almost 2 years ago

It seems to happen at every run currently on sle 15sp2/aarch64, even in cases where it seems to have worked, like here or here

#42 Updated by okurz almost 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: yast_no_self_update
https://openqa.suse.de/tests/3526342

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#43 Updated by okurz almost 2 years ago

  • Has duplicate action #58799: test fails in user_settings: Misstyping added

#44 Updated by okurz almost 2 years ago

  • Has duplicate action #58847: False positive in user_settings added

#46 Updated by SLindoMansilla over 1 year ago

  • Status changed from Blocked to Workable

Blocker resolved: #45650

#47 Updated by okurz over 1 year ago

With https://github.com/os-autoinst/os-autoinst/pull/1260 typing in general is configured by default to be slower and also especially the modifier keys are handled now more human-like. This might fix it already. Please check test results for the status accordingly.

#48 Updated by okurz over 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: RAID1
https://openqa.suse.de/tests/3624277

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#49 Updated by okurz over 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: cryptlvm+activate_existing
https://openqa.suse.de/tests/3686994

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#50 Updated by SLindoMansilla over 1 year ago

  • Status changed from Workable to New
  • Assignee deleted (mgriessmeier)

#51 Updated by SLindoMansilla over 1 year ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Estimated time set to 42.00 h

#52 Updated by zluo over 1 year ago

  • Description updated (diff)

#53 Updated by zluo over 1 year ago

  • Related to action #60833: [qe-core][sle][functional] performance issue of aarch64 worker: Stall detected added

#54 Updated by okurz over 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: skip_registration+workaround_modules
https://openqa.suse.de/tests/3731135

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#55 Updated by mgriessmeier over 1 year ago

  • Target version changed from Milestone 28 to Milestone 30

needs to be discussed offline

#56 Updated by zluo over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over and check current status.

#57 Updated by zluo over 1 year ago

the issue mentioned in #54 is performance related: see Stall detection text in first_boot.

https://openqa.suse.de/tests/3731135#step/user_settings/3 shows softfail and uppercase 'Bernhard M Wiedemann' is used. and the workaround needle is not correct here.

I cannot see any issue here.

#58 Updated by zluo over 1 year ago

I believe the real issue with tying issue is performance on aarch64 worker. We have Stall detection sometimes. for example:

https://openqa.suse.de/tests/3766064#step/accept_license/3

#59 Updated by zluo over 1 year ago

for TW we see clearly that we don't have this issue anymore, however the needle which used is not accurate:

https://openqa.opensuse.org/tests/1138820#step/user_settings/2

#60 Updated by okurz over 1 year ago

zluo wrote:

I believe the real issue with tying issue is performance on aarch64 worker

If it all this is a different issue than the originally described on which happened on i586, at least a sub-issue, which can not explain all failures. If you want to follow on with this hypothesis I suggest to do it in a different (sub-)ticket.

#61 Updated by zluo over 1 year ago

http://f40.suse.de/tests/5995#step/user_settings/2 looks much better with VNC_TYPING_LIMIT=18 in this case, but I found match level of the needle is not set, so this needs to be changed anyway.

http://f40.suse.de/tests/5998#step/user_settings/2 shows now 100% match and with VNC_TYPING_LIMIT=18

#62 Updated by zluo over 1 year ago

https://progress.opensuse.org/issues/60833 needs to be handled as well to get for a good performance.

Together with VNC_TYPING_LIMIT and a new needle (with proper match level), I think it can prevent and resolve this issue.

#63 Updated by okurz over 1 year ago

zluo wrote:

Together with VNC_TYPING_LIMIT […] it can prevent and resolve this issue.

VNC_TYPING_LIMIT should not be considered a fix unless it is used for specific workers or machines. It can be used for investigation purposes but slowing down the complete test flow to fix a single test module is not a good idea. Where necessary slower typing can be instructed with the according test API calls or the helper functions we have in os-autoinst-distri-opensuse.

#64 Updated by zluo over 1 year ago

I think we live without VNC_TYPING_LIMIT if we can make sure that poor performance will not cause typing issue.

#66 Updated by okurz over 1 year ago

zluo wrote:

I think we live without VNC_TYPING_LIMIT if we can make sure that poor performance will not cause typing issue.

Unless you can define "poor performance" better I doubt we can "fix it". Tests and os-autoinst should be designed to work regardless of a slow worker host though.

#68 Updated by zluo over 1 year ago

We have all the time poor performance for aarch64 on osd:

https://openqa.suse.de/tests/3776484#next_previous
https://openqa.suse.de/tests/3776484#next_previous

Just look at first_boot and see a lot of Stall detection.

#69 Updated by zluo over 1 year ago

So poor performance of aarch64 workers on osd is the root cause.
If we don't want to use VNC_TYPING_LIMIT, then we need to solve the issue at first or we have to leave with this kind of sporadic issue.

#70 Updated by zluo over 1 year ago

https://openqa.suse.de/tests/3803671#step/first_boot/7 shows still issue with stall detection:

related ticket: #25864

#72 Updated by zluo over 1 year ago

it looks really bad.

https://openqa.suse.de/tests/3817022#step/accept_license/4 show issue with stall detection.

#73 Updated by okurz over 1 year ago

I guess when we can actually detect "stalls" then we should regard it as a different issue. We have #25864 for OSD worker specific issues. I suggest to keep this ticket specific when we see the symptoms of wrong username typing in the user_settings test module without seeing other symptoms, e.g. no stall detection message.

#74 Updated by zluo over 1 year ago

  • Status changed from In Progress to Workable

okay, then let's handle this differently.

Let's talk about following:

  1. delete the workaround needle which matches even uppercase
  2. create new needle tag for a softfail for misstyping and we need then information for the product issue.

#75 Updated by okurz over 1 year ago

zluo wrote:

  1. delete the workaround needle which matches even uppercase

if you found false-matches, yes.

  1. create new needle tag for a softfail for misstyping and we need then information for the product issue.

I am not sure what you see this as necessary for. Keep in mind that for openSUSE we already track this issue since about 1 year and there are workaround needles in place which correctly detect the error condition and accept the mistyped username as acceptable. What IIRC the test code does not do is to try to fix the mistyping, e.g. detecting mistyping, deleting wrong characters and retype until typing is correct before continuing. This is already implemented but depends on the needle tag 'boo#1122804' which maybe you still need to add for the corresponding SLE needles.

#76 Updated by zluo over 1 year ago

https://openqa.suse.de/tests/3694753#step/user_settings/2 shows that workaround doesn't come up for matching. inst-userinfostyped-sle15-2018022 matches however it has typing issue with lowercase. We should delete this needle anyway.

For TW we have also issue with workaround needle:
https://openqa.opensuse.org/tests/1150786#step/user_settings/3 typing correct with uppercase, but screen before this it shows lowercase for m. and it got matched as by workaround needle already, really weird. So what is the typing issue here? We have actually then uppercase for M and this got also matched correctly, but little bit later.

So in this case the workaround needle is not needed.

#77 Updated by okurz over 1 year ago

zluo wrote:

https://openqa.suse.de/tests/3694753#step/user_settings/2 shows that workaround doesn't come up for matching. inst-userinfostyped-sle15-2018022 matches however it has typing issue with lowercase. We should delete this needle anyway.

agreed. Replace it by a more strict version.

For TW we have also issue with workaround needle:
https://openqa.opensuse.org/tests/1150786#step/user_settings/3 typing correct with uppercase, but screen before this it shows lowercase for m. and it got matched as by workaround needle already, really weird. So what is the typing issue here? We have actually then uppercase for M and this got also matched correctly, but little bit later.

So in this case the workaround needle is not needed.

No, the workaround needle is needed but the test code correctly detects this and corrects the mistyping. We already have the correct code since af67fc8e7 to retry on typing mistakes. see #46190#note-24

#78 Updated by zluo over 1 year ago

  • Assignee deleted (zluo)

unassign myself for talk this ticket in team meeting.

#79 Updated by SLindoMansilla over 1 year ago

  • Assignee set to SLindoMansilla

As already agreed by the team, I am going to extend the workaround to only apply it when the expected typefaces are NOT present.

At the moment the workaround is only applied when a needle with tag boo#1122804 matches wrong typefaces. That would mean that a new workaround needle should be created for any different combination of shift+key and key.

#80 Updated by SLindoMansilla over 1 year ago

  • Status changed from Workable to In Progress

#82 Updated by sbehlert over 1 year ago

Wouldn't be the fastest way to simplify the username?
This "mistyping" looks a lot like a tool issue, not like a product issue.
And if it's "just" the same issue again and a gain, using less letters is the easiest way to reduce the failures.
(Yes, this requires adaptions on some testcases/images, but this might be faster than everything else)

#83 Updated by okurz over 1 year ago

sbehlert wrote:

Wouldn't be the fastest way to simplify the username?
This "mistyping" looks a lot like a tool issue, not like a product issue.

I am still convinced this is a product issue: https://bugzilla.opensuse.org/show_bug.cgi?id=1122804

This ticket is only about a workaround for the real issue. Simplifying the username would definitely be a possible workaround as well but with no possibility to detect the original issue. Seeing how much effort has gone into this ticket and apparently none into a bug fix it might have been a better choice from the beginning. Would be cool if someone would have made the call in the bug to state: "Yes, this is clearly a product regression but we will not fix it due to low customer impact and too high implementation effort". Then probably someone would have arrived to the decision sooner to accept any "workaround" as the new "happy path".

#84 Updated by SLindoMansilla over 1 year ago

sbehlert wrote:

Wouldn't be the fastest way to simplify the username?
This "mistyping" looks a lot like a tool issue, not like a product issue.
And if it's "just" the same issue again and a gain, using less letters is the easiest way to reduce the failures.
(Yes, this requires adaptions on some testcases/images, but this might be faster than everything else)

If the bug ticket gets "resolved: won't fix", we can remove the soft-fail. Then our support team can tell customers that when they use a VM with 1GB RAM, they should pick short full names and don't press the shift key.

#85 Updated by SLindoMansilla over 1 year ago

  • Status changed from In Progress to Feedback

#86 Updated by maritawerner over 1 year ago

Hello Sergio, thanks for your comment. I have raised your question to Stefan Behlert directly (again). If he confirms we can remove a lot of soft failures but I also agree with Oli Kurz, we could have saved a lot of time....

#87 Updated by sbehlert over 1 year ago

maritawerner wrote:

Hello Sergio, thanks for your comment. I have raised your question to Stefan Behlert directly (again). If he confirms we can remove a lot of soft failures but I also agree with Oli Kurz, we could have saved a lot of time....

Hm, I fail to see what the question is? As mentioned, I don't think this is a product bug, and currently I see or hear no evidence to the contrary.

Reducing the namelength might reduce the times the issue happen, but of course if its an openQA issue it still should be fixed. (For a product issue, I see no real life occurance yet, which also points to the "no product issue" part...)

#88 Updated by okurz over 1 year ago

sbehlert wrote:

[…]
Hm, I fail to see what the question is? As mentioned, I don't think this is a product bug.

It is a product bug. https://bugzilla.opensuse.org/show_bug.cgi?id=1122804 is the report about it. The bug report is currently in status "CONFIRMED". As long as that is the case we should consider it as a product bug.

[…] and currently I see or hear no evidence to the contrary.

slindomansilla already manually reproduced the problem which appears when a VM is configured with just 1 GB. My suggestion:

  • Adjust product requirements and recommend >= 2 GB for GUI interactive installer and keep existing requirements for textmode or non-interactive installer
  • Adjust test plan accordingly, e.g. run openQA tests using interactive installer against 2GB variants, 1GB for others

side-note: https://gitlab.suse.de/openqa/os-autoinst-needles-sles/merge_requests/1316 merged to prevent some false-positives and links to the progress ticket when instead we should directly link to the bug report.

#89 Updated by SLindoMansilla over 1 year ago

  • Status changed from Feedback to In Progress

The tries need to be increased for ARM: https://openqa.suse.de/tests/3922439#step/user_settings/6

#90 Updated by SLindoMansilla over 1 year ago

Also for x86_64: https://openqa.suse.de/tests/3929374#step/user_settings/6
But, aarch64 is the most affected.

#91 Updated by maritawerner over 1 year ago

I have talked to Alex Herzig and he has talked to Stefan Behlert -> they do not agree on OLi's suggestion and now they try to get a QT expert who will fix the bug.

#92 Updated by okurz over 1 year ago

maritawerner wrote:

I have talked to Alex Herzig and he has talked to Stefan Behlert -> they do not agree on OLi's suggestion and now they try to get a QT expert who will fix the bug.

Even better then :D I never ruled out the option to have the real bug fixed instead ;)

#93 Updated by SLindoMansilla over 1 year ago

  • Status changed from In Progress to Feedback

Increasing the retries: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9738 (merged)

Jobs on aarch64 still fail a lot.
Some jobs on x86_64 also can fail after 2 retries

#94 Updated by SLindoMansilla over 1 year ago

Waiting for verification on next build

#96 Updated by SLindoMansilla over 1 year ago

  • Status changed from In Progress to Feedback

#97 Updated by SLindoMansilla over 1 year ago

Isolate product bug to specific scenarios: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9808 (merged)

Setting ASSERT_BSC1122804=1 added to default test suite.

#99 Updated by SLindoMansilla over 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF