Project

General

Profile

action #48572

[sle][functional][y] test fails in welcome - wrong url sent to worker because of mistyping

Added by JRivrain over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 24
Start date:
2019-03-01
Due date:
2019-04-09
% Done:

0%

Estimated time:
5.00 h
Difficulty:

Description

Observation

In vars.json we have : SCC_URL "http://Server-0126.proxy.scc.suse.de"
In autoinst-log.txt : type_string(string=' regurl=http://Server-0126.proxy.scc.suse.de'
But
In serial.txt and on video : regurl=http://Server-0126.proxysc.s.e

openQA test in scenario sle-12-SP5-Server-DVD-x86_64-RAID5@64bit fails in
welcome

We should improve our tests to detect such cases and not hide them to simplify review.

Acceptance criteria

  1. Typos in boot parameters are detected and are clearly visualized on the job page

Test suite description

Maintainer: slindomansilla, jrauch

Installation of RAID5 using expert partitioner

Reproducible

Fails since (at least) Build 0126 (current job)

Expected result

Last good: 0122 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #42275: [functional][u][sporadic] test fails in bootloader with mistyped/incomplete regurl on x86_64Resolved2018-10-10

Related to openQA Tests - action #46190: [functional][u] test fails in user_settings - mistyping in Username (lowercase instead of uppercase) Resolved2019-01-15

History

#1 Updated by okurz over 2 years ago

  • Related to action #42275: [functional][u][sporadic] test fails in bootloader with mistyped/incomplete regurl on x86_64 added

#2 Updated by okurz over 2 years ago

  • Related to action #46190: [functional][u] test fails in user_settings - mistyping in Username (lowercase instead of uppercase) added

#3 Updated by okurz over 2 years ago

  • Subject changed from [sle][functional][y] test fails in welcome - wrong url sent to worker. to [sle][functional][y] test fails in welcome - wrong url sent to worker because of mistyping
  • Due date set to 2019-03-26
  • Status changed from New to Workable
  • Target version set to Milestone 23

Pretty sure this is a sporadic issue and the workaround of "retriggering" should work. Please crosscheck that during the next sprint.

#4 Updated by riafarov over 2 years ago

  • Description updated (diff)
  • Priority changed from High to Normal

Lowering the priority as re-triggering works, refine to do assert, so it's clear from the first sight if we have a typo.

#5 Updated by riafarov over 2 years ago

  • Estimated time set to 5.00 h

#6 Updated by oorlov over 2 years ago

  • Assignee set to oorlov

#7 Updated by oorlov over 2 years ago

  • Status changed from Workable to In Progress

#8 Updated by JERiveraMoya over 2 years ago

  • Due date changed from 2019-03-26 to 2019-04-09

It was evaluated that a most robust solution is required. Moving to next sprint.

#9 Updated by riafarov over 2 years ago

  • Target version changed from Milestone 23 to Milestone 24

#10 Updated by oorlov over 2 years ago

  • Status changed from In Progress to Feedback

#11 Updated by JERiveraMoya over 2 years ago

  • Status changed from Feedback to In Progress

#12 Updated by oorlov over 2 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF