action #48110

[functional][u][sporadic] test failed in different modules that switch from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct tty

Added by okurz about 1 year ago. Updated about 22 hours ago.

Status:WorkableStart date:04/01/2019
Priority:LowDue date:
Assignee:-% Done:

0%

Category:Enhancement to existing testsEstimated time:42.00 hours
Target version:SUSE QA tests - Milestone 31
Difficulty:
Duration:

Description

Observation

openQA test in scenario opensuse-15.1-DVD-x86_64-extra_tests_on_gnome@64bit failed in
NM_wpa2_enterprise
This was fixed meanwhile in #45710 however.

Actually we just switch back from a text console to gdm, we detect that, enter the password in https://openqa.opensuse.org/tests/823304/file/video.ogv#t=126.72,126.74 and that is not accepted.

Acceptance criteria

Suggestions
* Find another test module or create one at least temporarily that switches to text console and back to "x11" and needing to login when just an unlock should do
* Newer versions of gdm are started twice, on tty2+tty7. If we switch to the "wrong one" we can login and are diverted to the other tty. We should ensure we select the tty where we are already logged in, i.e. we should not expect the user selection screen but the unlock screen of the already logged in user "bernhard"

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #53246: [desktop][tumbleweed] test fails in yast2_control_center Resolved 18/06/2019
Related to openQA Tests - action #36126: [functional][u] post_fail_hook matches on "text_login_roo... Resolved 14/05/2018
Related to openQA Tests - action #57281: [sle][Migration][SLE15SP2] test fails in orphaned_package... Resolved 24/09/2019
Related to openQA Tests - action #63727: select_console "log-console" do not try to activate after... New 21/02/2020
Related to openQA Tests - action #63643: test fails in consoletest_finish and exiv2 due to failure... New 20/02/2020
Related to openQA Tests - action #63670: [functional][u] test fails in x11 - black screen Workable 20/02/2020
Duplicated by openQA Tests - action #56852: test fails in ooffice Rejected 12/09/2019
Blocks openQA Tests - action #47321: [qam][opensuse][sporadic] openSUSE Leap 15.0 started fail... New 09/02/2019
Blocks openQA Tests - action #44153: [functional][u][sporadic] test fails in gnome_control_cen... Blocked 21/11/2018
Copied from openQA Tests - action #45710: [functional][u] test fails in NM_wpa2_enterprise - unable... Resolved 04/01/2019 08/02/2019

History

#1 Updated by okurz about 1 year ago

  • Copied from action #45710: [functional][u] test fails in NM_wpa2_enterprise - unable to login into the gnome session again (was: screenlock displays) added

#2 Updated by okurz 12 months ago

  • Blocks action #47321: [qam][opensuse][sporadic] openSUSE Leap 15.0 started failing updates_packagekit_gpk test added

#3 Updated by okurz 12 months ago

  • Blocks action #44153: [functional][u][sporadic] test fails in gnome_control_center - fails to unlock screenlock added

#4 Updated by mgriessmeier 9 months ago

  • Status changed from New to Rejected
  • Assignee set to mgriessmeier
  • Target version changed from Milestone 24 to Milestone 25

not happening for 4 months

#5 Updated by okurz 9 months ago

  • Status changed from Rejected to New

@mgriessmeier I think we misunderstood (again). Already in #45710 the real problem was not adressed, only symptoms. The problem is that the wrong tty is selected. Does not matter if the specified mentioned test looks stable now but the problem is still true. This ticket here is also a blocker to the two mentioned ones so we need to address the whole ticket chain properly. What ticket you use for which particular purpose I will leave to you of course. I came back to this ticket just because @lemon/coolgw asked in https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6768 for feedback which is related.

#6 Updated by okurz 8 months ago

  • Related to action #53246: [desktop][tumbleweed] test fails in yast2_control_center added

#7 Updated by mgriessmeier 8 months ago

  • Target version changed from Milestone 25 to Milestone 26

#8 Updated by mgriessmeier 6 months ago

  • Assignee deleted (mgriessmeier)
  • Priority changed from Normal to High
  • Target version changed from Milestone 26 to Milestone 27

for next grooming

#9 Updated by SLindoMansilla 6 months ago

  • Status changed from New to Rejected
  • Assignee set to mgriessmeier

Considering it resolved, as it was not failing since two months: https://openqa.opensuse.org/tests/1013759#next_previous

#10 Updated by okurz 6 months ago

  • Status changed from Rejected to Workable

again and still #48110#note-5 . This is stated in the subject line as well as the acceptance criteria (someone only messed up the syntax but the text is there). Also the category is "Enhancement". Do we need to make this even more clear?

#11 Updated by mgriessmeier 5 months ago

  • Assignee deleted (mgriessmeier)
  • Target version changed from Milestone 27 to Milestone 28

then let's check this closer...

#12 Updated by szarate 5 months ago

  • Status changed from Workable to New

I'm loving the ping pong on this ticket. Moving back to be groomed

#13 Updated by SLindoMansilla 5 months ago

  • Priority changed from High to Low

Agreed to set it low prio as long as no new occurrence happens.

#14 Updated by SLindoMansilla 5 months ago

  • Subject changed from [functional][u] test failed in NM_wpa2_enterprise unable to login into the gnome session again but we should not even need to login when selecting the correct tty to [functional][u][sporadic] test failed in NM_wpa2_enterprise unable to login into the gnome session again but we should not even need to login when selecting the correct tty
  • Priority changed from Low to Normal

Just found new occurrence: https://openqa.opensuse.org/tests/1030766#step/ooffice/1

testapi::x11_start_program(program='oowriter')
testapi::send_key(key='alt-f2', do_wait=0)

#15 Updated by SLindoMansilla 5 months ago

#16 Updated by SLindoMansilla 5 months ago

  • Priority changed from Normal to High

#17 Updated by SLindoMansilla 5 months ago

  • Subject changed from [functional][u][sporadic] test failed in NM_wpa2_enterprise unable to login into the gnome session again but we should not even need to login when selecting the correct tty to [functional][u][sporadic] test failed in different modules that swtich from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct tty
  • Status changed from New to Workable
  • Priority changed from High to Low
  • Estimated time set to 42.00

#18 Updated by okurz 4 months ago

  • Related to action #36126: [functional][u] post_fail_hook matches on "text_login_root" before actual tty switch and therefore never logs in added

#19 Updated by okurz 3 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: create_hdd_gnome@svirt-xen-pv
https://openqa.suse.de/tests/3648677

To prevent further reminder comments one of the following options should be followed:
1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
2. The openQA job group is moved to "Released"
3. The label in the openQA scenario is removed

#20 Updated by okurz 2 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: create_hdd_gnome@svirt-xen-pv
https://openqa.suse.de/tests/3718200

To prevent further reminder comments one of the following options should be followed:
1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
2. The openQA job group is moved to "Released"
3. The label in the openQA scenario is removed

#21 Updated by mgriessmeier about 1 month ago

  • Target version changed from Milestone 28 to Milestone 31

#22 Updated by okurz about 1 month ago

  • Related to action #57281: [sle][Migration][SLE15SP2] test fails in orphaned_packages_check - switch to tty failed added

#23 Updated by okurz about 1 month ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: create_hdd_gnome@svirt-xen-pv
https://openqa.suse.de/tests/3766980

To prevent further reminder comments one of the following options should be followed:
1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
2. The openQA job group is moved to "Released"
3. The label in the openQA scenario is removed

#24 Updated by okurz about 22 hours ago

  • Subject changed from [functional][u][sporadic] test failed in different modules that swtich from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct tty to [functional][u][sporadic] test failed in different modules that switch from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct tty

I doubt that the assessment from #48110#note-13 was entirely correct. Just because tests didn't immediately fail it doesn't mean that the issue wouldn't happen. I am pretty sure that https://openqa.opensuse.org/tests/1182632 linked to #63670 is an error of the same kind: tests/x11/toolkit/x11.pm calls select_console 'x11' coming from an X11 session but what we do is ask gnome to open another session on tty7 instead of re-using the existing one on tty2. This seems to take much longer than in before in the linked openQA job, probably because it's a common approach to reduce performance with new versions of gnome ;)

I suggest to prioritize this ticket higher again very soon to fix also #63670 and probably also other less well understood unclear issues of the same kind.

#25 Updated by okurz about 22 hours ago

  • Related to action #63727: select_console "log-console" do not try to activate after a previous failure added

#26 Updated by okurz about 22 hours ago

  • Related to action #63643: test fails in consoletest_finish and exiv2 due to failure in x11 console switch added

#27 Updated by okurz about 22 hours ago

  • Related to action #63670: [functional][u] test fails in x11 - black screen added

Also available in: Atom PDF