Project

General

Profile

action #63643

[opensuse] test fails in consoletest_finish and exiv2 due to failure in x11 console switch

Added by ggardet_arm over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-02-20
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.2-DVD-aarch64-system_performance@aarch64 fails in
consoletest_finish

We probably need to leave more time to switch to X11 console, as we are trying to unlock the desktop, whereas the system is just busy to switch to x11 console (see the underscore on top left corner).

Test suite description

Maintainer: okurz@suse.de

An explicit system performance test.

https://progress.opensuse.org/issues/36100

Reproducible

Fails since (at least) Build 98.3

Expected result

Last good: 90.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #63727: [opensuse][ppc64le] select_console "log-console" do not try to activate after a previous failureNew2020-02-21

Related to openQA Tests - action #48110: [functional][u][sporadic] test failed in different modules that switch from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct ttyResolved2019-01-04

Related to openQA Tests - action #63670: [functional][u] test fails in x11 - black screenResolved2020-02-20

Related to openQA Tests - action #63910: [functional][y][sporadic] test fails in remote_controller - ends up on unexpected gdm screenResolved2020-02-272020-03-24

History

#1 Updated by ggardet_arm over 2 years ago

  • Subject changed from test fails in consoletest_finish to test fails in consoletest_finish and exiv2 due to failure in x11 console switch

#2 Updated by okurz over 2 years ago

  • Related to action #63727: [opensuse][ppc64le] select_console "log-console" do not try to activate after a previous failure added

#3 Updated by okurz over 2 years ago

  • Related to action #48110: [functional][u][sporadic] test failed in different modules that switch from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct tty added

#4 Updated by okurz over 2 years ago

  • Related to action #63670: [functional][u] test fails in x11 - black screen added

#5 Updated by okurz over 2 years ago

To me looks like the same as #63670 : Probably a gnome performance regression triggered this but is obfuscated due to #48110

#7 Updated by okurz over 2 years ago

I think the real problem is #48110 and we are better off with a proper fix that ensures that select_console('x11') is effectively a noop when called repeatedly because we should always return to the already running gnome session rather than switch to the tty that has gdm running, asking for login which IIUC automagically moves us to the old tty then.

#9 Updated by okurz over 2 years ago

  • Subject changed from test fails in consoletest_finish and exiv2 due to failure in x11 console switch to [opensuse] test fails in consoletest_finish and exiv2 due to failure in x11 console switch
  • Status changed from New to Resolved
  • Assignee set to ggardet_arm

I know in the end it was just two lines of changes but still you did a great job to actually do it! :) I think you can call this ticket "done", by you, and leave the SLE specifics to #48110 which is still open

#10 Updated by okurz over 2 years ago

  • Related to action #63910: [functional][y][sporadic] test fails in remote_controller - ends up on unexpected gdm screen added

Also available in: Atom PDF