Project

General

Profile

action #53246

[desktop][tumbleweed] test fails in yast2_control_center

Added by zcjia over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-06-18
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

As we discussed in https://bugzilla.opensuse.org/show_bug.cgi?id=1138327 ,

with gdm 3.32, the default terminal for Tumbleweed is changed to tty2, we should adjust test for it.

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_gui@64bit fails in
yast2_control_center

Test suite description

Maintainer: zluo, riafarov

Test for yast2 UI, GUI only. Running on created gnome images which provides both text console for ncurses UI tests as well as the gnome environment for the GUI tests.

Temporarily added YAST2_GUI_TERMINATE_PREVIOUS_INSTANCES to see if helps. This variable triggers code which terminates all yast2 processes before starting new one. (see poo#26104).

Reproducible

Fails since (at least) Build 20190315

Expected result

Last good: 20190313 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #48110: [functional][u][sporadic] test failed in different modules that switch from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct ttyResolved2019-01-04

History

#1 Updated by zcjia over 2 years ago

  • Status changed from New to In Progress

#2 Updated by okurz over 2 years ago

  • Assignee set to zcjia

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7711 merged but please consider my recommendations in the PR comments for a follow-up.

#3 Updated by dimstar over 2 years ago

okurz wrote:

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7711 merged but please consider my recommendations in the PR comments for a follow-up.

Has averse side effects on tests like

there we boot a 42.1/GNOME HDD, switch around to root console and then back to X11 - which at this point we should still switch to VT7, not VT2

#4 Updated by okurz over 2 years ago

  • Related to action #48110: [functional][u][sporadic] test failed in different modules that switch from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct tty added

#6 Updated by zcjia over 2 years ago

  • Status changed from In Progress to Resolved

PR merged and test passed "yast2_control_center" step: https://openqa.opensuse.org/tests/964157

Also available in: Atom PDF