Project

General

Profile

action #63670

[functional][u] test fails in x11 - black screen

Added by lkocman almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 30
Start date:
2020-02-20
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.2-DVD-x86_64-toolkits@64bit fails in
x11

The entire x11/toolkit test suite seems to display just a black screen.
This looks like a test-setup issue as GNOME/KDE/XFCE test are not displaying such an issue.

I've noticed that plymouth startup takes sometimes longer (in my case extra 20 seconds)
https://bugzilla.suse.com/show_bug.cgi?id=1162535
https://bugzilla.opensuse.org/show_bug.cgi?id=1164073

Perhaps that could be the root cause, but please investigate

Test suite description

Maintainer: dheidler@suse.de Test GUI Toolkits

Reproducible

Fails since (at least) Build 581.2 (current job)

Expected result

Last good: 577.2 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #48110: [functional][u][sporadic] test failed in different modules that switch from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct ttyResolved2019-01-04

Related to openQA Tests - action #63643: [opensuse] test fails in consoletest_finish and exiv2 due to failure in x11 console switchResolved2020-02-20

Blocked by openQA Tests - action #63346: [tools][sporadic] false-positive match on "screenlock-xscreensaver-20180821" when instead a console prompt is shownResolved2020-02-10

History

#3 Updated by lkocman almost 3 years ago

libreoffice in KDE seems to be unaffected

#4 Updated by okurz almost 3 years ago

  • Subject changed from test fails in x11 - black screen to [functional][u] test fails in x11 - black screen
  • Description updated (diff)

These tickets really read in a weird way when there is some text above the first header referencing an openQA test result that is also only mentioned afterwards.

lkocman please don't add text before "Observation" but as part of it - like I did now.

#5 Updated by okurz almost 3 years ago

  • Status changed from New to Blocked
  • Assignee set to okurz

The failed step https://openqa.opensuse.org/tests/1180871/modules/x11/steps/23 you referenced is in the post_fail_hook though which can not be the root cause of the problem. You already mentioned potential performance regressions in e.g. plymouth that could explain it. That's good. Still, what I see is a lot of false-positive matches which at least disturb the test flow, e.g. https://openqa.opensuse.org/tests/1180871#step/x11/1 showing a match of "screensaver" when instead there is a logged in text console seen. This I am handling in #63346 so I will track this ticket as "Blocked" and see what issue might be left after I deleted the faulty needle.

#6 Updated by okurz almost 3 years ago

  • Blocked by action #63346: [tools][sporadic] false-positive match on "screenlock-xscreensaver-20180821" when instead a console prompt is shown added

#7 Updated by okurz almost 3 years ago

  • Status changed from Blocked to Workable
  • Assignee changed from okurz to mgriessmeier
  • Priority changed from Normal to High

A retriggered test now fails as expected but in a way more explicit way: https://openqa.opensuse.org/tests/1182632# shows that simply the selection of x11 session doesn't yield a valid desktop in time in https://openqa.opensuse.org/tests/1182632#step/x11/1

After checking in an interactive session in https://openqa.opensuse.org/tests/1182650 I am pretty sure that the issue was triggered by a performance regression in a recent gnome submission to Leap 15.2 but the test had a problem since long which is tracked in #48110 : Simply the wrong tty is selected. tests/x11/toolkit/x11.pm calls select_console 'x11' coming from an X11 session but what we do is ask gnome to open another session on tty7 instead of re-using the existing one on tty2.

mgriessmeier I suggest to prioritize #48110 to have the issue resolved properly soon but you might prefer to handle this ticket instead as a quick fix one.

#8 Updated by okurz almost 3 years ago

  • Related to action #48110: [functional][u][sporadic] test failed in different modules that switch from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct tty added

#9 Updated by okurz almost 3 years ago

  • Related to action #63643: [opensuse] test fails in consoletest_finish and exiv2 due to failure in x11 console switch added

#11 Updated by mgriessmeier over 2 years ago

  • Assignee deleted (mgriessmeier)
  • Target version set to Milestone 30

can be picked up

#12 Updated by okurz over 2 years ago

  • Status changed from Workable to Resolved
  • Assignee set to okurz

This has been covered by ggardet_arm and me in #63643, tests green again: https://openqa.opensuse.org/tests/1191353

Also available in: Atom PDF