Project

General

Profile

action #36126

[functional][u] post_fail_hook matches on "text_login_root" before actual tty switch and therefore never logs in

Added by okurz about 2 years ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA tests - Milestone 28
Start date:
2018-05-14
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-NET-ppc64-minimalx@ppc64 fails in
zypper_up
executing the post_fail_hook trying to match on "tt5-selected" - which should have been the right needle in this case - as well as "text_logged_in_root" which unfortunately matches but should not.

Reproducible

Fails since (at least) Build 20180427

Expected result

Last good: 20180425 (or more recent)

The post_fail_hook should be able to match on tty5-selected and log into that terminal

Suggestions

I assume this can only be a problem when executing tests in console which would fail very early or do not produce much output so that the initial prompt is still visible
We could clear the console before executing a test module after logging on. Or we wait a forced sleep time after executing the console switch so that at least the original should go away even though this also sounds not necessarily save enough.

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #43376: [functional][u] Adapt opensusebasetest to provide dmesg and journal logResolved2018-11-05

Related to openQA Tests - action #44588: [functional][u][svirt] test fails in bootloader_svirt - test started typing before actually logging inResolved2018-11-30

Related to openQA Tests - action #34339: [sle][functional][medium][u] test fails in consoletest_setup - generic text login matching too early, causing mistyping -- was " login prompt not ready to type - missing keys while typing login"Blocked2018-04-05

Related to openQA Tests - action #49649: [functional][u] test fails in logs_from_installation_system - select_console('install-shell') doesn't loginRejected2019-03-25

Related to openQA Tests - action #31132: [sle][functional][u][ipmi][hard] test fails in consoletest_setup - login input is wrongRejected2018-01-31

Related to openQA Tests - action #34471: [functional][opensuse][u][medium] too early matching in too generic needle text-login-20160812New2018-04-08

Related to openQA Tests - action #46508: [functional][u] Ensure to use a clean "extra" console for keymap_or_locale and / or do not try to login (at least on local backends)Workable2019-01-22

Related to openQA Tests - action #48110: [functional][u][sporadic] test failed in different modules that switch from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct ttyResolved2019-01-04

Related to openQA Tests - action #46394: [sle][s390x][spvm][kvm][sporadic] test fails in various modules to login to svirt console (or system is not up yet)Workable

Related to openQA Tests - action #54488: [opensuse][kde][functional][u] test fails in kontact, then fails to login in post_fail_hook. Enable post_fail_hook for collecting logsWorkable2019-07-20

History

#1 Updated by okurz almost 2 years ago

  • Target version changed from Milestone 18 to Milestone 18

#2 Updated by okurz over 1 year ago

  • Target version changed from Milestone 18 to future

#3 Updated by okurz over 1 year ago

  • Related to action #43376: [functional][u] Adapt opensusebasetest to provide dmesg and journal log added

#4 Updated by okurz over 1 year ago

  • Related to action #44588: [functional][u][svirt] test fails in bootloader_svirt - test started typing before actually logging in added

#5 Updated by okurz 8 months ago

  • Related to action #34339: [sle][functional][medium][u] test fails in consoletest_setup - generic text login matching too early, causing mistyping -- was " login prompt not ready to type - missing keys while typing login" added

#6 Updated by okurz 8 months ago

  • Related to action #49649: [functional][u] test fails in logs_from_installation_system - select_console('install-shell') doesn't login added

#7 Updated by okurz 8 months ago

  • Related to action #31132: [sle][functional][u][ipmi][hard] test fails in consoletest_setup - login input is wrong added

#8 Updated by okurz 8 months ago

  • Related to action #34471: [functional][opensuse][u][medium] too early matching in too generic needle text-login-20160812 added

#9 Updated by okurz 8 months ago

  • Related to action #46508: [functional][u] Ensure to use a clean "extra" console for keymap_or_locale and / or do not try to login (at least on local backends) added

#10 Updated by okurz 8 months ago

  • Related to action #48110: [functional][u][sporadic] test failed in different modules that switch from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct tty added

#11 Updated by okurz 8 months ago

  • Related to action #46394: [sle][s390x][spvm][kvm][sporadic] test fails in various modules to login to svirt console (or system is not up yet) added

#12 Updated by okurz 8 months ago

  • Related to action #54488: [opensuse][kde][functional][u] test fails in kontact, then fails to login in post_fail_hook. Enable post_fail_hook for collecting logs added

#13 Updated by zluo 6 months ago

  • Status changed from New to In Progress
  • Assignee set to zluo
  • Target version changed from future to Milestone 28
  • Estimated time set to 42.00 h

take over and check

#14 Updated by zluo 6 months ago

https://openqa.opensuse.org/tests/1092034#next_previous doesn't show problem with pos_fail_hook for failed test module yast2_lan for example.

#15 Updated by okurz 6 months ago

of course not, because the tests do not fail. Please read the description carefully about the word "post_fail_hook". The problem was that if the tests fail – which you can simulate by putting in artificial failures – the post_fail_hook could not do anything useful.

#16 Updated by zluo 6 months ago

delete the old text-logged-in-root and it looks much better by matching text-logged-in-root-20170627 which covers bigger areas and prevent the issue with text-logged-in-root-20151205:

http://f40.suse.de/tests/5541#step/zypper_up/19

#17 Updated by zluo 6 months ago

  • Status changed from In Progress to Feedback

#18 Updated by zluo 6 months ago

  • Status changed from Feedback to Resolved

since the needle PR got merged and there is no issue atm with zypper_up on o3 for quite long time and if it needs to start post_fail_hook for failure, then it is covered now by my needle PR. So set is as resolved for now.

https://openqa.opensuse.org/tests/1103566#next_previous

Also available in: Atom PDF