Project

General

Profile

Actions

action #45710

closed

[functional][u] test fails in NM_wpa2_enterprise - unable to login into the gnome session again (was: screenlock displays)

Added by mlin7442 almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 23
Start date:
2019-01-04
Due date:
2019-02-08
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.1-DVD-x86_64-extra_tests_on_gnome@64bit fails in
NM_wpa2_enterprise

https://openqa.opensuse.org/tests/823304/file/NM_wpa2_enterprise-journal.log

screenlock was there then confused gnome_widget matching. Actually we just switch back from a text console to gdm, we detect that, enter the password in https://openqa.opensuse.org/tests/823304/file/video.ogv#t=126.72,126.74 and that is not accepted.

Reproducible

Fails since (at least) Build 385.1

Expected result

Last good: 383.2 (or more recent)

Suggestions

  • Newer versions of gdm are started twice, on tty2+tty7. If we switch to the "wrong one" we can login and are diverted to the other tty. We should ensure we select the tty where we are already logged in, i.e. we should not expect the user selection screen but the unlock screen of the already logged in user "bernhard"
  • Investigate why we can not login, e.g. take a look into https://openqa.opensuse.org/tests/823304/file/NM_wpa2_enterprise-journal.log at the correct timestamp, potentially report bug
  • Optional: Simplify test scenario and/or modules to not switch back and forth so often between "root-console" and "x11".

Further details

Always latest result in this scenario: latest


Related issues 7 (1 open6 closed)

Related to openQA Tests - action #45131: [functional][u] test fails in worker to unlock the screen of openQA-in-openQA testRejectedmgriessmeier2018-12-13

Actions
Related to openQA Tests - action #40490: [qe-core][functional] Implement test for screensaver and disable it in other scenariosWorkable2018-08-31

Actions
Related to openQA Tests - action #39734: [aarch64] test fails in updates_packagekit_gpk / updates_packagekit_kde due to locked screensaverResolvedggardet_arm2018-08-14

Actions
Related to openQA Tests - action #36652: [sle][functional][u] test fails in first_boot - screensaver already active after boot to desktop?Rejectedokurz2018-05-30

Actions
Has duplicate openQA Tests - action #42740: [functional][u] test fails in NM_wpa2_enterprise - console switch fails because of messages on the consoleRejectedokurz2018-10-21

Actions
Blocks openQA Tests - action #44153: [functional][u][sporadic] test fails in gnome_control_center - fails to unlock screenlockRejectedmgriessmeier2018-11-21

Actions
Copied to openQA Tests - action #48110: [functional][u][sporadic] test failed in different modules that switch from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct ttyResolvedSLindoMansilla2019-01-04

Actions
Actions #1

Updated by agraul almost 5 years ago

  • Subject changed from test fails in NM_wpa2_enterprise - screenlock displays to [functional][u] test fails in NM_wpa2_enterprise - screenlock displays
Actions #2

Updated by okurz almost 5 years ago

  • Related to action #45131: [functional][u] test fails in worker to unlock the screen of openQA-in-openQA test added
Actions #3

Updated by okurz almost 5 years ago

  • Related to action #44153: [functional][u][sporadic] test fails in gnome_control_center - fails to unlock screenlock added
Actions #4

Updated by okurz almost 5 years ago

  • Related to action #40490: [qe-core][functional] Implement test for screensaver and disable it in other scenarios added
Actions #5

Updated by okurz almost 5 years ago

  • Related to action #39734: [aarch64] test fails in updates_packagekit_gpk / updates_packagekit_kde due to locked screensaver added
Actions #6

Updated by okurz almost 5 years ago

  • Related to action #36652: [sle][functional][u] test fails in first_boot - screensaver already active after boot to desktop? added
Actions #7

Updated by okurz almost 5 years ago

  • Priority changed from Normal to High
Actions #8

Updated by okurz almost 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_on_gnome
https://openqa.opensuse.org/tests/841035

Actions #9

Updated by lnussel almost 5 years ago

  • Due date set to 2019-02-08

ping! this keeps failing. we need an ETA for a fix

Actions #10

Updated by okurz almost 5 years ago

  • Status changed from New to Workable
  • Priority changed from High to Urgent
  • Target version set to Milestone 22

Previously with "High" in the backlog of the u-team that meant ETA of 2 weeks to 2 months. Bumping to "urgent". Therefore according to https://progress.opensuse.org/projects/qa/wiki#How-we-work-on-our-backlog means we want to pick the ticket up within 2-3 days and have the "urgency" removed within 1 week.

Actions #11

Updated by okurz almost 5 years ago

  • Subject changed from [functional][u] test fails in NM_wpa2_enterprise - screenlock displays to [functional][u] test fails in NM_wpa2_enterprise - unable to login into the gnome session again (was: screenlock displays)
  • Description updated (diff)
Actions #12

Updated by SLindoMansilla almost 5 years ago

  • Status changed from Workable to In Progress
  • Assignee set to SLindoMansilla

Taking this urgent, because more log in problems.

Maybe need to fix same function and may find same verification problems as https://progress.opensuse.org/issues/46223

Actions #13

Updated by SLindoMansilla almost 5 years ago

Not able to reproduce locally with Build404.2: http://openqa.slindomansilla-vm.qa.suse.de/tests/1202

It didn't fail on last build 406.2: https://openqa.opensuse.org/tests/844167#next_previous

Comparing the video differences make me think that the session simply went to the lock screen.

Actions #14

Updated by SLindoMansilla almost 5 years ago

  • Priority changed from Urgent to High

My bet is that this could improve the problem: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6729

Actions #15

Updated by okurz almost 5 years ago

  • Status changed from In Progress to Workable
  • Assignee deleted (SLindoMansilla)

Hm, I am not exactly sure what fixed the scenario but definitely not your PR as it is not yet merged. https://openqa.opensuse.org/tests/844167 is the latest job that worked again after a longer time. I don't think your PR is a good idea though. The switching to the text terminal and back happens within a minute so the screen shouldn't even be locked unless this is some feature that I do not know about. @SLindoMansilla it seems you have ignored all my suggestions from the description? Leaving for someone else during his absence.

Actions #16

Updated by okurz almost 5 years ago

  • Related to deleted (action #44153: [functional][u][sporadic] test fails in gnome_control_center - fails to unlock screenlock)
Actions #17

Updated by okurz almost 5 years ago

  • Blocks action #44153: [functional][u][sporadic] test fails in gnome_control_center - fails to unlock screenlock added
Actions #18

Updated by okurz almost 5 years ago

  • Target version changed from Milestone 22 to Milestone 23
Actions #19

Updated by szarate almost 5 years ago

Do we run this scenario for SLED?

Actions #20

Updated by okurz almost 5 years ago

Pretty sure we don't

Actions #21

Updated by szarate almost 5 years ago

  • Status changed from Workable to Feedback
  • Assignee set to szarate

I decided to go for a simpler route: Don't switch to the root console :), https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6825

Actions #22

Updated by okurz almost 5 years ago

yes, what I suggested as an alternative. Feel free to extract the part about "switching back to x11 does needs re-login" into another ticket or solve it within this one.

Actions #23

Updated by szarate almost 5 years ago

  • Status changed from Feedback to Resolved

last test did not fail and shows the new behaviour

Actions #24

Updated by okurz almost 5 years ago

  • Copied to action #48110: [functional][u][sporadic] test failed in different modules that switch from textmode terminal to graphical terminal - unable to login into the gnome session again but we should not even need to login when selecting the correct tty added
Actions #25

Updated by okurz almost 5 years ago

ok, I guess you somehow missed my comments so I will create a new ticket for the further improvement. -> #48110

Actions #26

Updated by szarate almost 5 years ago

@okurz sorry! my bad! I was going to put those on a separate ticket, but thanks for taking care!

Actions #27

Updated by okurz almost 5 years ago

  • Has duplicate action #42740: [functional][u] test fails in NM_wpa2_enterprise - console switch fails because of messages on the console added
Actions

Also available in: Atom PDF