Project

General

Profile

action #46223

[functional][u] test fails in user_gui_login - fails to re-login, password not typed or entry field not focussed?

Added by dheidler over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-01-15
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-zdup-Leap-42.2-kde@64bit fails in
user_gui_login

Reproducible

Fails since (at least) Build 20190112

Expected result

Last good: 20190111 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Blocks openQA Tests - action #35589: [functional][u][opensuse][sporadic][medium] test fails in kontact - needs workaround for boo#1105207, then akregator not closedRejected2018-04-26

History

#1 Updated by mgriessmeier over 1 year ago

  • Subject changed from test fails in user_gui_login to [functional][u] test fails in user_gui_login

#2 Updated by okurz over 1 year ago

  • Subject changed from [functional][u] test fails in user_gui_login to [functional][u] test fails in user_gui_login - fails to re-login, password not typed or entry field not focussed?
  • Status changed from New to Workable
  • Priority changed from Normal to Urgent

dheidler you should know better how to write tickets because we just had a lengthy discussion about that yesterday. Please use "catchy subject lines"

#3 Updated by SLindoMansilla over 1 year ago

  • Assignee set to SLindoMansilla

Trying to remove urgency

#4 Updated by SLindoMansilla over 1 year ago

It happens sporadically: https://openqa.opensuse.org/tests/831695#step/user_gui_login/8

  • 6 of 100 in 2 years.

#5 Updated by okurz over 1 year ago

well, no one said we have this issue for long :)

#6 Updated by SLindoMansilla over 1 year ago

Comparing this job where it worked with a failing one:

I can see how the passing one matches the blinking typing-cursor, while the failing one doesn't.
PR to assure focused password textbox: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6596

#7 Updated by SLindoMansilla over 1 year ago

Bug created for recording a soft-failure so we can remove urgency: https://bugzilla.opensuse.org/show_bug.cgi?id=1122664

#9 Updated by SLindoMansilla over 1 year ago

  • Status changed from Workable to Feedback

Waiting for PR to be merged.

#10 Updated by okurz over 1 year ago

PR merged

#11 Updated by okurz over 1 year ago

This became critical due to openSUSE as well as SLE staging tests failing.

#12 Updated by SLindoMansilla over 1 year ago

New PR merged: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6669

Waiting for verification on O3 and OSD

#14 Updated by okurz over 1 year ago

  • Status changed from Resolved to Feedback

That does not work as expected. Please see https://openqa.opensuse.org/tests/843506#step/start_wayland_plasma5/45 as well as https://openqa.opensuse.org/tests/842984#step/user_gui_login/5 which clearly shows a focussed text field. You might want to review the existing needles with the tag "displaymanager-password-prompt"

#15 Updated by okurz over 1 year ago

  • Blocks action #35589: [functional][u][opensuse][sporadic][medium] test fails in kontact - needs workaround for boo#1105207, then akregator not closed added

#16 Updated by SLindoMansilla over 1 year ago

  • Status changed from Feedback to In Progress

#17 Updated by SLindoMansilla over 1 year ago

I was able to reproduce manually that the login doesn't work and brings you back to SDDM.

#18 Updated by SLindoMansilla over 1 year ago

The journal (http://slindomansilla-vm.qa.suse.de/tests/1204/file/start_wayland_plasma5-journal.log) says:

QObject: Cannot create children for a parent that is in a different thread.

It happens with Wayland/KDE, but not with X11/KDE.

I think it could be the same problem I had with nvidia card on SLE using Wayland/GNOME. Investigating...

#20 Updated by okurz over 1 year ago

  • Status changed from In Progress to Feedback

I think I made a mistake and one of the two examples I mentioned is invalid because the wrong machine type is used, "64bit" instead of "64bit_virtio". Also, the latest staging test from the example I mentioned is https://openqa.opensuse.org/tests/846061 which is soft-failed and also the 5 jobs in before. I assume everything is ok now. Maybe someone created a missing needle and we are good for now? Unless you were looking into something further I suggest to set to "Resolved" now.

#21 Updated by okurz over 1 year ago

  • Status changed from Feedback to In Progress

Sorry, I forgot something: https://openqa.opensuse.org/tests/846061 shows a focussed password prompt but the soft-fail still shows up. That needs to be fixed still.

#22 Updated by SLindoMansilla over 1 year ago

My changes are not making it to fail, but a bug. I am waiting for answer here: https://bugzilla.opensuse.org/show_bug.cgi?id=987900
In case I can reuse that ticket or create new one.

Should I create a soft-fail with the workaround to select X11?

#23 Updated by SLindoMansilla over 1 year ago

  • Status changed from In Progress to Resolved

This urgent ticket was already resolved, and the problem seen is actually a bug: https://bugzilla.opensuse.org/show_bug.cgi?id=1124294

I will create a workaround for using X11 and recording a soft-fail.

#24 Updated by okurz over 1 year ago

  • Status changed from Resolved to In Progress

Sorry I am not sure. Did you actually read my last two comments in #46223#note-20 and #46223#note-21 or missed them somehow:

  1. Pretty sure the bug is invalid as described in #46223#note-20
  2. Many many tests are now soft-failing with reference to the bug that the password field would not be focussed but it is, see https://openqa.opensuse.org/tests/846061#step/user_gui_login/6

#25 Updated by SLindoMansilla over 1 year ago

That is a different problem that I didn't notice in your last comment.

The cause is the wrong use of match_has_tag, due to its implementation: https://github.com/os-autoinst/os-autoinst/blob/6ef6a5332bf9df5c5c599a981665715f606b9c0a/testapi.pm#L457

So, while negating it, you can get false positives.

#26 Updated by okurz over 1 year ago

Could you please answer to my assessment that the bug is invalid?

Also, please shift your focus on preventing the many soft-fails in case the password field is actually still focussed.

This ticket is urgent for 21 days now. That is about 5-10 times longer than it should be. We need to handle what is visible in most tests. And this is as of now that nearly every "user_gui_login" test module report as soft_fail in an invalid way.

#27 Updated by SLindoMansilla over 1 year ago

Identified two problems

#28 Updated by mgriessmeier over 1 year ago

  • Assignee changed from SLindoMansilla to okurz

WIP PR by olli is in place, not tested yet.
okurz agreed on deploying new os-autoinst over the weekend to test this pr and u team will revisit this ticket eventually on monday

#29 Updated by okurz over 1 year ago

  • Status changed from In Progress to Feedback

I managed to repair my test instance on lord and could have a verification for: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6728 , see there

#30 Updated by okurz over 1 year ago

  • Status changed from Feedback to Resolved

#31 Updated by okurz about 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_on_kde
https://openqa.opensuse.org/tests/867635

Also available in: Atom PDF