Project

General

Profile

action #39734

[aarch64] test fails in updates_packagekit_gpk / updates_packagekit_kde due to locked screensaver

Added by StefanBruens almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-08-14
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-aarch64-gnome@aarch64 fails in
updates_packagekit_gpk

openQA test in scenario opensuse-Tumbleweed-DVD-aarch64-kde@aarch64 fails in
updates_packagekit_kde

openQA test in scenario opensuse-Tumbleweed-DVD-aarch64-xfce@aarch64 fails in
updates_packagekit_gpk

autoinst.log excerpts for XFCE:

[2018-08-13T20:37:48.0164 CEST] [debug] >>> testapi::_handle_found_needle: found XFCE-desktop-tw-20180716, similarity 1.00 @ 0/0
BYTES {"set_current_test":null,"json_cmd_token":"kJCpdhEp"}
[2018-08-13T20:37:48.0166 CEST] [debug] ||| finished first_boot installation at 2018-08-13 18:37:48 (103 s)
[2018-08-13T20:37:48.0168 CEST] [debug] Creating a VM snapshot lastgood
...
[2018-08-13T20:40:41.0175 CEST] [debug] Migrating remaining bytes: 0
[2018-08-13T20:40:41.0176 CEST] [debug] Snapshot complete
...
[2018-08-13T20:40:41.0193 CEST] [debug] ||| starting zypper_clear_repos tests/update/zypper_clear_repos.pm
...
[2018-08-13T20:41:54.0801 CEST] [debug] ||| finished zypper_clear_repos update at 2018-08-13 18:41:54 (73 s)
[2018-08-13T20:41:54.0803 CEST] [debug] ||| starting zypper_ar tests/console/zypper_ar.pm
...
[2018-08-13T20:42:47.0481 CEST] [debug] ||| finished zypper_ar console at 2018-08-13 18:42:47 (53 s)
[2018-08-13T20:42:47.0483 CEST] [debug] ||| starting zypper_ref tests/console/zypper_ref.pm
...
[2018-08-13T20:43:23.0175 CEST] [debug] ||| finished zypper_ref console at 2018-08-13 18:43:23 (36 s)
[2018-08-13T20:43:23.0177 CEST] [debug] Creating a VM snapshot lastgood
...
[2018-08-13T20:45:33.0183 CEST] [debug] Snapshot complete
[2018-08-13T20:45:33.0204 CEST] [debug] EVENT {"timestamp":{"microseconds":190705,"seconds":1534185933},"event":"RESUME"}
[2018-08-13T20:45:33.0206 CEST] [debug] ||| starting prepare_system_for_update_tests tests/update/prepare_system_for_update_tests.pm
...
[2018-08-13T20:46:22.0131 CEST] [debug] ||| finished prepare_system_for_update_tests update at 2018-08-13 18:46:22 (49 s)
[2018-08-13T20:46:22.0133 CEST] [debug] Creating a VM snapshot lastgood
...
[2018-08-13T20:49:44.0643 CEST] [debug] Snapshot complete
[2018-08-13T20:49:44.0665 CEST] [debug] EVENT {"event":"RESUME","timestamp":{"seconds":1534186184,"microseconds":664408}}
[2018-08-13T20:49:44.0682 CEST] [debug] ||| starting updates_packagekit_gpk tests/update/updates_packagekit_gpk.pm
...

[2018-08-13T20:49:44.0700 CEST] [debug] <<< testapi::select_console(testapi_console='x11', await_console=0)

I.e. it takes about 12 minutes from the last activity on the desktop - login during first_boot - until the X11 session is selected again.
For KDE, there is a 10 minute wall clock difference: https://openqa.opensuse.org/tests/725497#step/first_boot/3 vs https://openqa.opensuse.org/tests/725497#step/updates_packagekit_kde/1

The time is long enough for the screensaver to kick in.

The same test on x86_64 takes about 2 minutes: https://openqa.opensuse.org/tests/724552#step/first_boot/3

Reproducible

Fails since (at least) Build 20180330

Expected result

Last good: 20180322 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #45710: [functional][u] test fails in NM_wpa2_enterprise - unable to login into the gnome session again (was: screenlock displays)Resolved2019-01-042019-02-08

History

#1 Updated by StefanBruens almost 2 years ago

All desktops deactivate the screen locker first during updates_packagekit_{gpk,kde}.

Possible solution:
deactivate the screensaver as part of or immediately after (separate testcase) first_boot

#2 Updated by ggardet_arm almost 2 years ago

  • Status changed from New to In Progress

On a SoftIron Overdrive 1000 (aarch64 system), between firstboot and updates_packagekit_gpk for the XFCE test, I have only 2 minutes with os-autoinst:
[2018-08-17T10:48:31.0837 CEST] [debug] ||| finished first_boot installation at 2018-08-17 08:48:31 (84 s)
...
[2018-08-17T10:50:33.0098 CEST] [debug] ||| starting updates_packagekit_gpk tests/update/updates_packagekit_gpk.pm

Not sure why aarch64 openQA worker is so slow.

Anyway, we can just add ensure_unlocked_desktop to updates_packagekit_* to unlock the screen if needed.
I will test it locally.

#3 Updated by ggardet_arm almost 2 years ago

I made a PR to unlock the screen when needed: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5601

#4 Updated by okurz almost 2 years ago

  • Assignee set to ggardet_arm

PR merged but tests still fail: I think your fix did not work, see https://openqa.opensuse.org/tests/738497#step/updates_packagekit_gpk/2 . first it matches the desktop. in the video we can see the xscreensaver dialog

#5 Updated by ggardet_arm almost 2 years ago

  • Assignee deleted (ggardet_arm)

okurz, it does work, for gnome and kde, but lxde and xfce are missing a needle matching the screenlock. I will prepare such a needle and send a PR.

#6 Updated by ggardet_arm almost 2 years ago

  • Assignee set to ggardet_arm

#8 Updated by StefanBruens almost 2 years ago

There are still some issues:

  1. We may have a blank screen, not the lock/password dialog (LXDE):
    https://openqa.opensuse.org/tests/739620#step/updates_packagekit_gpk/1

  2. Deactivation is not permanent when quit with "xscreensaver-command -exit", screenlock is active after relogin:
    https://openqa.opensuse.org/tests/739615#step/midori/11

sub ensure_installed in lib/susedistribution.pm has no "ensure_unlocked_desktop if DESKTOP not in ['KDE', 'GNOME']".

#9 Updated by ggardet_arm almost 2 years ago

@StefanBruens my PRs were not merged, so your point 1) was expected at that time. I retriggered the test, so let's see if it passes.
For point 2) I created a new ticket: https://progress.opensuse.org/issues/40094

#10 Updated by ggardet_arm over 1 year ago

  • Status changed from In Progress to Resolved

This is fixed now.

#11 Updated by okurz over 1 year ago

  • Related to action #45710: [functional][u] test fails in NM_wpa2_enterprise - unable to login into the gnome session again (was: screenlock displays) added

Also available in: Atom PDF