Project

General

Profile

coordination #33859

[qe-core][sles][functional][saga][s390x] Review s390x Bugs found by IBM and see what can be implemented in the future

Added by mgriessmeier over 3 years ago. Updated 6 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
New test
Target version:
SUSE QA - Milestone 32
Start date:
2018-03-27
Due date:
% Done:

100%

Estimated time:
(Total: 10.00 h)
Difficulty:

Description

User Story

In late february coolo and me were visiting the IBM Regression Testing team in Böblingen to talk about test coverage and unification of our testcase into openQA.
There were two main topics in this meeting. One was about how we can integrate the automated testcases conducted by IBM into openQA (this discussion is still ongoing).

The second, more relevant topic atm, was to talk about Bugs in SLE* which were found by IBM and to see which of the executed scenarios are covered on our side and which are not. It turned out that we lack a lot of test-scenarios and therefore missed some bugs in the product

This ticket is about to collect all those bugs and act on them by creating subtasks for implementing those scenarios step-by-step

Further information

using tags to define those further:

  • [INFRA] - needs to be clarified with Ihno or Gerhard, e.g. Hardware component/setup on system level is missing, blocks other tags
  • [YAST] - Affecting a YaST module, extending YaST module tests for s390x
  • [MANUAL] - Can be verified manually in first place
  • [AUTOMATE] - eligible for being automated in the future
  • [FIXED] - bug is verified fixed

Network

Access & Package*

System hangs

Devices

Others


Subtasks

coordination #33862: [sles][functional][epic][s390x][yast][y] Review and extend test coverage of YaST2 modules on s390x Resolvedriafarov

action #33865: [sles][functional][s390x][easy][y] Enable yast2_ncurses testsuite for s390xResolvedriafarov

coordination #37315: [sle][functional][s390x][yast][y] Review and extend test coverage of YaST2 modules on s390x - epic end trackerRejectedriafarov

action #39344: [functional][y][s390] create new test suite for yast dump moduleResolvedJRivrain

action #54239: [functional][y][s390x] test fails in yast2_lan_restart_devices: bond slaves doesn't show any entriesResolvedriafarov


Related issues

Related to openQA Tests - action #11922: [sle][functional][s390][yast][y][hard] Add AutoYaST tests for s390Resolved2016-05-112018-04-24

History

#2 Updated by mgriessmeier over 3 years ago

note that this user story is not fully described yet

#3 Updated by mgriessmeier over 3 years ago

  • Description updated (diff)

#4 Updated by mgriessmeier over 3 years ago

  • Related to action #11922: [sle][functional][s390][yast][y][hard] Add AutoYaST tests for s390 added

#5 Updated by mgriessmeier over 3 years ago

  • Due date set to 2018-04-10

due to changes in a related task

#6 Updated by okurz over 3 years ago

  • Subject changed from [sles][functional][saga][s390x] Review s390x Bugs found by IBM and see what can be implemented in the future to [sles][functional][saga][s390x][u] Review s390x Bugs found by IBM and see what can be implemented in the future

#7 Updated by mgriessmeier over 3 years ago

  • Description updated (diff)

#8 Updated by okurz over 3 years ago

  • Due date changed from 2018-07-03 to 2018-12-31

due to changes in a related task

#9 Updated by okurz over 3 years ago

  • Target version changed from Milestone 21+ to Milestone 21+

#10 Updated by okurz over 2 years ago

  • Status changed from New to Blocked
  • Assignee set to okurz
  • Target version changed from Milestone 21+ to Milestone 25

-> #33862

#11 Updated by okurz over 2 years ago

  • Assignee changed from okurz to mgriessmeier

mgriessmeier to track as stand-in as discussed.

#12 Updated by riafarov over 2 years ago

  • Due date changed from 2019-06-30 to 2019-07-23

due to changes in a related task

#13 Updated by mgriessmeier about 2 years ago

  • Target version changed from Milestone 25 to Milestone 26

#14 Updated by riafarov about 2 years ago

  • Due date changed from 2019-07-23 to 2019-07-30

due to changes in a related task

#15 Updated by riafarov about 2 years ago

  • Due date changed from 2019-06-30 to 2019-08-13

due to changes in a related task

#16 Updated by mgriessmeier about 2 years ago

  • Target version changed from Milestone 26 to Milestone 27

ongoing

#17 Updated by mgriessmeier about 2 years ago

removed due date to prevent email spam

#18 Updated by riafarov about 2 years ago

  • Due date changed from 2019-09-24 to 2019-06-30

due to changes in a related task

#19 Updated by riafarov about 2 years ago

  • Due date changed from 2019-06-30 to 2020-02-04

due to changes in a related task

#20 Updated by mgriessmeier about 2 years ago

  • Target version changed from Milestone 27 to Milestone 29

#21 Updated by mgriessmeier over 1 year ago

  • Target version changed from Milestone 29 to Milestone 32

#22 Updated by riafarov over 1 year ago

  • Due date changed from 2020-02-04 to 2020-04-07

due to changes in a related task

#23 Updated by riafarov over 1 year ago

  • Due date changed from 2020-04-07 to 2021-01-12

due to changes in a related task

#24 Updated by SLindoMansilla over 1 year ago

  • Assignee changed from mgriessmeier to SLindoMansilla

#25 Updated by SLindoMansilla over 1 year ago

  • Due date changed from 2021-01-12 to 2018-03-27

due to changes in a related task: #33862

#26 Updated by SLindoMansilla over 1 year ago

  • Due date set to 2021-01-12

due to changes in a related task: #33862

#27 Updated by szarate 12 months ago

  • Tracker changed from action to coordination
  • Status changed from Blocked to New

#29 Updated by tjyrinki_suse 11 months ago

  • Subject changed from [sles][functional][saga][s390x][u] Review s390x Bugs found by IBM and see what can be implemented in the future to [qe-core][sles][functional][saga][s390x] Review s390x Bugs found by IBM and see what can be implemented in the future

#30 Updated by SLindoMansilla 6 months ago

  • Assignee deleted (SLindoMansilla)

No time to work on this :(

Also available in: Atom PDF