Project

General

Profile

action #11922

coordination #9572: [sles][functional][autoyast][yast][y][epic]AutoYaST testing - build autoyast.xml and then test

[sle][functional][s390][yast][y][hard] Add AutoYaST tests for s390

Added by mgriessmeier over 5 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Start date:
2016-05-11
Due date:
2018-04-24
% Done:

0%

Estimated time:
Difficulty:

Description

as discussed with Marita, we want to have AutoYaST tested on s390x as well

Acceptance criteria

Tasks

  • Take the easiest autoyast test with the simplest profile and run it on s390x :)

Related issues

Related to openQA Tests - action #29101: [sle][migration][sle15] Upgrade to SLE15 with z/VMResolved2017-12-08

Related to openQA Tests - coordination #33859: [qe-core][sles][functional][saga][s390x] Review s390x Bugs found by IBM and see what can be implemented in the futureNew2018-03-27

Blocked by openQA Tests - action #12330: Upgrades on s390Resolved2016-12-16

History

#1 Updated by mgriessmeier over 5 years ago

  • Status changed from New to In Progress

#2 Updated by okurz about 5 years ago

  • Status changed from In Progress to New

it's not :-)

current problem: shutdown/reboot is not implemented and missing, "reconnect console issue"

#3 Updated by okurz about 5 years ago

#4 Updated by mgriessmeier over 4 years ago

  • Is duplicate of coordination #9572: [sles][functional][autoyast][yast][y][epic]AutoYaST testing - build autoyast.xml and then test added

#5 Updated by mgriessmeier over 4 years ago

  • Subject changed from Add AutoYaST tests for s390 to [sles][functional][s390] Add AutoYaST tests for s390

#6 Updated by mgriessmeier almost 4 years ago

  • Assignee deleted (mgriessmeier)

I'm not working on that - feel free to pick

#7 Updated by okurz almost 4 years ago

  • Subject changed from [sles][functional][s390] Add AutoYaST tests for s390 to [sle][functional][s390] Add AutoYaST tests for s390

#8 Updated by okurz almost 4 years ago

  • Target version set to Milestone 14

#9 Updated by okurz over 3 years ago

  • Subject changed from [sle][functional][s390] Add AutoYaST tests for s390 to [sle][functional][s390][yast] Add AutoYaST tests for s390
  • Description updated (diff)
  • Due date set to 2018-03-13

#10 Updated by okurz over 3 years ago

  • Due date changed from 2018-03-13 to 2018-04-10
  • Target version changed from Milestone 14 to Milestone 15

#11 Updated by okurz over 3 years ago

  • Is duplicate of deleted (coordination #9572: [sles][functional][autoyast][yast][y][epic]AutoYaST testing - build autoyast.xml and then test)

#12 Updated by okurz over 3 years ago

  • Parent task set to #9572

#13 Updated by mitiao over 3 years ago

  • Related to action #29101: [sle][migration][sle15] Upgrade to SLE15 with z/VM added

#14 Updated by riafarov over 3 years ago

  • Description updated (diff)
  • Status changed from New to Workable

#15 Updated by riafarov over 3 years ago

  • Subject changed from [sle][functional][s390][yast] Add AutoYaST tests for s390 to [sle][functional][s390][yast][y] Add AutoYaST tests for s390

#16 Updated by mgriessmeier over 3 years ago

  • Related to coordination #33859: [qe-core][sles][functional][saga][s390x] Review s390x Bugs found by IBM and see what can be implemented in the future added

#17 Updated by mgriessmeier over 3 years ago

  • Description updated (diff)

#18 Updated by riafarov over 3 years ago

  • Assignee set to riafarov

#19 Updated by riafarov over 3 years ago

  • Status changed from Workable to In Progress

#20 Updated by okurz over 3 years ago

  • Subject changed from [sle][functional][s390][yast][y] Add AutoYaST tests for s390 to [sle][functional][s390][yast][y][hard] Add AutoYaST tests for s390

pretty sure it's hard because it's covering so many different domains

#21 Updated by riafarov over 3 years ago

  • Status changed from In Progress to Feedback

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4796

After PR is merged we can enable at least reinstall scenario on zKVM.
Next steps:
Improve logs collection and verify errors during second stage (potentially by checking logs), on top collect logs even if second stage fails.
Enable more scenarios on zVM and zKVM based on profiles from the customers attached above and existing ones. s390x is special and we may either inject s390x specific configuration (e.g. disks configuration, etc.) or have special profiles.

#23 Updated by riafarov over 3 years ago

  • Due date changed from 2018-04-10 to 2018-04-24

#24 Updated by riafarov over 3 years ago

  • Status changed from Feedback to In Progress

Reinstall scenario cannot work as we get static ip address in the profile when configure it. So we should either try existing profile, or use one we had used to test installation locally.

#27 Updated by riafarov over 3 years ago

  • Status changed from In Progress to Feedback

https://openqa.suse.de/tests/1612953#settings test moved from test dev to autoyast job group and triggered.

#28 Updated by riafarov over 3 years ago

  • Status changed from Feedback to Resolved

#29 Updated by okurz over 3 years ago

great achievement. I wonder about AC2, which I did not add. I guess it was mgriessmeier and/or you. Can you comment on these?

Also available in: Atom PDF