action #31375

[sle][functional][ipmi][u][hard] test fails in first_boot - VNC installation on SLE 15 failed because of various issues (ipmi worker, first_boot, boot_from_pxe, await_install)

Added by SLindoMansilla about 2 years ago. Updated 8 months ago.

Status:RejectedStart date:05/02/2018
Priority:NormalDue date:
Assignee:SLindoMansilla% Done:

0%

Category:New test
Target version:SUSE QA tests - Milestone 27
Difficulty:
Duration:

Description

Observation

VNC installation on SLE 15 doesn't provide a running VNC server on installed system.
The test gnome@64bit-ipmi needs adaptions.

openQA test in scenario sle-15-Installer-DVD-x86_64-gnome@64bit-ipmi fails in
first_boot

Acceptance criteria

  • AC1: The test suite gnome@64bit-ipmi passes or fails/soft-fails on a proper product bug.
  • AC2: "installation/first_boot" is not an ugly if-else-backend-specific-stuff mess

Tasks

  • Fix the module first_boot to enable a vncserver on the SUT or connect to it
  • Record a soft-failure for bsc#1073793
  • Make sure the right display manager or login is expected
  • Refactor first_boot to be not an ugly if-else-backend-specific-stuff mess

Reproducible

Fails since (at least) Build 294.1

Expected result

Last good: SLE 12-SP3 Build0314

Further details

Always latest result in this scenario: latest, former 15SP0 latest


Related issues

Related to openQA Tests - action #32746: [sle][tools][remote-backends][hard] Incomplete job becaus... Resolved 05/03/2018
Related to openQA Tests - action #34015: [functional][y][easy] yast2/vnc doesn't have rules for fi... Resolved 29/03/2018 08/05/2018
Related to openQA Project - action #36316: IPMI backend only renders a black screen with openQA-work... Rejected 17/05/2018
Related to openQA Tests - action #38423: [sle][functional][u][hard] Refactor first_boot to unify d... Rejected 16/07/2018
Related to openQA Tests - action #41693: [sle][functional][u][ipmi][sporadic] test fails in boot_f... Rejected 27/09/2018
Related to openQA Tests - action #36027: [sle][functional][u][ipmi] test fails in boot_from_pxe - ... Resolved 20/10/2017
Blocks openQA Tests - action #31132: [sle][functional][u][ipmi][hard] test fails in consoletes... Rejected 31/01/2018
Blocked by openQA Infrastructure - action #41480: [sle][functional][u][ipmi] Malfunction of openqaworker2:2... Resolved 24/09/2018

History

#1 Updated by okurz about 2 years ago

  • Target version set to Milestone 14

#2 Updated by SLindoMansilla about 2 years ago

After manual test of 456.1, a VNC server was running on :1 on the installed system. This ticket could be deprecated.

#3 Updated by okurz about 2 years ago

  • Due date set to 13/03/2018

What do you mean with "This ticket could be deprecated"?

#4 Updated by okurz about 2 years ago

  • Subject changed from [sle][functional] test fails in first_boot - VNC installation on SLE 15 doesn't provide a running VNC server on installed system to [sle][functional][ipmi] test fails in first_boot - VNC installation on SLE 15 is maybe not connected to, we never got that far (was: doesn't provide a running VNC server on installed system)
  • Description updated (diff)
  • Due date changed from 13/03/2018 to 24/04/2018
  • Category changed from Bugs in existing tests to New test
  • Status changed from New to Workable
  • Target version changed from Milestone 14 to Milestone 15

We can see this reproduced in the mentioned scenario

#5 Updated by okurz about 2 years ago

  • Copied to action #32089: [sle][functional][u][ipmi][easy] test fails in first_boot - abort the test early so that we at least test the installation added

#6 Updated by mgriessmeier about 2 years ago

  • Subject changed from [sle][functional][ipmi] test fails in first_boot - VNC installation on SLE 15 is maybe not connected to, we never got that far (was: doesn't provide a running VNC server on installed system) to [sle][functional][ipmi][u] test fails in first_boot - VNC installation on SLE 15 is maybe not connected to, we never got that far (was: doesn't provide a running VNC server on installed system)

#7 Updated by okurz almost 2 years ago

  • Description updated (diff)

Talked with slindomansilla, https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4678 is fine to fix #32089 but now first_boot is getting ugly. Updated the description to ensure we work on refactoring the code.

#8 Updated by okurz almost 2 years ago

slindomansilla really wants to keep it and work on it during the time. The scenario "gnome@ipmi" is not there anymore for SLE15 as of now. Could be I have scheduled "default@ipmi" instead. If not please add gnome@ipmi back.

#9 Updated by okurz almost 2 years ago

  • Subject changed from [sle][functional][ipmi][u] test fails in first_boot - VNC installation on SLE 15 is maybe not connected to, we never got that far (was: doesn't provide a running VNC server on installed system) to [sle][functional][ipmi][u][hard] test fails in first_boot - VNC installation on SLE 15 is maybe not connected to, we never got that far (was: doesn't provide a running VNC server on installed system)

#10 Updated by SLindoMansilla almost 2 years ago

  • Copied to deleted (action #32089: [sle][functional][u][ipmi][easy] test fails in first_boot - abort the test early so that we at least test the installation)

#11 Updated by SLindoMansilla almost 2 years ago

  • Related to action #32089: [sle][functional][u][ipmi][easy] test fails in first_boot - abort the test early so that we at least test the installation added

#12 Updated by SLindoMansilla almost 2 years ago

  • Related to action #23650: [sle][functional][ipmi][epic][u] Fix test suite gnome to work on ipmi 12-SP3 and 15 (WAS: test fails in boot_from_pxe - connection refused trying to ipmi host over ssh?) added

#13 Updated by SLindoMansilla almost 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to SLindoMansilla

#14 Updated by mgriessmeier almost 2 years ago

  • Due date changed from 24/04/2018 to 08/05/2018
  • Target version changed from Milestone 15 to Milestone 16

#15 Updated by SLindoMansilla almost 2 years ago

  • Related to action #32746: [sle][tools][remote-backends][hard] Incomplete job because console isn't responding correctly. Half-open socket on IPMI added

#16 Updated by SLindoMansilla almost 2 years ago

  • Blocks action #31132: [sle][functional][u][ipmi][hard] test fails in consoletest_setup - login input is wrong added

#17 Updated by SLindoMansilla almost 2 years ago

  • Priority changed from Normal to High

Because it is blocking a high prio ticket.

#19 Updated by SLindoMansilla almost 2 years ago

  • Related to action #34015: [functional][y][easy] yast2/vnc doesn't have rules for firewalld -> workaround for bsc#1088647 added

#20 Updated by mgriessmeier almost 2 years ago

  • Due date changed from 08/05/2018 to 22/05/2018

#21 Updated by SLindoMansilla almost 2 years ago

  • Status changed from In Progress to Workable

Problems with IPMI machines:

  • openqaw4-sp.qa.suse.de
  • sonic-sp.qa.suse.de

szarate and nsinger are investigating the issue.

#22 Updated by SLindoMansilla almost 2 years ago

  • Related to action #36316: IPMI backend only renders a black screen with openQA-worker-4.5.1526033850.1ad9148d-79.1 added

#23 Updated by mgriessmeier almost 2 years ago

  • Due date changed from 22/05/2018 to 05/06/2018

AppArmor profile got fixed -> workable for upcoming sprint

#24 Updated by mgriessmeier almost 2 years ago

  • Due date changed from 05/06/2018 to 17/07/2018
  • Assignee deleted (SLindoMansilla)
  • Priority changed from High to Normal
  • Target version changed from Milestone 16 to Milestone 17

We should work on better error reporting first, before doing this one

#25 Updated by okurz almost 2 years ago

  • Related to action #36027: [sle][functional][u][ipmi] test fails in boot_from_pxe - pxe boot menu doesn't show up at all added

#26 Updated by okurz almost 2 years ago

  • Target version changed from Milestone 17 to Milestone 17

#27 Updated by okurz almost 2 years ago

  • Target version changed from Milestone 17 to Milestone 18

#28 Updated by okurz almost 2 years ago

  • Due date changed from 17/07/2018 to 31/07/2018

It's hackweek time!

#29 Updated by okurz over 1 year ago

  • Due date deleted (31/07/2018)
  • Target version changed from Milestone 18 to Milestone 19

#30 Updated by okurz over 1 year ago

  • Due date set to 28/08/2018
  • Target version changed from Milestone 19 to Milestone 18

Let's see if we can do this in S24 to unblock #37339

#31 Updated by okurz over 1 year ago

  • Target version changed from Milestone 18 to Milestone 19

well, we could not.

#32 Updated by okurz over 1 year ago

  • Due date changed from 28/08/2018 to 11/09/2018

#33 Updated by mgriessmeier over 1 year ago

  • Related to action #38423: [sle][functional][u][hard] Refactor first_boot to unify duplicated behavior for remote backend added

#34 Updated by mgriessmeier over 1 year ago

blocked by "Test does not reach that step in 15-SP1" -> TODO: create ticket for https://openqa.suse.de/tests/latest?test=default&distri=sle&version=15-SP1&machine=64bit-ipmi&arch=x86_64&flavor=Installer-DVD# and update link to latest

#35 Updated by zluo over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over and checking test runs locally.

#36 Updated by zluo over 1 year ago

workaround locally to get through welcome test module, but now I have problem with grub_test:

http://e13.suse.de/tests/7945#step/grub_test

#37 Updated by zluo over 1 year ago

http://e13.suse.de/tests/7946#step/first_boot/1

shows successful test run for first_boot of sles 15 sp1

#38 Updated by zluo over 1 year ago

http://e13.suse.de/tests/7947#step/first_boot/1

looks good now as well after I create new needle: grub2 (login_console-grub2-for-sles12-ipmi-20180831)

#40 Updated by zluo over 1 year ago

http://e13.suse.de/tests/latest?version=12-SP4&machine=64bit-ipmi&distri=sle&flavor=Server-DVD&test=default&arch=x86_64#next_previous

shows now stable tests results, I use workaround for boot option(characters limitation) in bootloader_setup.pm:

# Enable linuxrc core dumps https://en.opensuse.org/SDB:Linuxrc#p_linuxrccore
type_string_very_slow "linuxrc.core=/dev/$serialdev " unless $args{pxe};
type_string_very_slow "linuxrc.debug=4,trace " unless $args{pxe};

#41 Updated by zluo over 1 year ago

  • Status changed from In Progress to Resolved

resolved. new created needle helps :)

https://openqa.suse.de/tests/2028710#step/first_boot/12

#42 Updated by okurz over 1 year ago

  • Due date changed from 11/09/2018 to 25/09/2018
  • Status changed from Resolved to In Progress

sorry, I don't see it as done. The ticket references SLE15, not SLE12. #31375#note-34 mentions the idea to split the ticket but as long as this is not done the current ticket can also not be done. Also AC2 is not attended. Please see the ACs and the proper link to latest. Also, https://openqa.suse.de/tests/latest?flavor=Installer-DVD&test=gnome&arch=x86_64&distri=sle&version=15-SP1&machine=64bit-ipmi#next_previous shows that we have tests on 15SP1 which are all failing in an earlier step, the job is in test development, and no job is labeled -> not done.

#44 Updated by zluo over 1 year ago

https://openqa.suse.de/tests/2039165# shows grub_test failed.

#45 Updated by zluo over 1 year ago

https://openqa.suse.de/tests/2039165# shows grub_test failed.

but on my our ipmi machine it just works fine:
http://e13.suse.de/tests/8091#step/first_boot/14

So I assume strongly that we have problem with hardware performance on osd.

Will run more test runs for this for now to be sure that is related to hardware...

#46 Updated by zluo over 1 year ago

openqaworker13:3 on osd has problem with boot from disk, just for record.

#47 Updated by okurz over 1 year ago

zluo wrote:

So I assume strongly that we have problem with hardware performance on osd.

as always, this could be true but then we need to gather more data to point in the direction of what is at fault or what would need to be changed.

#48 Updated by zluo over 1 year ago

https://openqa.suse.de/tests/2039347#step/first_boot/4

shows this time grub menu and entries, but still failed for linux_login.

Compared with my cloned tests:

http://e13.suse.de/tests/8093#next_previous

no issue at all.

Need to collect more examples for now.

#49 Updated by zluo over 1 year ago

created gnome-first_boot_on-ipmi@64bit-ipmi on osd:

https://openqa.suse.de/tests/2039612#next_previous

#50 Updated by zluo over 1 year ago

https://openqa.suse.de/tests/2039612#next_previous shows issues for boot_from_pxe, grub_test.

first_boot reached, but got connection issue:

https://openqa.suse.de/tests/2039613#step/first_boot/4

or could not boot up:
https://openqa.suse.de/tests/2039616#step/first_boot/4

#51 Updated by zluo over 1 year ago

The test runs on osd above mentioned shows issues with ipmi worker and connection issue.

#52 Updated by nicksinger over 1 year ago

zluo wrote:

https://openqa.suse.de/tests/2039347#step/first_boot/4


shows this time grub menu and entries, but still failed for linux_login.


Compared with my cloned tests:


http://e13.suse.de/tests/8093#next_previous


no issue at all.


Need to collect more examples for now.

I had a look in the morning with @mgriessmeier at this. We figured out that grub_test should actually send return to confirm booting from HDD. first_boot should only wait for the login manager and should not handle the bootloader at all. Why it worked on your machine is unclear to me but I guess you maybe just created another needle.
I'll open a poo for this.

#53 Updated by zluo over 1 year ago

@nsinger needle PR got merged a week ago: https://gitlab.suse.de/openqa/os-autoinst-needles-sles/merge_requests/923

So it should be available on osd as well. And some tests on osd reached firs_boot as well.

#55 Updated by zluo over 1 year ago

started 20 times test runs: https://openqa.suse.de/tests/2073161#next_previous

https://openqa.suse.de/tests/2073160 shows successful test run.
but we still have other issue: connection refused, so this is setup or network issue which doesn't have to do with initial problem here.

#56 Updated by zluo over 1 year ago

openqaworker2 makes trouble as I can see.

#57 Updated by zluo over 1 year ago

gonzo.qa.suse.de

2018-09-19T14:47:17.0319 CEST] [debug] <<< testapi::select_console(testapi_console='x11')
/usr/lib/os-autoinst/consoles/vnc_base.pm:71:{
'password' => 'nots3cr3t',
'port' => 5901,
'hostname' => 'gonzo.qa.suse.de'
}
[2018-09-19T14:47:19.0327 CEST] [debug] Error connecting to host : IO::Socket::INET: connect: Connection refused
[2018-09-19T14:47:20.0328 CEST] [debug] Error connecting to host : IO::Socket::INET: connect: Connection refused
[2018-09-19T14:47:21.0329 CEST] [debug] Error connecting to host : IO::Socket::INET: connect: Connection refused
[2018-09-19T14:47:22.0331 CEST] [debug] Error connecting to host : IO::Socket::INET: connect: Connection refused
[2018-09-19T14:47:23.0332 CEST] [debug] Error connecting to host : IO::Socket::INET: connect: Connection refused
[2018-09-19T14:47:24.0334 CEST] [debug] Error connecting to host : IO::Socket::INET: connect: Connection refused
[2018-09-19T14:47:25.0335 CEST] [debug] Error connecting to host : IO::Socket::INET: connect: Connection refused
[2018-09-19T14:47:26.0336 CEST] [debug] Error connecting to host : IO::Socket::INET: connect: Connection refused
[2018-09-19T14:47:27.0461 CEST] [debug] Error connecting to host : IO::Socket::INET: connect: Connection refused at /usr/lib/os-autoinst/testapi.pm line 1416.

#58 Updated by zluo over 1 year ago

https://openqa.suse.de/tests/2073157#step/grub_test/3 shows a different issue fro grub_test: openqaworker13:3

#59 Updated by zluo over 1 year ago

https://openqa.suse.de/tests/2079399#step/boot_from_pxe/27 shows boot_from_pxe has problem with repo url.

#61 Updated by zluo over 1 year ago

  • Status changed from In Progress to Feedback

https://openqa.suse.de/tests/2080143#next_previous shows more test runs which failed because of openqaworker2:25

So will open another ticket for ipmi sserver issue.

#63 Updated by okurz over 1 year ago

  • Blocked by action #41480: [sle][functional][u][ipmi] Malfunction of openqaworker2:25 - Investigate, bring it back or repair it (WAS: remove openqaworker2:25 (IPMI machine) from OSD testing) added

#64 Updated by okurz over 1 year ago

  • Status changed from Feedback to Blocked

To me it looks like we are "blocked" by #41480

#65 Updated by SLindoMansilla over 1 year ago

  • Due date changed from 25/09/2018 to 09/10/2018

Moving to sprint 27. Not able to unblock it during sprint 26.
Blocking ticket is waiting for feedback on a PR.

#66 Updated by zluo over 1 year ago

  • Related to action #41693: [sle][functional][u][ipmi][sporadic] test fails in boot_from_pxe - needs to increase ssh_vnc_wait_time added

#67 Updated by zluo over 1 year ago

  • Status changed from Blocked to In Progress

#68 Updated by zluo over 1 year ago

http://e13.suse.de/tests/8632#step/first_boot/3

shows problem with first_boot. This is sporadic however.

#69 Updated by zluo over 1 year ago

my $boot_timeout = (get_var('SES5_DEPLOY') || check_var('VIRSH_VMM_FAMILY', 'hyperv')) ? 450 : 200;
# SLE >= 15 s390x does not offer auto-started VNC server in SUT, only login prompt as in textmode
return if check_var('ARCH', 's390x') && sle_version_at_least('15');
if (check_var('WORKER_CLASS', 'hornet')) {
# hornet does not show the console output
diag "waiting $boot_timeout seconds to let hornet boot and finish initial script";
sleep $boot_timeout;
reset_consoles;
select_console 'root-ssh';
return;
}

boot_timeout 200 seems to be not enough here. I also the same issue on osd:
https://openqa.suse.de/tests/2104272#step/first_boot/3

#70 Updated by okurz over 1 year ago

Pretty sure no timeout will be enough when you are stuck in the grub menu and something like return key is not sent :)

#71 Updated by zluo over 1 year ago

http://e13.suse.de/tests/8705#step/await_install/4 shows a new issue but this is an other product issue. Will file a bug report.

PR for increase boot_timeout:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5851

#72 Updated by zluo over 1 year ago

bug report for the issue with await_install(mount issue):

https://bugzilla.suse.com/show_bug.cgi?id=1110283

#73 Updated by zluo over 1 year ago

  • Subject changed from [sle][functional][ipmi][u][hard] test fails in first_boot - VNC installation on SLE 15 is maybe not connected to, we never got that far (was: doesn't provide a running VNC server on installed system) to [sle][functional][ipmi][u][hard] test fails in first_boot - VNC installation on SLE 15 failed because of various issues (ipmi worker, first_boot, boot_from_pxe, await_install)

#74 Updated by zluo over 1 year ago

we have rare problem for boot_from_pxe:

http://e13.suse.de/tests/8700#step/boot_from_pxe/30

screen is overflooded with SUSE Linux Enterprise 15.
I see string: Unexpected response: >>w<<

[2018-09-29T12:53:39.0582 CEST] [debug] <<< testapi::send_key(key='alt-sysrq-w', do_wait=0)
BYTES {"json_cmd_token":"QmlwrkXY","send_key":{"key":"alt-sysrq-w","json_cmd_token":"Dxyiclri"}}
[2018-09-29T12:53:39.0788 CEST] [debug] <<< testapi::wait_serial(regexp='SysRq : Show Blocked State', timeout=1)

So for this case I suspect ipmi machine got problem with loading files, it is probably a network issue at this moment.

#75 Updated by zluo over 1 year ago

We can see after fail:

Loading basic drivers...exec: insmod /modules/af_paclet.ko = 0

So it means ssh_vnc_wait_time = 300 is still not enough...

#76 Updated by okurz over 1 year ago

zluo wrote:

I see string: Unexpected response: >>w<<

[…]

So for this case I suspect ipmi machine got problem with loading files, it is probably a network issue at this moment.

What files are you talking about? This key press is happening in the post_fail_hook so can not be the real issue. https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5769 introduced this magic-sysrq-keypress. dheidler worked on that. AFAIR he planned to exclude it from triggering on IPMI.

#77 Updated by zluo over 1 year ago

"Loading basic drivers...exec: insmod /modules/af_paclet.ko = 0" shows up, this is what I mean

yes, magic-sysrq-keypress should not confuse in this case/on ipmi, thanks.

#78 Updated by zluo over 1 year ago

compared with successful test run http://e13.suse.de/tests/8728:

After loading basic drivers...exec: insmod /modues/af_packet.ko = 0

the whole modules cannot be loaded. I found 2 errors but they don't seem to have impact on booting up to VNC stage

#79 Updated by zluo over 1 year ago

It looks already much better, but it failed still sporadic:

http://e13.suse.de/tests/8846#step/boot_from_pxe/30

will try with 450 for ipmi now:

my $ssh_vnc_wait_time = (check_var('BACKEND', 'ipmi')) ? 450 : 300;

#80 Updated by zluo over 1 year ago

http://e13.suse.de/tests/8855#next_previous shows green status except boot_from_pxe.

It means that first_boot doesn't fail.

#81 Updated by zluo over 1 year ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5851/files

changes for ipmi only:

my $boot_timeout = (get_var('SES5_DEPLOY') || check_var('VIRSH_VMM_FAMILY', 'hyperv') || check_var('BACKEND', 'ipmi')) ? 450 : 200;

#82 Updated by okurz over 1 year ago

PR merged, changes deployed to osd. Could you follow https://progress.opensuse.org/projects/openqatests/wiki/Wiki#Statistical-investigation and trigger some more tests on osd to check statistics?

#83 Updated by okurz over 1 year ago

  • Description updated (diff)

Regarding http://e13.suse.de/tests/8855# please keep in mind that this ticket was and is still about gnome@ipmi which we need to have fixed in the end. https://openqa.suse.de/tests/2111451 shows the most recent test that could reach the furthest, ending up in the vim module. However, most of the tests fail in either first_boot or qa_net_boot_from_hdd as e.g. https://openqa.suse.de/tests/2116869

#84 Updated by zluo over 1 year ago

mark this test run on osd: https://openqa.suse.de/tests/2122654#

Will check this later.

#85 Updated by zluo over 1 year ago

#86 Updated by zluo over 1 year ago

check on my local machine: http://e13.suse.de/tests/9147

and restart on osd: https://openqa.suse.de/tests/2123010

#89 Updated by zluo over 1 year ago

https://openqa.suse.de/tests/2122251#step/first_boot/5 shows a another issue again:

[2018-10-04T15:05:33.0518 CEST] [debug] Error connecting to host : IO::Socket::INET: connect: Connection refused

https://progress.opensuse.org/issues/31375#note-57

#90 Updated by zluo over 1 year ago

remote_slave_ready-ipmi-20171023.json is mtaching for needle tag vnc-server-started at: http://e13.suse.de/tests/9170#step/boot_from_pxe/7

but now it failed:

https://openqa.suse.de/tests/2123037#step/boot_from_pxe/30

#91 Updated by zluo over 1 year ago

https://openqa.suse.de/tests/2122457 shows that it works fine.

https://openqa.suse.de/tests/2127922#step/partitioning_filesystem/6 shows partitioning_filesystem has failed in build 62.6, but this is an another issue.

I think the original issue with first_boot got resolved. And the issue with boot_from_pxe still remained, but we continue on it: https://progress.opensuse.org/issues/41693

#92 Updated by zluo over 1 year ago

  • Category changed from New test to Bugs in existing tests

changed category wrongly, correct it now.

#93 Updated by okurz over 1 year ago

  • Category changed from Bugs in existing tests to New test

Don't worry. I set "New test" to show that it never worked properly and it's basically an extension to the test coverage we have :)

zluo wrote:

I think the original issue with first_boot got resolved.

Well, then we should have the statistics to support this hypothesis. As discussed in the daily, feel free to unassign.

#94 Updated by zluo over 1 year ago

  • Assignee deleted (zluo)

okay, let's see if someone can work on this issue, thanks.

There are still tests running and the test results might be helpful to us:

http://e13.suse.de/tests/9379#step/boot_from_pxe/35 shows one problem which needs to be resolved at first.

http://e13.suse.de/tests/9379#next_previous show also other problems

#95 Updated by okurz over 1 year ago

  • Due date deleted (09/10/2018)
  • Status changed from In Progress to Workable
  • Target version changed from Milestone 19 to Milestone 22

I think we should work on boot_from_pxe first in #41693 and then care about first_boot again.

#96 Updated by SLindoMansilla over 1 year ago

  • Status changed from Workable to Blocked
  • Assignee set to SLindoMansilla

Make BOOT_FROM_PXE stable first to be able to continue.

Assigning myself as tracker.

#97 Updated by SLindoMansilla over 1 year ago

  • Related to deleted (action #36027: [sle][functional][u][ipmi] test fails in boot_from_pxe - pxe boot menu doesn't show up at all)

#98 Updated by SLindoMansilla over 1 year ago

  • Related to deleted (action #23650: [sle][functional][ipmi][epic][u] Fix test suite gnome to work on ipmi 12-SP3 and 15 (WAS: test fails in boot_from_pxe - connection refused trying to ipmi host over ssh?))

#99 Updated by SLindoMansilla over 1 year ago

  • Parent task set to #36027

#100 Updated by SLindoMansilla over 1 year ago

  • Parent task deleted (#36027)

#101 Updated by SLindoMansilla over 1 year ago

  • Blocked by action #36027: [sle][functional][u][ipmi] test fails in boot_from_pxe - pxe boot menu doesn't show up at all added

#102 Updated by SLindoMansilla over 1 year ago

  • Related to deleted (action #32089: [sle][functional][u][ipmi][easy] test fails in first_boot - abort the test early so that we at least test the installation)

#103 Updated by SLindoMansilla over 1 year ago

  • Blocked by deleted (action #36027: [sle][functional][u][ipmi] test fails in boot_from_pxe - pxe boot menu doesn't show up at all)

#104 Updated by SLindoMansilla over 1 year ago

Trying to make this ticket a subticket of: #23650

#105 Updated by SLindoMansilla over 1 year ago

  • Blocked by action #36027: [sle][functional][u][ipmi] test fails in boot_from_pxe - pxe boot menu doesn't show up at all added

#106 Updated by pvorel over 1 year ago

We have timeout problem on first_boot on LTP on ipmi backend:
https://openqa.suse.de/tests/2262596#step/first_boot/2
Any idea what that caused?
Problem was with GRUB_TIMEOUT setting first to 300 (good for IPMI) and even with 900.

#107 Updated by okurz over 1 year ago

@pvorel I think this is neither #42863, this ticket, nor #31375, rather its own, new thing. The 'ret' key in the grub screen does not have an effect. Better track as its own issue.

#108 Updated by okurz about 1 year ago

  • Target version changed from Milestone 22 to Milestone 25+

#109 Updated by okurz about 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default@64bit-ipmi
https://openqa.suse.de/tests/2522783

#110 Updated by okurz about 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default@64bit-ipmi
https://openqa.suse.de/tests/2745480

#111 Updated by okurz 12 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default@64bit-ipmi
https://openqa.suse.de/tests/2799086

#112 Updated by okurz 11 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default@64bit-ipmi
https://openqa.suse.de/tests/2826516

#113 Updated by okurz 11 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default@64bit-ipmi
https://openqa.suse.de/tests/2890123

#114 Updated by mgriessmeier 11 months ago

  • Target version changed from Milestone 25+ to Milestone 27

#115 Updated by okurz 10 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default@64bit-ipmi
https://openqa.suse.de/tests/2915078

#116 Updated by okurz 10 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default@64bit-ipmi
https://openqa.suse.de/tests/2974778

#117 Updated by okurz 9 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default@64bit-ipmi
https://openqa.suse.de/tests/2992439

#118 Updated by okurz 9 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default@64bit-ipmi
https://openqa.suse.de/tests/3058673

#119 Updated by okurz 8 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default@64bit-ipmi
https://openqa.suse.de/tests/3159955

#120 Updated by okurz 8 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default@64bit-ipmi
https://openqa.suse.de/tests/3227997

#121 Updated by SLindoMansilla 8 months ago

  • Blocked by deleted (action #36027: [sle][functional][u][ipmi] test fails in boot_from_pxe - pxe boot menu doesn't show up at all)

#122 Updated by SLindoMansilla 8 months ago

  • Status changed from Blocked to Rejected

Let's reject this in favor of: #38423

#123 Updated by SLindoMansilla 8 months ago

  • Related to action #36027: [sle][functional][u][ipmi] test fails in boot_from_pxe - pxe boot menu doesn't show up at all added

Also available in: Atom PDF