Project

General

Profile

action #32089

action #23650: [sle][functional][ipmi][epic][u] Fix test suite gnome to work on ipmi 12-SP3 and 15 (WAS: test fails in boot_from_pxe - connection refused trying to ipmi host over ssh?)

[sle][functional][u][ipmi][easy] test fails in first_boot - abort the test early so that we at least test the installation

Added by okurz over 2 years ago. Updated 11 months ago.

Status:
Resolved
Priority:
High
Category:
New test
Start date:
2018-02-05
Due date:
% Done:

0%

Estimated time:
Difficulty:
easy
Duration:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-gnome@64bit-ipmi fails in
first_boot

Acceptance criteria

  • AC1: test soft-fails or passes
  • AC2: No super-cool adaptions except for early-abort, rest of the work goes into #31375

Tasks

  • Abort the test as soon as the system has booted, regardless if it's gdm or getty
  • Rest is done in #31375

Reproducible

Fails since (at least) Build 294.1

Expected result

Last good: SLE 12-SP3 Build0314

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #33556: [sle][functional][y][yast][ipmi]New test scenario: textmode+kvm_server_role@ipmiBlocked2018-03-21

Related to openQA Tests - action #32746: [sle][tools][remote-backends][hard] Incomplete job because console isn't responding correctly. Half-open socket on IPMIResolved2018-03-05

Related to openQA Tests - action #31132: [sle][functional][u][ipmi][hard] test fails in consoletest_setup - login input is wrongRejected2018-01-31

Related to openQA Tests - action #37820: [functional][sle][u][hard][ipmi][sporadic] test fails in first_boot - Lost connection to SUT on SLE12-SP4Resolved2018-06-262018-07-17

History

#1 Updated by okurz over 2 years ago

  • Copied from action #31375: [sle][functional][ipmi][u][hard] test fails in first_boot - VNC installation on SLE 15 failed because of various issues (ipmi worker, first_boot, boot_from_pxe, await_install) added

#2 Updated by okurz over 2 years ago

  • Blocks action #31132: [sle][functional][u][ipmi][hard] test fails in consoletest_setup - login input is wrong added

#3 Updated by SLindoMansilla about 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to SLindoMansilla

#4 Updated by SLindoMansilla about 2 years ago

  • Parent task set to #23650

#5 Updated by SLindoMansilla about 2 years ago

Trying with DESKTOP=textmode: http://copland.arch.suse.de/tests/942

#7 Updated by SLindoMansilla about 2 years ago

Trying with DESKTOP=textmode and INSTALLONLY=1: http://copland.arch.suse.de/tests/946

#8 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-03-13 to 2018-03-27
  • Status changed from In Progress to Blocked
  • Target version changed from Milestone 14 to Milestone 15

#9 Updated by okurz about 2 years ago

  • Subject changed from [sle][functional][ipmi][easy] test fails in first_boot - abort the test early so that we at least test the installation to [sle][functional][u][ipmi][easy] test fails in first_boot - abort the test early so that we at least test the installation
  • Status changed from Blocked to Workable

as SLindoMansilla described in SP there should be a way to continue, regarding making use of the vnc server+client.

#10 Updated by SLindoMansilla about 2 years ago

  • Status changed from Workable to In Progress

#11 Updated by SLindoMansilla about 2 years ago

The original expected behavior is to boot from graphical display: https://openqa.suse.de/tests/857605#step/qa_net_boot_from_hdd/1

When the VNC server was missing, the test stop working and I made a workaround to select the sol console. This makes the worker to control the SUT over serial console, also textmode.

I have to learn how the ipmi backend works and how it connected to the vnc server before, since now there is again a VNC server, actually a systemd socket listening on display :1 (port 5901), and try to connect to it and maintain the same behavior as before.

#12 Updated by okurz about 2 years ago

  • Priority changed from Normal to High

considering all subsequent tickets which are blocked by this here I raise prio to high. Also this chain of tickets is important to help our neighbouring team "QA SLE virtualization" with #33136

#13 Updated by SLindoMansilla about 2 years ago

I am having problems with our shared IPMI workers on QA-SLE-Functional. This is making me going slower.
There are sporadic failures that breaks the test and I have to start again from the beggining, wasting a lot of time.

#14 Updated by SLindoMansilla about 2 years ago

  • Related to action #33556: [sle][functional][y][yast][ipmi]New test scenario: textmode+kvm_server_role@ipmi added

#15 Updated by SLindoMansilla about 2 years ago

Ok, today the IPMI workers performed better.

I am very closed to fix gnome@ipmi: http://copland.arch.suse.de/tests/1014#step/first_boot/7

#17 Updated by SLindoMansilla about 2 years ago

  • Status changed from In Progress to Feedback

#18 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-03-27 to 2018-04-10

#19 Updated by okurz about 2 years ago

  • Status changed from Feedback to Workable
  • Assignee deleted (SLindoMansilla)

SLindoMansilla is in vacation, the PR has some comments. Can be picked up and worked in another PR if we want - or wait for @slindomansilla.

#20 Updated by cwh about 2 years ago

  • Difficulty set to easy

#21 Updated by SLindoMansilla about 2 years ago

  • Status changed from Workable to Feedback
  • Assignee set to SLindoMansilla

It seems that nobody took this. So, taking again.
PR updated. Please, review.

#22 Updated by SLindoMansilla about 2 years ago

PR merged, waiting for verification run on OSD:

#23 Updated by SLindoMansilla about 2 years ago

No setting DESKTOP=gnome on default@ipmi. That makes the test module to not select x11 console:

We need to set that setting or check for !textmode.

#24 Updated by SLindoMansilla about 2 years ago

Checking for !textmode

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4804

Wrong, default is textmode.
Test suite gnome@ipmi is missing.

#25 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-04-10 to 2018-04-24

#26 Updated by SLindoMansilla about 2 years ago

  • Copied from deleted (action #31375: [sle][functional][ipmi][u][hard] test fails in first_boot - VNC installation on SLE 15 failed because of various issues (ipmi worker, first_boot, boot_from_pxe, await_install))

#27 Updated by SLindoMansilla about 2 years ago

  • Related to action #31375: [sle][functional][ipmi][u][hard] test fails in first_boot - VNC installation on SLE 15 failed because of various issues (ipmi worker, first_boot, boot_from_pxe, await_install) added

#28 Updated by okurz about 2 years ago

That is now default@64bit-ipmi

#29 Updated by SLindoMansilla about 2 years ago

default@64bit-ipmi is not testing gnome always.

On SLE12-SP3+ the default installation is gnome, but on SLE15 the default installation is textmode.
To test gnome on ipmi on SLE15, the test suite gnome has to be enabled.
Enabling it on development: https://openqa.suse.de/admin/job_templates/96

#30 Updated by SLindoMansilla about 2 years ago

Waiting for a new build to be triggered to see if the test suite is properly set up.

#31 Updated by okurz about 2 years ago

But if you only changed test suite settings slightly I suggest to clone an existing job and set the same settings there and use that as validation. No need to wait for a new build.

SLindoMansilla wrote:

Test suite gnome@ipmi is missing.

Btw, I think you meant "scenario" because the test suite "gnome" still exists to explicitly make sure that DESKTOP=gnome.

#32 Updated by SLindoMansilla about 2 years ago

  • Status changed from Feedback to In Progress

New build was triggered: https://openqa.suse.de/tests/1625224

okurz, yes, I meant scenario.

#33 Updated by SLindoMansilla about 2 years ago

Trying to run the job with setting INSTALLONLY=1: http://10.160.66.74/tests/141#step/hostname_inst/5

It fails. I am investigating why while verifying that the test can pass without executing that test module: http://10.160.66.74/tests/143

#34 Updated by SLindoMansilla about 2 years ago

PR to avoid serial issues on IPMI when INSTALLONLY=1: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4899

#35 Updated by SLindoMansilla about 2 years ago

  • Status changed from In Progress to Feedback

#36 Updated by SLindoMansilla about 2 years ago

PR merged. Verifying on OSD:

Both passed.

#37 Updated by SLindoMansilla about 2 years ago

Found 3 useful test suites that run with setting INSTALLONLY=1.

  • btrfs
  • ext4
  • xfs

Enabled machine 64bit-ipmi in job groups:

Waiting for:

Module partitioning_filesystem is not adapted for multi-disk machine: https://openqa.suse.de/tests/1639471#step/partitioning_filesystem/3

#38 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-04-24 to 2018-05-08
  • Target version changed from Milestone 15 to Milestone 16

#39 Updated by SLindoMansilla about 2 years ago

  • Status changed from Feedback to In Progress

#40 Updated by SLindoMansilla about 2 years ago

  • Related to action #32746: [sle][tools][remote-backends][hard] Incomplete job because console isn't responding correctly. Half-open socket on IPMI added

#41 Updated by SLindoMansilla about 2 years ago

  • Blocks deleted (action #31132: [sle][functional][u][ipmi][hard] test fails in consoletest_setup - login input is wrong)

#42 Updated by SLindoMansilla about 2 years ago

  • Related to action #31132: [sle][functional][u][ipmi][hard] test fails in consoletest_setup - login input is wrong added

#43 Updated by SLindoMansilla about 2 years ago

PR, Adapting partioning_filesystem for ipmi with 2 disks: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4929

#44 Updated by SLindoMansilla about 2 years ago

As suggested by okurz, moving the two ipmi scenarios (default, textmode), that are failing because of bugs in existing tests, from Functional (https://openqa.suse.de/admin/job_templates/110) to Test Development (https://openqa.suse.de/admin/job_templates/96).

#45 Updated by SLindoMansilla about 2 years ago

PR merged.

Waiting for verification on OSD:

#47 Updated by SLindoMansilla about 2 years ago

  • Status changed from In Progress to Feedback

Merged. Waiting for verification run on OSD.

#48 Updated by SLindoMansilla about 2 years ago

Test suites btrfs, ext4 and xfs enabled for ipmi on job group SLE 15 Functional

#49 Updated by SLindoMansilla about 2 years ago

  • Status changed from Feedback to Resolved

#50 Updated by okurz about 2 years ago

  • Status changed from Resolved to In Progress

wait, don't we have scenarios left in the test development job group? E.g. there is https://openqa.suse.de/tests/1647706 which is currently scheduled, last one was failing, and it is not in the functional group.

#51 Updated by SLindoMansilla about 2 years ago

  • Status changed from In Progress to Resolved

Those cannot be used as INSTALLONLY=1 because they will affect coverage of other architectures. The IPMI leftovers on Development job group needs the VNC adaption from https://progress.opensuse.org/issues/31375
Work continues there.

#52 Updated by okurz about 2 years ago

ok, fine. I got it now. We have scenarios with INSTALLONLY=1 which we use for now. As discussed with SLindoMansilla I have removed "xfs" and "ext4" again from the test schedule as we are a bit limited in IPMI machine capacity so we leave only "btrfs" for now which should suffice. https://openqa.suse.de/tests/1651222 should be the verification job in the validation job group so I verify the "Resolved" of this ticket with this ;)

#53 Updated by okurz about 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default@64bit-ipmi
https://openqa.suse.de/tests/1688360

#54 Updated by okurz almost 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default@64bit-ipmi
https://openqa.suse.de/tests/1762825

#55 Updated by SLindoMansilla almost 2 years ago

  • Related to action #37820: [functional][sle][u][hard][ipmi][sporadic] test fails in first_boot - Lost connection to SUT on SLE12-SP4 added

#56 Updated by SLindoMansilla almost 2 years ago

For the failure in SLE12-SP4 see: https://progress.opensuse.org/issues/37820

#57 Updated by SLindoMansilla over 1 year ago

  • Related to deleted (action #31375: [sle][functional][ipmi][u][hard] test fails in first_boot - VNC installation on SLE 15 failed because of various issues (ipmi worker, first_boot, boot_from_pxe, await_install))

#58 Updated by SLindoMansilla 11 months ago

  • Due date deleted (2018-05-08)

Also available in: Atom PDF