action #41693

action #23650: [sle][functional][ipmi][epic][u] Fix test suite gnome to work on ipmi 12-SP3 and 15 (WAS: test fails in boot_from_pxe - connection refused trying to ipmi host over ssh?)

[sle][functional][u][ipmi][sporadic] test fails in boot_from_pxe - needs to increase ssh_vnc_wait_time

Added by zluo over 1 year ago. Updated 6 months ago.

Status:RejectedStart date:27/09/2018
Priority:NormalDue date:
Assignee:SLindoMansilla% Done:

0%

Category:Bugs in existing tests
Target version:SUSE QA tests - Milestone 27
Difficulty:
Duration:

Description

I found that openqaw1:1 has problem with ssh_vnc_wait_time for boot_from_pxe. It looks that this ipmi host takes longer to get installer to be ready.

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-x86_64-btrfs@64bit-ipmi fails in
boot_from_pxe

Reproducible

Fails since (at least) Build 43.1

Expected result

Last good: 41.4 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #31375: [sle][functional][ipmi][u][hard] test fails in first_boot... Rejected 05/02/2018
Related to openQA Tests - action #36027: [sle][functional][u][ipmi] test fails in boot_from_pxe - ... Workable 20/10/2017

History

#1 Updated by zluo over 1 year ago

  • Related to action #31375: [sle][functional][ipmi][u][hard] test fails in first_boot - VNC installation on SLE 15 failed because of various issues (ipmi worker, first_boot, boot_from_pxe, await_install) added

#2 Updated by zluo over 1 year ago

  • Status changed from New to In Progress

#4 Updated by okurz over 1 year ago

  • Subject changed from [sle][functional][y] test fails in boot_from_pxe - needs to increase ssh_vnc_wait_time to [sle][functional][u][ipmi][fast] test fails in boot_from_pxe - needs to increase ssh_vnc_wait_time
  • Due date set to 09/10/2018
  • Target version set to Milestone 19

#5 Updated by okurz over 1 year ago

  • Status changed from In Progress to Feedback

PR merged

#6 Updated by okurz over 1 year ago

As stated by you in #31375 as well it seems the timeout of 300s is still not enough in some cases. https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5863 bumps it from 300s to 600s now.

#7 Updated by asmorodskyi over 1 year ago

  • Status changed from Feedback to Workable

#8 Updated by asmorodskyi over 1 year ago

#9 Updated by zluo over 1 year ago

  • Assignee deleted (zluo)

https://openqa.suse.de/tests/2123037#step/boot_from_pxe/29 shows that we still issue here.
And I don't have any idea why this happens sometimes.

As I discussed with @okurz already, please someone can take over?

#10 Updated by okurz over 1 year ago

  • Subject changed from [sle][functional][u][ipmi][fast] test fails in boot_from_pxe - needs to increase ssh_vnc_wait_time to [sle][functional][u][ipmi][sporadic] test fails in boot_from_pxe - needs to increase ssh_vnc_wait_time
  • Due date changed from 09/10/2018 to 06/11/2018
  • Target version changed from Milestone 19 to Milestone 20

#41480 is related and we can work on that first, then try again here.

#11 Updated by SLindoMansilla over 1 year ago

  • Status changed from Workable to Blocked
  • Assignee set to SLindoMansilla
  • Parent task set to #23650

Make BOOT_FROM_PXE stable before working on this sporadic and hardware-specific issue: https://progress.opensuse.org/issues/36027

Assigning myself as tracker.

#12 Updated by SLindoMansilla over 1 year ago

  • Blocked by action #36027: [sle][functional][u][ipmi] test fails in boot_from_pxe - pxe boot menu doesn't show up at all added

#13 Updated by pvorel over 1 year ago

These tests are probably affected by it as well:

This is strange

#14 Updated by okurz about 1 year ago

  • Due date deleted (06/11/2018)
  • Target version changed from Milestone 20 to Milestone 23

#15 Updated by mgriessmeier 11 months ago

moving to M24

#16 Updated by mgriessmeier 11 months ago

  • Target version changed from Milestone 23 to Milestone 24

#17 Updated by mgriessmeier 9 months ago

  • Target version changed from Milestone 24 to Milestone 25

#18 Updated by mgriessmeier 8 months ago

  • Target version changed from Milestone 25 to Milestone 26

#19 Updated by mgriessmeier 6 months ago

  • Target version changed from Milestone 26 to Milestone 27

#20 Updated by SLindoMansilla 6 months ago

  • Blocked by deleted (action #36027: [sle][functional][u][ipmi] test fails in boot_from_pxe - pxe boot menu doesn't show up at all)

#21 Updated by SLindoMansilla 6 months ago

  • Related to action #36027: [sle][functional][u][ipmi] test fails in boot_from_pxe - pxe boot menu doesn't show up at all added

#22 Updated by SLindoMansilla 6 months ago

  • Status changed from Blocked to Rejected

Let's reject this in favor of #38423

Also available in: Atom PDF