tickets #42599

[admin] Redirection limit for this URL exceeded trying to reach BOO and forums

Added by mrmazda about 1 year ago. Updated about 1 month ago.

Status:ResolvedStart date:
Priority:NormalDue date:
Assignee:okurz% Done:

0%

Category:servers hosted in Provo
Target version:-
Duration:

Description

This is all that happens trying to load any BOO or Forum page:

[quote]
[bold]Redirect Loop[/bold]

Redirection limit for this URL exceeded. Unable to load the requested page. This may be caused
by cookies that are blocked.

The browser has stopped trying to retrieve the requested item. The site is redirecting the
request in a way that will never complete.

Have you disabled or blocked cookies required by this site?
NOTE: If accepting the site’s cookies does not resolve the problem, it is likely a server

configuration issue and not your computer.[/quote]

I tried deleting cookies, but it has no apparent impact. All form and BOO URLs are producing
this same result.

This same problem occurred about 3 hours ago, but 30 minute of fussing with cookies and reloads

eventually produced login success, required to do anything useful in either forums or BOO.

Evolution as taught in public schools is religion, not science.

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/


Related issues

Related to openSUSE admin - tickets #52178: [admin] obstacles overwhelming New
Related to openSUSE admin - tickets #52772: latency on forums on weekends is routinely awful New 08/06/2019
Related to openSUSE admin - tickets #54182: Unable to login to Opensuse forum Feedback
Duplicated by openSUSE admin - tickets #52268: Problems accessing openSUSE forums Rejected

History

#1 Updated by mrmazda about 1 year ago

Less than 5 minutes after reporting, I was finally able to login and access both BOO and the forums. An hour after that to come here I had to login, even though I remained logged in on BOO and the forums.

I generally have at least half dozen BOO and/or forum pages open in background tabs at any given time. Working them takes time. Interruptions are routine. Being logged out repeatedly interferes with getting things done. BOO and the forums are routinely less responsive than the web in general, with "waiting on www.suse.com" or "waiting on...opensuse.org" on the statusbar more common than not.

#2 Updated by cboltz about 1 year ago

  • Category set to servers hosted in Provo
  • Assignee set to tampakrap
  • Private changed from Yes to No

Theo, can you please forward this to the admins in Provo?

Felix:

An hour after that to come here I had to login, even though I remained logged in on BOO and the forums.

That's normal - we have different login servers in Provo (130.57.66.6) and Nuremberg (login2.opensuse.org)

"waiting on...opensuse.org"

It would be interesting which subdomain causes the wait time so that we know what needs fixing.

#3 Updated by mrmazda about 1 year ago

"It would be interesting which subdomain causes the wait time so that we know what needs fixing."

Exactly how might one do that? Where/how is a redirection limit set?

#4 Updated by mrmazda about 1 year ago

It's happening on BOO again now.

#5 Updated by mrmazda about 1 year ago

Copied from URLBAR of failing BOO tab
https://esp.microfocus.com/LAGBroker?agAppNa=openbugzilla&c=suse/name/password/uri&%22https://bugzilla.opensuse.org/accessmanagerlogin.cgi?target=buglist.cgi?cmdtype%3Drunnamed%26namedcmd%3Dall%2520my%2520bugs%22

Why esp.microfocus.com rather than www?

# traceroute login.microfocus.com
traceroute to login.microfocus.com (130.57.66.2), 30 hops max, 60 byte packets
1 192.168.0.50 (192.168.0.50) 0.454 ms 0.553 ms 0.685 ms
2 10.80.213.145 (10.80.213.145) 8.276 ms 14.269 ms 15.229 ms
3 71-46-26-167.res.bhn.net (71.46.26.167) 15.325 ms 15.349 ms 15.382 ms
4 ten-0-0-0-2-4-tamp20-car2.bhn.net (71.44.17.146) 19.314 ms ten-0-0-0-3-3-tamp20-car2.bhn.net (71.44.17.144) 18.422 ms 18.470 ms
5 hun0-1-0-5-tamp20-cbr1.bhn.net (72.31.3.97) 18.259 ms * 17.260 ms
6 bu-ether19.chctilwc00w-bcr00.tbone.rr.com (66.109.6.42) 24.511 ms 10.bu-ether15.tamsflde20w-bcr00.tbone.rr.com (66.109.6.96) 15.581 ms bu-ether19.chctilwc00w-bcr00.tbone.rr.com (66.109.6.42) 16.985 ms
7 bu-ether17.hstqtx0209w-bcr00.tbone.rr.com (66.109.1.70) 42.439 ms 43.511 ms 44.487 ms
8 bu-ether12.dllstx976iw-bcr00.tbone.rr.com (66.109.6.39) 50.044 ms 49.085 ms 107.14.19.49 (107.14.19.49) 44.455 ms
9 0.ae0.pr1.dfw10.tbone.rr.com (107.14.17.232) 40.152 ms 41.063 ms 0.ae4.pr1.dfw10.tbone.rr.com (107.14.19.97) 46.779 ms
10 66.109.9.91 (66.109.9.91) 41.208 ms 42.038 ms 41.068 ms
11 zayo-eli.er2.dfw2.us.zip.zayo.com (64.125.14.154) 79.201 ms 78.219 ms 71.215 ms
12 209.63.99.250 (209.63.99.250) 90.587 ms 90.750 ms 90.629 ms
13 70.103.180.172 (70.103.180.172) 117.156 ms 116.301 ms 116.117 ms
14 192.94.118.230 (192.94.118.230) 89.252 ms 96.367 ms 112.940 ms
15 130.57.66.2 (130.57.66.2) 127.004 ms 137.489 ms 150.422 ms

#6 Updated by mrmazda about 1 year ago

# traceroute esp.microfocus.com
traceroute to esp.microfocus.com (130.57.66.3), 30 hops max, 60 byte packets
1 192.168.0.50 (192.168.0.50) 0.407 ms 0.526 ms 0.641 ms
2 10.80.213.145 (10.80.213.145) 9.788 ms 16.044 ms 16.998 ms
3 71-46-26-165.res.bhn.net (71.46.26.165) 17.117 ms 17.142 ms 17.174 ms
4 ten0-0-0-9-1.tamp20-car1.bhn.net (72.31.118.24) 20.579 ms ten0-0-0-9-0.tamp20-car1.bhn.net (71.44.48.80) 19.462 ms ten-0-0-0-3-3-tamp20-car1.bhn.net (71.44.17.152) 20.528 ms
5 hun0-0-0-5-tamp20-cbr1.bhn.net (72.31.3.51) 21.393 ms * 20.404 ms
6 bu-ether19.chctilwc00w-bcr00.tbone.rr.com (66.109.6.42) 26.128 ms 10.bu-ether15.tamsflde20w-bcr00.tbone.rr.com (66.109.6.96) 13.745 ms 19.591 ms
7 bu-ether17.hstqtx0209w-bcr00.tbone.rr.com (66.109.1.70) 42.680 ms 45.822 ms 41.692 ms
8 107.14.19.49 (107.14.19.49) 46.790 ms bu-ether12.dllstx976iw-bcr00.tbone.rr.com (66.109.6.39) 47.830 ms 107.14.19.49 (107.14.19.49) 42.630 ms
9 0.ae4.pr1.dfw10.tbone.rr.com (107.14.19.97) 42.642 ms 42.612 ms 43.454 ms
10 66.109.9.91 (66.109.9.91) 38.667 ms 39.695 ms 39.611 ms
11 zayo-eli.er2.dfw2.us.zip.zayo.com (64.125.14.154) 75.923 ms 72.260 ms 78.856 ms
12 209.63.99.250 (209.63.99.250) 85.415 ms 89.910 ms 90.207 ms
13 70.103.180.172 (70.103.180.172) 98.636 ms 98.571 ms 97.646 ms
14 192.94.118.230 (192.94.118.230) 93.548 ms 90.987 ms 90.856 ms
15 esp.attachmategroup.com (130.57.66.3) 90.079 ms 88.888 ms 90.106 ms

#7 Updated by mrmazda about 1 year ago

# traceroute bugzilla.opensuse.org
traceroute to bugzilla.opensuse.org (130.57.66.6), 30 hops max, 60 byte packets
1 192.168.0.50 (192.168.0.50) 0.422 ms 0.544 ms 0.653 ms
2 10.80.213.145 (10.80.213.145) 8.627 ms 14.438 ms 15.378 ms
3 71-46-27-167.res.bhn.net (71.46.27.167) 15.454 ms 15.513 ms 15.543 ms
4 ten0-0-0-9-1.tamp20-car2.bhn.net (72.31.118.26) 20.132 ms tengig0-11-0-12.tamp20-car2.bhn.net (72.31.210.74) 18.126 ms ten-0-0-0-3-3-tamp20-car2.bhn.net (71.44.17.144) 19.195 ms
5 hun0-1-0-5-tamp20-cbr1.bhn.net (72.31.3.97) 20.193 ms 19.074 ms 20.020 ms
6 10.bu-ether15.tamsflde20w-bcr00.tbone.rr.com (66.109.6.96) 19.189 ms 16.912 ms 14.055 ms
7 bu-ether17.hstqtx0209w-bcr00.tbone.rr.com (66.109.1.70) 40.779 ms 45.130 ms 44.138 ms
8 bu-ether12.dllstx976iw-bcr00.tbone.rr.com (66.109.6.39) 46.097 ms 41.732 ms 107.14.19.49 (107.14.19.49) 46.085 ms
9 0.ae1.pr1.dfw10.tbone.rr.com (107.14.17.234) 69.846 ms 0.ae4.pr1.dfw10.tbone.rr.com (107.14.19.97) 68.766 ms 0.ae1.pr1.dfw10.tbone.rr.com (107.14.17.234) 69.762 ms
10 * 66.109.9.91 (66.109.9.91) 38.467 ms 39.432 ms
11 zayo-eli.er2.dfw2.us.zip.zayo.com (64.125.14.154) 74.028 ms 76.758 ms 75.789 ms
12 209.63.99.250 (209.63.99.250) 85.762 ms 85.819 ms 85.751 ms
13 70.103.180.172 (70.103.180.172) 94.713 ms 94.151 ms 99.414 ms
14 192.94.118.230 (192.94.118.230) 90.334 ms 91.267 ms 91.249 ms
15 130.57.66.6 (130.57.66.6) 92.270 ms 91.729 ms 92.549 ms

#9 Updated by mrmazda about 1 year ago

Back again already after several hours offline, while here on POO, login has remained.

#10 Updated by tampakrap 12 months ago

  • Status changed from New to Closed

#11 Updated by mrmazda 8 months ago

Again it's impossible to login on B.O.O. or the forums. Login here obviously works, as does https://en.opensuse.org/SDB:Linuxrc and https://connect.opensuse.org/. Deleting cookies doesn't help.

#12 Updated by pjessen 8 months ago

  • Status changed from Closed to In Progress

#13 Updated by mrmazda 8 months ago

B.O.O. and forums are working for me now.

#14 Updated by tampakrap 7 months ago

  • Status changed from In Progress to Closed

#15 Updated by mrmazda 5 months ago

It's back, can't post to forums (and can't find reopen button).

#16 Updated by okurz 5 months ago

  • Status changed from Closed to In Progress
  • Assignee changed from tampakrap to okurz

as discussed on IRC

#17 Updated by mrmazda 5 months ago

The URL in #8 solved it for me (for now).

#18 Updated by okurz 5 months ago

  • Status changed from In Progress to Resolved

well, good for you :) I can't offer more though

#19 Updated by okurz 5 months ago

#20 Updated by mrmazda 5 months ago

Redirect loops are back with a vengeance, and the #8 URL doesn't help any more, instead producing this:

"We’re sorry about that.
The page you’re searching for is unavailable.
Does one of the related page links below help? If not, try using our site search function at the top of this page."

#21 Updated by mrmazda 5 months ago

After 2+ more hours of being locked out again, I got back in by deleting microfocus.com cookies again.

For me, nowhere else on the web has messing with cookies been a solution to a problem. Then again, I can't think of anywhere else that repeatedly and stealthily logs me out multiple times every day. Other logins last as long as the browser session, if not as long as the browser's UA string remains unchanged.

#22 Updated by mrmazda 5 months ago

The delete microfocus cookies solution only lasted about an hour before another involuntary logout occurred, after which clicking any login button resulted only in reloading the current page. Subsequent microfocus cookies deletion did again work.

#23 Updated by okurz 5 months ago

#24 Updated by mrmazda 5 months ago

Redirect loops came back again following yet another involuntary logout. Eventually I deleted all microfocus and non-bugzilla cookies and got the login on the forums to work.

#25 Updated by mrmazda 5 months ago

Again the only way to get past redirect loops is to delete all microfocus and opensuse cookies.

#26 Updated by okurz 5 months ago

  • Status changed from Resolved to Feedback

alright, I will forward the information to Microfocus IT.

#27 Updated by okurz 5 months ago

  • Related to deleted (tickets #52268: Problems accessing openSUSE forums)

#28 Updated by okurz 5 months ago

  • Duplicated by tickets #52268: Problems accessing openSUSE forums added

#29 Updated by okurz 5 months ago

I reported two tickets to Microfocus IT, originally FIX_246784 which was set to "Resolved" and now FIX_247868

#30 Updated by mrmazda 5 months ago

Right in the middle of posting forums I was again involuntarily logged out and had to clear microfocus and opensuse cookies to stop the dead-end redirects trying to log back in.

#31 Updated by mrmazda 5 months ago

Again a submit button to a forum reply triggered a logout and need to remove all microfocus and opensuse cookies to get logged back in. This time it was obvious the server was unable to handle simultaneous submits from two different posters.

#32 Updated by okurz 5 months ago

Today again this also happened to myself. A bug link using bugzilla.opensuse.org ended up in the redirect error however a corresponding bugzilla.suse.com link did not show that problem.

#33 Updated by mrmazda 4 months ago

Again I lost all my work by clicking the preview button on a forum response, when I got redirected to the login page, which redirected me to a blank white page.

#34 Updated by okurz 4 months ago

  • Related to tickets #52772: latency on forums on weekends is routinely awful added

#35 Updated by mrmazda 4 months ago

Redirect loops are back to making doing anything useful impossible.

#36 Updated by okurz 4 months ago

Unfortunately the MF IT ticket has not received any update besides mine. Given that you seem to suffer quite reproducibly (and for example I don't) I guess further debugging on your side could help.

#37 Updated by mrmazda 4 months ago

okurz wrote:

I guess further debugging on your side could help.

That will require specific instruction.

#38 Updated by cboltz 4 months ago

For making you searchable in the logs, the following information is probably helpful:
* the browser you use (Firefox? Chromium? Which version?)
* your operating system, even if I can probably guess the answer already ;-)
* your IP at the time of failure
* the exact date and time of the failure (including timezone)
* the URL you (attempted to) use

It might also be helpful to know when you logged in - ideally with the exact time, but something like "4 hours ago" would already be helpful.

#39 Updated by okurz 3 months ago

#40 Updated by okurz about 1 month ago

  • Status changed from Feedback to Resolved

Now – finally again – there was movement in the RIO ticket. Another person which seems to be much more active reacted on the RIO ticket but could unfortunately not offer more help because we still do not have a good way to reproduce it or more data which would help analysis. Hence I can also only close this ticket. Please – if you still see this issue which I myself also have not observed over the past months – comment here or open new issues.

Also available in: Atom PDF