Project

General

Profile

action #55661

coordination #56267: [epic][qe-core][functional] openSUSE welcome message is not properly handled

[opensuse][u] test fails in several modules after booting and login - "openSUSE Welcome" not handled (WAS: test fails in first_boot)

Added by StefanBruens almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 30
Start date:
2019-08-16
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-kde@Laptop_64 fails in
first_boot

Affect all tests on KDE Plasma/GNOME/XFCE.
Greeter should be closed.
There is already a test module opensuse_welcome.
There is already a function untick_welcome_on_next_startup

On some scenarios the function call is more efficient than the opensuse_welcome module:

Acceptance criteria

  • AC1: The module change_password calls the function untick_welcome_on_next_startup to handle the opensuse-welcome popup. RESOLVED in PR #9310
  • AC2: The module multi_users_dm calls the function untick_welcome_on_next_startup to handle the opensuse-welcome popup. RESOLVED in #58577
  • AC3: The module first_boot calls the function untick_welcome_on_next_startup to handle the opensuse-welcome popup. dropped this AC as the magic happens in next module opensuse_welcome which already uses untick_welcome_on_next_startup.

Related issues

Related to openQA Tests - action #55664: [opensuse] test fails in application_starts_on_login (opensuse-welcome)Resolved2019-08-17

Related to openQA Tests - action #56963: test fails in opensuse_welcome - opensuse welcome dialog hasn't closed properlyRejected2019-09-17

Related to openQA Tests - action #58577: opensuse-welcome not handled in multi_users_dmResolved2019-10-23

Has duplicate openQA Tests - action #56162: [opensuse] closing of openSUSE-welcome is unreliabe/unstableRejected2019-08-30

Has duplicate openQA Tests - action #56798: [functional][u] test fails in change_password - openSUSE Welcome is shown for "Test" userRejected2019-09-11

Precedes openQA Tests - action #55805: [opensuse][functional][u] test fails in opensuse_welcome - does not have welcome dialog for root logged inResolved2019-08-17

Precedes openQA Tests - action #56774: [functional][u] test fails in boot_to_desktop - openSUSE Welcome not handled in upgrade scenariosResolved2019-08-17

History

#2 Updated by SLindoMansilla almost 3 years ago

  • Related to action #55664: [opensuse] test fails in application_starts_on_login (opensuse-welcome) added

#3 Updated by SLindoMansilla almost 3 years ago

  • Subject changed from test fails in first_boot - "openSUSE Welcome" not handled to [opensuse] test fails in first_boot - "openSUSE Welcome" not handled

#4 Updated by SLindoMansilla almost 3 years ago

  • Parent task set to #56267

#6 Updated by SLindoMansilla almost 3 years ago

  • Has duplicate action #56162: [opensuse] closing of openSUSE-welcome is unreliabe/unstable added

#7 Updated by SLindoMansilla almost 3 years ago

  • Subject changed from [opensuse] test fails in first_boot - "openSUSE Welcome" not handled to [opensuse][u] test fails in first_boot - "openSUSE Welcome" not handled
  • Status changed from In Progress to Workable
  • Priority changed from Normal to Urgent

It seems this is hitting several people/teams
The PR has not activity since 14 days.
Let's see if U-Team can take over.

#8 Updated by SLindoMansilla almost 3 years ago

  • Subject changed from [opensuse][u] test fails in first_boot - "openSUSE Welcome" not handled to [opensuse][u] test fails in several modules after booting and login - "openSUSE Welcome" not handled (test fails in first_boot)

#9 Updated by SLindoMansilla almost 3 years ago

  • Subject changed from [opensuse][u] test fails in several modules after booting and login - "openSUSE Welcome" not handled (test fails in first_boot) to [opensuse][u] test fails in several modules after booting and login - "openSUSE Welcome" not handled (WAS: test fails in first_boot)

#11 Updated by SLindoMansilla almost 3 years ago

  • Assignee set to ggardet_arm

PR to schedule welcome_opensuse module on live scenarios: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8348/files

#12 Updated by dimstar almost 3 years ago

ggardet_arm wrote:

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8336 has been merged, but we still have some occurrences, but less often apparently: https://openqa.opensuse.org/tests/1022681#step/opensuse_welcome/9

I woudln't sign the 'less often' statement
Just look at e.g. https://openqa.opensuse.org/tests/1024810#next_previous (and for once welcome was fine, FF was crazying up of course)

#13 Updated by ggardet_arm almost 3 years ago

  • Assignee deleted (ggardet_arm)

#14 Updated by SLindoMansilla almost 3 years ago

mgriessmeier, this ticket needs a milestone to change the status from URGENT to HIGH

#15 Updated by SLindoMansilla almost 3 years ago

  • Description updated (diff)
  • Priority changed from Urgent to High
  • Target version set to Milestone 28

#16 Updated by StefanBruens almost 3 years ago

AC3 will be difficult, as disabling is per user, and it shows up in e.g. 'change_password' https://progress.opensuse.org/issues/56798 later for the "Test" user. On the other hand, as the Test user is logged out immediately after, it is probably best to just accept the Welcome dialog as valid result and just log out.

#17 Updated by SLindoMansilla almost 3 years ago

  • Description updated (diff)

Hmm, I didn't thought about other users.
Well, as long as we avoid to duplicate the behavior in all cases, it should be fine.

#18 Updated by SLindoMansilla almost 3 years ago

  • Description updated (diff)

#19 Updated by SLindoMansilla almost 3 years ago

  • Has duplicate action #56798: [functional][u] test fails in change_password - openSUSE Welcome is shown for "Test" user added

#20 Updated by SLindoMansilla almost 3 years ago

  • Description updated (diff)

#21 Updated by SLindoMansilla almost 3 years ago

  • Has duplicate action #56963: test fails in opensuse_welcome - opensuse welcome dialog hasn't closed properly added

#22 Updated by SLindoMansilla almost 3 years ago

Scenario: opensuse-Tumbleweed-NET-x86_64-zdup-Leap-42.3-gnome@64bit_cirrus https://openqa.opensuse.org/tests/1033997#step/opensuse_welcome/10

#24 Updated by StefanBruens almost 3 years ago

SLindoMansilla wrote:

Scenario: opensuse-Tumbleweed-NET-x86_64-zdup-Leap-42.3-gnome@64bit_cirrus https://openqa.opensuse.org/tests/1033997#step/opensuse_welcome/10

May be one of the "input ignored" glitches, rerun scheduled.

Confirmed input glitch, second run passed without problems.

#25 Updated by StefanBruens almost 3 years ago

  • Has duplicate deleted (action #56963: test fails in opensuse_welcome - opensuse welcome dialog hasn't closed properly)

#26 Updated by StefanBruens almost 3 years ago

  • Related to action #56963: test fails in opensuse_welcome - opensuse welcome dialog hasn't closed properly added

#28 Updated by SLindoMansilla almost 3 years ago

  • Precedes action #55805: [opensuse][functional][u] test fails in opensuse_welcome - does not have welcome dialog for root logged in added

#29 Updated by SLindoMansilla almost 3 years ago

  • Description updated (diff)
  • Status changed from Workable to New

#30 Updated by StefanBruens almost 3 years ago

The Acceptance Criteria are nonsense.

You should write down what you want to achieve and why, but you just tell how something should be implemented.

The "is more efficient" is totally vague.

#31 Updated by SLindoMansilla almost 3 years ago

  • Precedes action #56774: [functional][u] test fails in boot_to_desktop - openSUSE Welcome not handled in upgrade scenarios added

#32 Updated by SLindoMansilla over 2 years ago

  • Related to action #58577: opensuse-welcome not handled in multi_users_dm added

#33 Updated by SLindoMansilla over 2 years ago

multi_users_dm may be fixed by: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8451/files

Waiting for verification run on O3.

#34 Updated by SLindoMansilla over 2 years ago

  • Description updated (diff)

multi_users_dm fixed in #58577
Verification run on O3: https://openqa.opensuse.org/tests/1095677#step/multi_users_dm/16

#35 Updated by SLindoMansilla over 2 years ago

  • Status changed from New to Workable
  • Estimated time set to 42.00 h

change_password is the important module to be fixed here.
Since the first_boot scenario is scheduling the "opensuse_welcome" module, which is using already the function untick_welcome_on_next_startup.

#36 Updated by mgriessmeier over 2 years ago

  • Target version changed from Milestone 28 to Milestone 30

needs to be discussed offline

#37 Updated by dheidler over 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to dheidler

#39 Updated by dheidler over 2 years ago

  • Description updated (diff)

#40 Updated by dheidler over 2 years ago

  • Description updated (diff)

#41 Updated by dheidler over 2 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF