Project

General

Profile

Actions

action #53339

closed

[opensuse] test fails in swing due to incorrect rendering on 16bpp framebuffers

Added by StefanBruens over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-06-19
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-toolkits@64bit fails in
swing

See https://bugzilla.opensuse.org/show_bug.cgi?id=1122165

Current Java versions apparently no longer render correctly when the framebuffer only has 16bpp.

As is, the current test is pointless. Possible changes:

  • disable the swing test completely
  • run the test (also) on machine-type @64bit_virtio, which uses a 32bpp screen depth
    • detect 16bpp and disable the swing test

Test suite description

Maintainer: dheidler@suse.de Test GUI Toolkits

Reproducible

Fails since (at least) Build 20190226

Expected result

Last good: 20190105 (or more recent)

TODO

Further details

Always latest result in this scenario: latest


Related issues 8 (0 open8 closed)

Related to openQA Tests - action #43778: [opensuse][functional][u] test fails in boot_encryptRejecteddimstar2018-11-14

Actions
Related to openQA Tests - action #42362: [qe-core][qem][virtio][sle15sp0][sle15sp1][desktop][typing] test fails in window_system because "typing string is too fast in wayland"Resolvedzcjia2018-10-12

Actions
Related to openQA Tests - action #27062: [sle][functional][sle15][desktop] Add new QEMUVGA types for Wayland testingResolvedqkzhu2017-10-27

Actions
Related to openQA Project - action #15496: qemu -vga qlx supportResolved2016-12-14

Actions
Related to openQA Tests - action #21786: [functional]proper wayland supportResolvedfavogt2017-08-04

Actions
Blocks openQA Tests - action #35589: [functional][u][opensuse][sporadic][medium] test fails in kontact - needs workaround for boo#1105207, then akregator not closedRejectedzluo2018-04-26

Actions
Copied to openQA Tests - action #55445: [functional][u] On OSD get rid of workaround QEMUVGA=cirrus in machinesResolveddheidler2019-10-28

Actions
Copied to openQA Tests - action #55448: [opensuse] cleanup cirrus/std/qxl ob o3Resolvedokurz2019-06-19

Actions
Actions #1

Updated by okurz over 4 years ago

  • Subject changed from test fails in swing to [functional][u] test fails in swing due to incorrect rendering on 16bpp framebuffers

hm, we just changed the kernel boot parameters for virtio with #51614 , maybe it is about time to change the default graphics adapter away from cirrus? Shouldn't be hard to test using the test parameter QEMUVGA. I do not have enough experience which vga adapter would be a better choice as a sane default – or is it virtio itself? Not sure about that.

Also see #43778#note-12

Actions #2

Updated by okurz over 4 years ago

  • Status changed from New to In Progress
  • Assignee set to okurz

Maybe I can explore the options:

openqa_clone_job_o3 --skip-chained-deps 963993 _GROUP=0 TEST=okurz_poo53339_std QEMUVGA=std BUILD=okurz_poo53339
openqa_clone_job_o3 --skip-chained-deps 963993 _GROUP=0 TEST=okurz_poo53339_cirrus QEMUVGA=cirrus BUILD=okurz_poo53339
openqa_clone_job_o3 --skip-chained-deps 963993 _GROUP=0 TEST=okurz_poo53339_qxl QEMUVGA=qxl BUILD=okurz_poo53339
openqa_clone_job_o3 --skip-chained-deps 963993 _GROUP=0 TEST=okurz_poo53339_virtio QEMUVGA=virtio BUILD=okurz_poo53339
openqa_clone_job_o3 --skip-chained-deps 964045 _GROUP=0 TEST=okurz_poo53339_std QEMUVGA=std BUILD=okurz_poo53339
openqa_clone_job_o3 --skip-chained-deps 964045 _GROUP=0 TEST=okurz_poo53339_cirrus QEMUVGA=cirrus BUILD=okurz_poo53339
openqa_clone_job_o3 --skip-chained-deps 964045 _GROUP=0 TEST=okurz_poo53339_qxl QEMUVGA=qxl BUILD=okurz_poo53339
openqa_clone_job_o3 --skip-chained-deps 964045 _GROUP=0 TEST=okurz_poo53339_virtio QEMUVGA=virtio BUILD=okurz_poo53339

Created job #964242: opensuse-Tumbleweed-DVD-x86_64-Build20190619-kde@64bit -> https://openqa.opensuse.org/t964242 ok (std) 1:45h
Created job #964243: opensuse-Tumbleweed-DVD-x86_64-Build20190619-kde@64bit -> https://openqa.opensuse.org/t964243 failed to switch consoles (cirrus), retriggered -> https://openqa.opensuse.org/tests/964569
Created job #964244: opensuse-Tumbleweed-DVD-x86_64-Build20190619-kde@64bit -> https://openqa.opensuse.org/t964244 ok (qxl) 1:45h
Created job #964245: opensuse-Tumbleweed-DVD-x86_64-Build20190619-kde@64bit -> https://openqa.opensuse.org/t964245 failed in https://openqa.opensuse.org/tests/964245#step/user_gui_login/8 (virtio), retriggered -> https://openqa.opensuse.org/tests/964570
Created job #964246: opensuse-Tumbleweed-DVD-x86_64-Build20190619-toolkits@64bit -> https://openqa.opensuse.org/t964246 failed to switch consoles (std), retriggered -> https://openqa.opensuse.org/tests/964571
Created job #964247: opensuse-Tumbleweed-DVD-x86_64-Build20190619-toolkits@64bit -> https://openqa.opensuse.org/t964247 failed in swing as expected (cirrus) 0:24h
Created job #964248: opensuse-Tumbleweed-DVD-x86_64-Build20190619-toolkits@64bit -> https://openqa.opensuse.org/t964248 failed to switch consoles (qxl), retriggered -> https://openqa.opensuse.org/tests/964572
Created job #964249: opensuse-Tumbleweed-DVD-x86_64-Build20190619-toolkits@64bit -> https://openqa.opensuse.org/t964249 failed to switch consoles (virtio), retriggered -> https://openqa.opensuse.org/tests/964573

EDIT: The result is horribly unstable and confusing though, updated above

Also scheduled one more, trying out if I can override the video= parameter to check out 32bpp:

openqa_clone_job_o3 --skip-chained-deps 964045 _GROUP=0 TEST=okurz_poo53339_boot32bpp_qxl QEMUVGA=qxl BUILD=okurz_poo53339 EXTRABOOTPARAMS_BOOT_LOCAL=video=1024x768

Created job #964574: opensuse-Tumbleweed-DVD-x86_64-Build20190619-toolkits@64bit -> https://openqa.opensuse.org/t964574

Actions #3

Updated by okurz over 4 years ago

  • Related to action #43778: [opensuse][functional][u] test fails in boot_encrypt added
Actions #4

Updated by okurz over 4 years ago

  • Related to action #42362: [qe-core][qem][virtio][sle15sp0][sle15sp1][desktop][typing] test fails in window_system because "typing string is too fast in wayland" added
Actions #5

Updated by okurz over 4 years ago

  • Related to action #27062: [sle][functional][sle15][desktop] Add new QEMUVGA types for Wayland testing added
Actions #6

Updated by okurz over 4 years ago

Actions #7

Updated by okurz over 4 years ago

  • Related to action #21786: [functional]proper wayland support added
Actions #8

Updated by okurz over 4 years ago

  • Status changed from In Progress to Feedback

So I will propose to switch the default QEMUVGA to "std", or actually just trust qemu's default and not overwrite it in os-autoinst, "std" in this case still. I will also add specific test cases within "openSUSE Tumbleweed" for "cirrus" and "qxl" as we already have "virtio" and "std" would be the new default for "64bit". DimStar gave his ok for adding the new variants. Added two machine variants "cirrus" and "qxl" to machines on o3, and four scenarios "gnome@64bit_cirrus", "gnome@64bit_qxl", "kde@64bit_cirrus", "gnome@64bit_qxl" to Development: openSUSE Tumbleweed.

https://github.com/os-autoinst/os-autoinst/pull/1169 for the proposal to revert to the qemu defaults.

However, we can still do some upfront testing so I scheduled some more tests for Tumbleweed tests on the special, specific machine "64bit_std" which explicitly sets the "std" graphics adapter. Scheduled many scenarios in Development Tumbleweed.

test results:

Actions #9

Updated by okurz over 4 years ago

  • Description updated (diff)
Actions #11

Updated by okurz over 4 years ago

  • Blocks action #35589: [functional][u][opensuse][sporadic][medium] test fails in kontact - needs workaround for boo#1105207, then akregator not closed added
Actions #12

Updated by okurz over 4 years ago

  • Description updated (diff)

Also I added "gnome@64bit_std" and "kde@64bit_std" to be explicit however I plan to remove these soon again after we actually switched the 64bit machines to "std" instead.

Asked DimStar which TW snapshot would be good to test against std and we agreed that 20190702 should be good. I removed QEMUVGA=cirrus from all machine definitions on o3 except "64bit_cirrus".

I installed the new version of os-autoinst on openqaworker1, rebooted and will check how jobs run there as well.

Actions #13

Updated by okurz over 4 years ago

  • Description updated (diff)
Actions #14

Updated by okurz over 4 years ago

openqa-clone-job --skip-chained-deps --within-instance https://openqa.opensuse.org 972404 QEMUVGA=
Created job #973125: opensuse-Tumbleweed-DVD-x86_64-Build20190701-toolkits@64bit -> https://openqa.opensuse.org/t973125

however that job failed in https://openqa.opensuse.org/tests/973125#step/prepare_test_data/1 as the kernel command line still has "video=1024x768-16" from the generated qcow2 image. I deleted the according jobs again. Better to wait for a fresh new snapshot with properly created images as cloning including the parent is not easily possible as clone-job does not pass parameters to the parent.

Actions #15

Updated by okurz over 4 years ago

  • Description updated (diff)
Actions #16

Updated by okurz over 4 years ago

  • Copied to action #55445: [functional][u] On OSD get rid of workaround QEMUVGA=cirrus in machines added
Actions #17

Updated by okurz over 4 years ago

  • Copied to action #55448: [opensuse] cleanup cirrus/std/qxl ob o3 added
Actions #18

Updated by okurz over 4 years ago

  • Description updated (diff)
  • Status changed from Feedback to Resolved

default graphics adapter in os-autoinst has been changed to "std", the QEMUVGA=cirrus machine variant on o3 has already been removed, special tickets have been created for followup on o3 and osd.

Actions #19

Updated by dheidler over 4 years ago

  • Status changed from Resolved to Workable

This fail seems to happen in https://openqa.suse.de/tests/3408495 due to cirrus.

Should we switch SLE15SP2 to std?

Actions #20

Updated by okurz over 4 years ago

  • Status changed from Workable to Resolved

Yes, you should. That is #55445

Actions #21

Updated by SLindoMansilla over 4 years ago

  • Subject changed from [functional][u] test fails in swing due to incorrect rendering on 16bpp framebuffers to [opensuse] test fails in swing due to incorrect rendering on 16bpp framebuffers

Not resolved by U-Team

Actions

Also available in: Atom PDF