Project

General

Profile

action #27062

coordination #23886: [sle][functional][desktop][sle15][epic] initial setup

[sle][functional][sle15][desktop] Add new QEMUVGA types for Wayland testing

Added by qkzhu about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-10-27
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-create_hdd_sled_gnome@64bit fails in
first_boot

SLED15 is using Wayland by default however the default QEMUVGA setting on o.s.d is cirrus
which doesn't support Wayland. So SLED15 and SLES15+WE stuck at the boot time currently.

We could:

  1. Add a new machine type with QEMUVGA=virtio/vga for the Wayland testing
  2. Set QEMUVGA=virtio/vga in the main.pm for Wayland testing

Reproducible

Fails since (at least) Build 303.1

Expected result

Last good: 302.1 (or more recent)


Related issues

Related to openQA Project - action #15496: qemu -vga qlx supportResolved2016-12-14

Related to openQA Tests - action #21786: [functional]proper wayland supportResolved2017-08-04

Related to openQA Tests - action #53339: [opensuse] test fails in swing due to incorrect rendering on 16bpp framebuffersResolved2019-06-19

History

#1 Updated by qkzhu about 4 years ago

Frederic suggests to use "VGA" or "QXL" instead.

#2 Updated by qkzhu about 4 years ago

#3 Updated by qkzhu about 4 years ago

  • Related to action #21786: [functional]proper wayland support added

#4 Updated by qkzhu about 4 years ago

QXL was blocked by boo#1057241 and action#15496

o.o.o also uses QEMUVGA=virtio for kde_walyand testing so I will add a new machine type with QEMUVGA=virtio for the SLED15

64bit-virtio-vga:
HDDSIZEGB=20
QEMUCPU=qemu64
QEMUVGA=virtio
VIRTIO_CONSOLE=1
WORKER_CLASS=qemu_x86_64

Validation test: http://10.67.17.30/tests/1955#

#5 Updated by qkzhu about 4 years ago

  • Status changed from New to Resolved

#6 Updated by okurz over 2 years ago

  • Related to action #53339: [opensuse] test fails in swing due to incorrect rendering on 16bpp framebuffers added

Also available in: Atom PDF