Project

General

Profile

Actions

action #43778

closed

[opensuse][functional][u] test fails in boot_encrypt

Added by dimstar over 5 years ago. Updated about 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 25
Start date:
2018-11-14
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-cryptlvm@uefi fails in
boot_encrypt

Reproducible

Fails since (at least) Build 20181112

Expected result

Last good: 20181110 (or more recent)

Further details

Always latest result in this scenario: latest

The tst repeatedly failed today, but it always seems like a graphical glitch just after boot - possible we're not waiting long enough to get over the tianacore bios setup? Probably will need to revalidate outside of openqa


Related issues 1 (0 open1 closed)

Related to openQA Tests - action #53339: [opensuse] test fails in swing due to incorrect rendering on 16bpp framebuffersResolvedokurz2019-06-19

Actions
Actions #1

Updated by okurz over 5 years ago

We wait for 200 seconds for encrypted-disk-password-prompt. The video also shows that we are stuck at the video glitch. I doubt anything is wrong with tests here. I highly recommend you to consider a product issue, e.g. pick this ticket yourself, crosscheck again e.g. by triggering a job in the last good build, etc.

Actions #2

Updated by dimstar over 5 years ago

  • Assignee set to dimstar

Thanks for the quick verification Oliver; I was considering that, but did not check the logs for how long we wait. 3 minutes indeed sounds like sufficient waiting time.

I'll see to take thus further

Actions #3

Updated by okurz over 5 years ago

  • Subject changed from test fails in boot_encrypt to [opensuse][functional][u] test fails in boot_encrypt
  • Target version set to Milestone 22
Actions #4

Updated by szarate over 5 years ago

I'm more inclined to say that this is definitely a product bug (qemu), since looks like it's the video that gets screwed... but the SUT seems to be able to keep working... as you can actually see in the serial console. Increasing the timeout here won't really help for this kind of errors...

Attempting to decrypt master key...

Enter passphrase for hd0,gpt2 (cf0983fb707b43f1bec2fd2a63882132): 

Slot 0 opened
Actions #5

Updated by okurz over 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: cryptlvm@uefi
https://openqa.opensuse.org/tests/815359

Actions #6

Updated by okurz over 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: cryptlvm@uefi
https://openqa.opensuse.org/tests/820948

Actions #7

Updated by okurz over 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: cryptlvm@uefi
https://openqa.opensuse.org/tests/829102

Actions #8

Updated by okurz over 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: cryptlvm@uefi
https://openqa.opensuse.org/tests/839888

Actions #9

Updated by okurz over 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: cryptlvm@uefi
https://openqa.opensuse.org/tests/850078

Actions #10

Updated by okurz over 5 years ago

  • Target version changed from Milestone 22 to Milestone 23

@dimstar ping

Actions #11

Updated by okurz over 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: cryptlvm@uefi
https://openqa.opensuse.org/tests/867251

Actions #12

Updated by dimstar over 5 years ago

So far, this was only seen in the cryptlvm@uefi test of the DVD install. Since snapshot 0810, this also shows up on the upgrade tests from 42.3/15.0 cryptlvm@uefi (until recently they passed, which was strange in itself)

fvogt recommended to try to use virtio or qxl as graphic chip - as using the legacy cirrus vga in openQA might really reach some limits

Actions #13

Updated by mgriessmeier over 5 years ago

  • Target version changed from Milestone 23 to Milestone 24

moving to M24

Actions #14

Updated by mgriessmeier about 5 years ago

  • Status changed from New to Rejected
  • Target version changed from Milestone 24 to Milestone 25

looks like this is not an issue anymore
@dimstar if you see this still relevant, please reopen

Actions #15

Updated by okurz about 5 years ago

  • Related to action #53339: [opensuse] test fails in swing due to incorrect rendering on 16bpp framebuffers added
Actions

Also available in: Atom PDF