Project

General

Profile

action #21786

[functional]proper wayland support

Added by okurz almost 3 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Start date:
2017-08-04
Due date:
% Done:

100%

Estimated time:
Difficulty:
Duration:

Description

favogt has accomplished a lot already for wayland testing for kde and such but as sle15 will most likely also make use of wayland there is still some work to and cleanup.

Record all necessary tasks to do here.


Related issues

Related to openQA Project - action #15496: qemu -vga qlx supportResolved2016-12-14

Related to openQA Tests - action #27062: [sle][functional][sle15][desktop] Add new QEMUVGA types for Wayland testingResolved2017-10-27

Related to openQA Tests - action #27502: Upgrade x86_64 workers to QEMU 2.9.* or later for Wayland testing of SLED15Resolved2017-11-08

Related to openQA Tests - action #53339: [opensuse] test fails in swing due to incorrect rendering on 16bpp framebuffersResolved2019-06-19

History

#1 Updated by favogt almost 3 years ago

as sle15 will most likely also make use of wayland

That would surprise me as YaST does not run on Wayland (at all - root applications are explicitly disallowed
to connect to the compositor and/or XWayland)

Anyway:

Generally I see these issues with Wayland (compositor independant):

  • Most compositors require proper DRM support -> Cirrus won't work anymore
  • Different appearance of native Wayland applications (different render paths) -> New needles required

Depending on the display manager and compositor there's also the issue that the VT the compositor
runs on is not well defined. Most display managers stay active in the background when starting
a wayland session (gdm, and sddm do, not sure about other wayland compatible ones) and so VT7
is not available.
Additionally, the display manager allocates the VT so the allocation is not the same on all desktops.
In fact, sddm asks the kernel for the next unallocated one so the VT number is depending on the previous
test modules. Without consoletest_setup for instance kwin_wayland is started on tty2, with on tty3.
It might be an option to define a minimum base VT in coordination with the other desktops for easier QA
testing to get a deterministic VT number.

As most "x11" parts of openQA also apply to wayland, the test group should probably be renamed to
"graphical", same for the console.

I do not know about issues with GNOME on Wayland as so far it's apparently not possible to
start a wayland session in QEMU at all (https://lists.opensuse.org/opensuse-factory/2017-07/msg00709.html).

#2 Updated by okurz over 2 years ago

#3 Updated by qkzhu over 2 years ago

  • Related to action #27062: [sle][functional][sle15][desktop] Add new QEMUVGA types for Wayland testing added

#4 Updated by qkzhu over 2 years ago

openQA won't Load the lastgood snapshot when a test module failed in wayland testing.

e.g. kde-wayland@64bit_virtio (with QEMUVGA=virtio) failed at:
https://openqa.opensuse.org/tests/520926#step/khelpcenter/120
The failed module terminated the whole job, all the test modules after khelpcenter.pm were skipped.

Expected Results:

kde@64bit failed at ooffice.pm:
https://openqa.opensuse.org/tests/520585#step/khelpcenter/1
But openQA will load the lastgood VM for the rest test modules.

I can reproduce this on my local instance:
http://10.67.17.30/tests/1980

$rpm -qa | grep openQA

openQA-client-4.5.1509097496.8b8e8e20-12.1.noarch
openQA-4.5.1509097496.8b8e8e20-12.1.noarch
openQA-worker-4.5.1509097496.8b8e8e20-12.1.noarch
openQA-common-4.5.1509097496.8b8e8e20-12.1.noarch

It works fine on:
http://10.67.17.21/tests/118

openQA-common-4.4.1500993922.f0db2597-95.1.noarch
openQA-worker-4.4.1500993922.f0db2597-95.1.noarch
openQA-client-4.4.1500993922.f0db2597-95.1.noarch
openQA-4.4.1500993922.f0db2597-95.1.noarch

#5 Updated by favogt over 2 years ago

qkzhu wrote:

openQA won't Load the lastgood snapshot when a test module failed in wayland testing.

e.g. kde-wayland@64bit_virtio (with QEMUVGA=virtio) failed at:
https://openqa.opensuse.org/tests/520926#step/khelpcenter/120
The failed module terminated the whole job, all the test modules after khelpcenter.pm were skipped.

QEMU only supports savestating of virtio-gpu in version >= 2.10 (IIRC). The version on o3 (except on aarch64 workers) is too old.

#6 Updated by qkzhu over 2 years ago

  • Related to action #27502: Upgrade x86_64 workers to QEMU 2.9.* or later for Wayland testing of SLED15 added

#7 Updated by okurz about 2 years ago

  • Subject changed from proper wayland support to [functional]proper wayland support
  • Target version set to Milestone 16

favogt do you plan to do anything more here? Do you see something missing or should we mark this ticket resolved?

#8 Updated by favogt about 2 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 100

okurz wrote:

favogt do you plan to do anything more here? Do you see something missing or should we mark this ticket resolved?

I don't see anything missing - both QXL and virtio work fine now on the hardware side and on the test side I don't
think any further changes are necessary.

#9 Updated by okurz about 2 years ago

  • Status changed from In Progress to Resolved

alright, then closed

#10 Updated by okurz 11 months ago

  • Related to action #53339: [opensuse] test fails in swing due to incorrect rendering on 16bpp framebuffers added

Also available in: Atom PDF