Project

General

Profile

action #41681

[desktop][sporadic][virtio] test fails in window_system to open windows or type correctly - related to wayland/virtio?

Added by sbehlert about 3 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-09-27
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-x86_64-desktopapps-remote-client2@64bit-virtio-vga fails in
window_system

Error:      failed  
Failed

# Test died: script failed with : SCRIPT_FINISHED7gJ4T-127-
  at /usr/lib/os-autoinst/testapi.pm line 957.

The script call needs a "./"
afaiks

Reproducible

Fails since (at least) Build 50.1 (current job)

Expected result

Last good: 47.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #42362: [qe-core][qem][virtio][sle15sp0][sle15sp1][desktop][typing] test fails in window_system because "typing string is too fast in wayland"In Progress2018-10-12

History

#1 Updated by okurz about 3 years ago

  • Subject changed from test fails in window_system to [desktop][sporadic] test fails in window_system to open windows or type correctly - related to wayland/virtio?
  • Description updated (diff)
  • Assignee changed from jbaier_cz to yfjiang
  • Priority changed from Normal to High

https://openqa.suse.de/tests/2096191#step/window_system/6 fails to type correctly, https://openqa.suse.de/tests/2096191#next_previous shows the majority of tests failing but not all. So the test module itself is fine in principle. I checked the logs and did not find anything obvious, e.g. no "btrfs-balance" in the background that I could see which would slow down the system. I assume that either wayland or virtio is affecting the system performance and causing this.

yfjiang could the "desktop"-team take a look into this?

#2 Updated by okurz almost 3 years ago

  • Subject changed from [desktop][sporadic] test fails in window_system to open windows or type correctly - related to wayland/virtio? to [desktop][sporadic][virtio] test fails in window_system to open windows or type correctly - related to wayland/virtio?

Am I right to assume that this is limited to virtio? Or also appearing on non-virtio but less likely?

upstream report: https://bugs.launchpad.net/qemu/+bug/1802465

#3 Updated by okurz almost 3 years ago

  • Related to action #42362: [qe-core][qem][virtio][sle15sp0][sle15sp1][desktop][typing] test fails in window_system because "typing string is too fast in wayland" added

#4 Updated by okurz almost 3 years ago

  • Blocks action #36259: [opensuse][functional][u][wayland][sporadic] stabilize scenario added

#5 Updated by okurz almost 3 years ago

  • Blocks action #44033: [sle][functional][u] test fails in start_wayland_plasma5 - send_key 'ret' seems not to work added

#6 Updated by okurz almost 3 years ago

  • Blocks action #44042: [sle][functional][u] test fails in desktop_runner because typing character 'true' is not working added

#7 Updated by zcjia almost 3 years ago

okurz wrote:

Am I right to assume that this is limited to virtio? Or also appearing on non-virtio but less likely?

upstream report: https://bugs.launchpad.net/qemu/+bug/1802465

Yes, this is limited to virtio (aka wayland). This can happen on non-virtio (aka X11) but is very very unlikely.

#8 Updated by okurz almost 3 years ago

  • Blocks action #46220: [functional][u][wayland] test fails in khelpcenter - mistyping in krunner added

#9 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: gnome_sled@laptop_64bit-virtio-vga
https://openqa.suse.de/tests/2726739

#10 Updated by okurz over 2 years ago

  • Blocks action #41540: [functional][u][sporadic] test fails in kontact as command "killall" is mistyped in x11_start_program (seems plasma specific problem) added

#11 Updated by mgriessmeier over 2 years ago

  • Blocks deleted (action #44033: [sle][functional][u] test fails in start_wayland_plasma5 - send_key 'ret' seems not to work)

#12 Updated by mgriessmeier over 2 years ago

  • Blocks deleted (action #44042: [sle][functional][u] test fails in desktop_runner because typing character 'true' is not working)

#13 Updated by zluo almost 2 years ago

  • Blocks deleted (action #41540: [functional][u][sporadic] test fails in kontact as command "killall" is mistyped in x11_start_program (seems plasma specific problem))

#14 Updated by mgriessmeier over 1 year ago

  • Blocks deleted (action #46220: [functional][u][wayland] test fails in khelpcenter - mistyping in krunner)

#15 Updated by SLindoMansilla over 1 year ago

  • Blocks deleted (action #36259: [opensuse][functional][u][wayland][sporadic] stabilize scenario)

#16 Updated by maritawerner 4 months ago

GraceWang I guess that is done already? Could we close the ticket?

#17 Updated by GraceWang 4 months ago

  • Status changed from New to Resolved
  • Assignee changed from yfjiang to GraceWang

maritawerner Yes, I checked the openQA results history and found there's no window_system failed in the past 5 months on SLE15SP3.
So, I think we can close it for now and file new ticket to track when we meet the same issue in the upcoming releases.

Also available in: Atom PDF