action #36259

[opensuse][functional][u][wayland][sporadic] stabilize scenario

Added by zluo almost 2 years ago. Updated 11 months ago.

Status:BlockedStart date:16/05/2018
Priority:NormalDue date:
Assignee:mgriessmeier% Done:

0%

Category:Bugs in existing tests
Target version:QA - future
Difficulty:medium
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-kde-wayland@64bit_virtio fails in
oocalc
and overall the scenario seems to be unstable showing to fail in many different test modules which do not seem to be that flaky in non-wayland/virtio scenarios

Reproducible

Fails since (at least) Build 20180425

Expected result

  • AC1: Scenario is stable, e.g. 50 jobs in a row pass

Last good: 20180424 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #44033: [sle][functional][u] test fails in start_wayland_plasma5 ... Rejected 20/11/2018
Blocked by openQA Tests - action #41681: [desktop][sporadic][virtio] test fails in window_system t... New 27/09/2018

History

#1 Updated by dimstar almost 2 years ago

No needle matched because 'Hello world!' was mistyped (only one 'l' in 'Hello' reached oo)

#2 Updated by okurz almost 2 years ago

  • Subject changed from [opensuse][functional] test fails in oocalc - Test died: no candidate needle with tag(s) 'test-oocalc-2' matched to [opensuse][functional][u][wayland] test fails in oocalc - Test died: no candidate needle with tag(s) 'test-oocalc-2' matched
  • Description updated (diff)
  • Due date set to 19/06/2018
  • Target version set to Milestone 17

#3 Updated by JERiveraMoya almost 2 years ago

  • Subject changed from [opensuse][functional][u][wayland] test fails in oocalc - Test died: no candidate needle with tag(s) 'test-oocalc-2' matched to [opensuse][functional][u][wayland] test fails in oocalc -need slow down typing speed
  • Description updated (diff)

#4 Updated by JERiveraMoya almost 2 years ago

  • Description updated (diff)

#5 Updated by JERiveraMoya almost 2 years ago

  • Description updated (diff)

#6 Updated by JERiveraMoya almost 2 years ago

  • Subject changed from [opensuse][functional][u][wayland] test fails in oocalc -need slow down typing speed to [opensuse][functional][u][wayland][medium] test fails in oocalc -need slow down typing speed
  • Status changed from New to Workable
  • Difficulty set to medium

#7 Updated by mgriessmeier almost 2 years ago

  • Due date deleted (19/06/2018)

#8 Updated by okurz almost 2 years ago

  • Target version changed from Milestone 17 to Milestone 19

#9 Updated by okurz almost 2 years ago

  • Target version changed from Milestone 19 to Milestone 19

#10 Updated by okurz over 1 year ago

  • Subject changed from [opensuse][functional][u][wayland][medium] test fails in oocalc -need slow down typing speed to [opensuse][functional][u][wayland][sporadic] stabilize scenario
  • Description updated (diff)
  • Target version changed from Milestone 19 to Milestone 20

The scenario did not really fail in this module in recent time but is overall not very stable, should be stabilized in general.

#11 Updated by zluo over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over and check.

#12 Updated by zluo over 1 year ago

http://e13.suse.de/tests/10254#step/oocalc/2 shows problem with desktop_runner.

#13 Updated by zluo over 1 year ago

http://e13.suse.de/tests/10257 shows problem with start_wayland_plasma5.

#14 Updated by zluo over 1 year ago

http://e13.suse.de/tests/10172#step/oocalc/7 shows a problem with start oocalc:

We see kcalc started instead of oocalc. This means typing character got problem.

#15 Updated by okurz over 1 year ago

I recommend to link related tickets, look for "wayland", e.g. assigned to "desktop" team, and at best also provide statistics about failing modules, e.g. "module fails X/Y runs", etc.

#16 Updated by zluo over 1 year ago

opened now https://progress.opensuse.org/issues/44033 for issue with start_wayland_plasma5.

2 times failure of 10 test runs, this is more than sporadic. We should resolve this problem at first.

#17 Updated by zluo over 1 year ago

  • Related to action #44033: [sle][functional][u] test fails in start_wayland_plasma5 - send_key 'ret' seems not to work added

#18 Updated by zluo over 1 year ago

https://progress.opensuse.org/issues/44042 shows issue with desktop_runner. We should also work at first on this issue which blocks further tests.

#19 Updated by zluo over 1 year ago

  • Related to action #44042: [sle][functional][u] test fails in desktop_runner because typing character 'true' is not working added

#20 Updated by zluo over 1 year ago

check other issue which can block oocalc:

http://e13.suse.de/tests/10267#next_previous

#21 Updated by zluo over 1 year ago

http://e13.suse.de/tests/10271#step/textinfo/3 shows issue:

BUG: workqueue lockup - pool cpus=0 node=0 flags=0x0 nice=0 stuck for 48s!

#22 Updated by zluo over 1 year ago

#23 Updated by okurz over 1 year ago

  • Blocked by action #41681: [desktop][sporadic][virtio] test fails in window_system to open windows or type correctly - related to wayland/virtio? added

#24 Updated by okurz over 1 year ago

  • Status changed from In Progress to Blocked
  • Assignee changed from zluo to okurz
  • Target version changed from Milestone 20 to Milestone 21

#25 Updated by okurz over 1 year ago

  • Target version changed from Milestone 21 to future

#26 Updated by okurz 11 months ago

  • Assignee changed from okurz to mgriessmeier

Move to new QSF-u PO after I moved to the "tools"-team. I mainly checked the subject line so in individual instances you might not agree to take it over completely into QSF-u. Feel free to discuss with me or reassign to me or someone else in this case. Thanks.

#27 Updated by mgriessmeier 9 months ago

  • Related to deleted (action #44042: [sle][functional][u] test fails in desktop_runner because typing character 'true' is not working)

Also available in: Atom PDF