Project

General

Profile

Actions

action #31132

closed

[sle][functional][u][ipmi][hard] test fails in consoletest_setup - login input is wrong

Added by zluo about 6 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 28
Start date:
2018-01-31
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

it seems osd has problem with input:

We get login screen, and then do not login. I guess select_console may need adjustments for ipmi.

We get login screen, and then do not login. I guess select_console may need adjustments for ipmi.
After investigation, we have found out that selecting 'root-console' doesn't work if we have ssh connection. So, we cannot switch to another tty using same way.

We have root-ssh and ssh consoles which are capable of handling login, but that won't work as later in the code we switch to user-console, log-console, etc.

We may consider to just do installation.

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-textmode@64bit-ipmi fails in
consoletest_setup

Acceptance criteria

AC1: test suite has same coverage as extra-tests in text mode

Reproducible

Fails since (at least) Build 288.8

Expected result

Last good: test never worked

Further details

Always latest result in this scenario: latest


Related issues 6 (0 open6 closed)

Related to openQA Tests - action #32089: [sle][functional][u][ipmi][easy] test fails in first_boot - abort the test early so that we at least test the installationResolvedSLindoMansilla2018-02-05

Actions
Related to openQA Tests - action #35742: [functional][u] test fails in consoletest_setup - premature user name typingRejectedokurz2018-05-02

Actions
Related to openQA Tests - action #36126: [functional][u] post_fail_hook matches on "text_login_root" before actual tty switch and therefore never logs inResolvedzluo2018-05-14

Actions
Blocks openQA Tests - coordination #25510: [sle][functional][u][hard][epic] New test scenario textmode@ipmiRejected2018-02-26

Actions
Blocks openQA Tests - action #32305: [functional][u][ipmi] Ensure console tests can be run in textmode@ipmi scenarioRejectedmgriessmeier2018-02-26

Actions
Blocked by openQA Tests - action #31375: [sle][functional][ipmi][u][hard] test fails in first_boot - VNC installation on SLE 15 failed because of various issues (ipmi worker, first_boot, boot_from_pxe, await_install)RejectedSLindoMansilla2018-02-05

Actions
Actions #1

Updated by riafarov about 6 years ago

  • Subject changed from test fails in consoletest_setup - login input is wrong to [sle][functional][ipmi] test fails in consoletest_setup - login input is wrong
  • Description updated (diff)
Actions #2

Updated by riafarov about 6 years ago

  • Related to coordination #25510: [sle][functional][u][hard][epic] New test scenario textmode@ipmi added
Actions #3

Updated by okurz about 6 years ago

  • Target version set to Milestone 15
Actions #4

Updated by riafarov about 6 years ago

  • Description updated (diff)
Actions #5

Updated by riafarov about 6 years ago

  • Subject changed from [sle][functional][ipmi] test fails in consoletest_setup - login input is wrong to [sle][functional][ipmi][hard] test fails in consoletest_setup - login input is wrong
Actions #6

Updated by riafarov about 6 years ago

  • Related to deleted (coordination #25510: [sle][functional][u][hard][epic] New test scenario textmode@ipmi)
Actions #7

Updated by riafarov about 6 years ago

  • Blocks coordination #25510: [sle][functional][u][hard][epic] New test scenario textmode@ipmi added
Actions #8

Updated by riafarov about 6 years ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Priority changed from Normal to High
Actions #9

Updated by okurz about 6 years ago

  • Due date set to 2018-03-13
Actions #10

Updated by okurz about 6 years ago

  • Blocked by action #32089: [sle][functional][u][ipmi][easy] test fails in first_boot - abort the test early so that we at least test the installation added
Actions #11

Updated by okurz about 6 years ago

  • Due date changed from 2018-03-13 to 2018-03-27
Actions #12

Updated by okurz almost 6 years ago

  • Due date deleted (2018-03-27)
  • Target version changed from Milestone 15 to Milestone 18

we just suck - and ipmi does as well, let's postpone

Actions #13

Updated by okurz almost 6 years ago

  • Due date set to 2018-04-10
  • Target version changed from Milestone 18 to Milestone 15

ok, actually I think we should be able to handle this earlier. As we have some capacity in the current sprint I am proposing to add it.

But first #32089

Actions #14

Updated by okurz almost 6 years ago

  • Blocks action #32305: [functional][u][ipmi] Ensure console tests can be run in textmode@ipmi scenario added
Actions #15

Updated by okurz almost 6 years ago

  • Status changed from Workable to Blocked
  • Assignee set to okurz
Actions #16

Updated by mgriessmeier almost 6 years ago

  • Due date changed from 2018-04-10 to 2018-04-24
Actions #17

Updated by mgriessmeier almost 6 years ago

  • Due date changed from 2018-04-24 to 2018-05-08
  • Target version changed from Milestone 15 to Milestone 16

Blocker still not fixed, moving

Actions #18

Updated by SLindoMansilla almost 6 years ago

  • Due date changed from 2018-05-08 to 2018-05-22

As spoken in review. Since blocked by https://progress.opensuse.org/issues/31375, not possible to work on this on sprint 16

Actions #19

Updated by SLindoMansilla almost 6 years ago

  • Blocked by action #31375: [sle][functional][ipmi][u][hard] test fails in first_boot - VNC installation on SLE 15 failed because of various issues (ipmi worker, first_boot, boot_from_pxe, await_install) added
Actions #20

Updated by SLindoMansilla almost 6 years ago

  • Blocked by deleted (action #32089: [sle][functional][u][ipmi][easy] test fails in first_boot - abort the test early so that we at least test the installation)
Actions #21

Updated by SLindoMansilla almost 6 years ago

  • Related to action #32089: [sle][functional][u][ipmi][easy] test fails in first_boot - abort the test early so that we at least test the installation added
Actions #22

Updated by okurz almost 6 years ago

  • Subject changed from [sle][functional][ipmi][hard] test fails in consoletest_setup - login input is wrong to [sle][functional][u][ipmi][hard] test fails in consoletest_setup - login input is wrong
Actions #23

Updated by okurz almost 6 years ago

  • Related to action #35742: [functional][u] test fails in consoletest_setup - premature user name typing added
Actions #24

Updated by mgriessmeier almost 6 years ago

  • Due date changed from 2018-05-22 to 2018-06-05
Actions #25

Updated by mgriessmeier over 5 years ago

  • Due date changed from 2018-06-05 to 2018-06-19
  • Target version changed from Milestone 16 to Milestone 17

blocker still not resolved, moving

Actions #26

Updated by okurz over 5 years ago

  • Due date changed from 2018-06-19 to 2018-07-31
  • Target version changed from Milestone 17 to Milestone 18

based on #31375

Actions #27

Updated by okurz over 5 years ago

  • Target version changed from Milestone 18 to Milestone 18
Actions #28

Updated by okurz over 5 years ago

  • Due date deleted (2018-07-31)
  • Target version changed from Milestone 18 to Milestone 20

after #31375

Actions #29

Updated by okurz over 5 years ago

  • Target version changed from Milestone 20 to Milestone 22
Actions #30

Updated by okurz about 5 years ago

  • Target version changed from Milestone 22 to Milestone 25+
Actions #31

Updated by mgriessmeier almost 5 years ago

  • Target version changed from Milestone 25+ to Milestone 27
Actions #32

Updated by okurz almost 5 years ago

  • Assignee changed from okurz to mgriessmeier

Move to new QSF-u PO after I moved to the "tools"-team. I mainly checked the subject line so in individual instances you might not agree to take it over completely into QSF-u. Feel free to discuss with me or reassign to me or someone else in this case. Thanks.

Actions #33

Updated by mgriessmeier over 4 years ago

  • Status changed from Blocked to Workable
  • Assignee deleted (mgriessmeier)
  • Target version changed from Milestone 27 to Milestone 28

unblocked, to be refined

Actions #34

Updated by okurz over 4 years ago

  • Related to action #36126: [functional][u] post_fail_hook matches on "text_login_root" before actual tty switch and therefore never logs in added
Actions #35

Updated by zluo over 4 years ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over and check what is possible for now to do with sub tickets.

Actions #36

Updated by zluo over 4 years ago

https://openqa.suse.de/tests/3577831#step/consoletest_setup/21 shows that we don't have issue with consoletest_setup atm. We have problem with keymap_or_locale now.

Actions #38

Updated by zluo over 4 years ago

  • Status changed from In Progress to Rejected

since I opened a ticket for keymap_or_locale and working on it and this initial issue doesn't exist anymore, set is as invalid for now.

Actions

Also available in: Atom PDF