Project

General

Profile

Actions

coordination #25510

closed

coordination #37339: [qe-core][functional][saga][ipmi] Stable testing on IPMI backend including x11 tests

[sle][functional][u][hard][epic] New test scenario textmode@ipmi

Added by okurz over 6 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
New test
Target version:
SUSE QA - Milestone 30+
Start date:
2018-02-26
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:

Description

Observation

openQA test in scenario sle-15-Leanos-DVD-x86_64-textmode@64bit-ipmi fails in
partitioning_firstdisk

Reproducible

Fails since (at least) Build 274.1

Expected result

Last good: Never, compare to textmode@64bit. What is special for IMPI is that our machine has two disks so the "partitioning_firstdisk" module is called here. The normal textmode scenario does not have it -> needs at least needle updates.

AC1: Scenario works covering all relevant test modules equivalent to textmode@64bit

Further details

Always latest result in this scenario: latest


Subtasks 1 (0 open1 closed)

action #32305: [functional][u][ipmi] Ensure console tests can be run in textmode@ipmi scenarioRejectedmgriessmeier2018-02-26

Actions

Related issues 4 (1 open3 closed)

Related to openQA Tests - action #34699: [qe-core][functional][ipmi] access to serial log during installationNew2018-04-10

Actions
Blocked by openQA Tests - action #27108: [sle][functional][ipmi][hard] test fails in qa_net_boot_from_hdd - No SOL updates anymore after installationResolvedSLindoMansilla2017-10-302018-01-30

Actions
Blocked by openQA Tests - action #31132: [sle][functional][u][ipmi][hard] test fails in consoletest_setup - login input is wrongRejectedzluo2018-01-31

Actions
Blocks qe-yam - action #33556: [ipmi]New test scenario: textmode+kvm_server_role@ipmiResolved2018-03-21

Actions
Actions #2

Updated by okurz over 6 years ago

@xlai: Please test https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3592 again with a recent build, then we can come back here.

Actions #3

Updated by okurz over 6 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: textmode@64bit-ipmi
https://openqa.suse.de/tests/1236188

Actions #4

Updated by xlai over 6 years ago

  • Assignee changed from xlai to okurz

From latest test results, https://openqa.suse.de/tests/1244594 shows that the installation pass, but test fail at qa_net_boot_from_hdd. I did not read code of this test module, but from the name at least it shows not proper to be tested on physical machine, because it boot from hdd.

Actions #5

Updated by okurz over 6 years ago

  • Due date set to 2017-11-22
  • Assignee deleted (okurz)
  • Target version set to Milestone 12

scheduling for current qa sle functional sprint

Actions #6

Updated by nicksinger over 6 years ago

  • Blocked by action #27108: [sle][functional][ipmi][hard] test fails in qa_net_boot_from_hdd - No SOL updates anymore after installation added
Actions #7

Updated by okurz over 6 years ago

  • Subject changed from [sle][functional] New test scenario textmode@ipmi to [sle][functional][hard][BLOCKED] New test scenario textmode@ipmi
  • Due date changed from 2017-11-22 to 2017-12-20
Actions #8

Updated by okurz over 6 years ago

  • Due date changed from 2017-12-20 to 2017-12-19
Actions #9

Updated by okurz over 6 years ago

  • Due date changed from 2017-12-19 to 2018-02-13
  • Status changed from New to Feedback
  • Target version changed from Milestone 12 to Milestone 13

blocked

Actions #10

Updated by nicksinger over 6 years ago

  • Assignee set to nicksinger
Actions #11

Updated by riafarov over 6 years ago

  • Target version changed from Milestone 13 to Milestone 14
Actions #12

Updated by riafarov over 6 years ago

  • Due date changed from 2018-02-13 to 2018-02-27

Please, check if cannot proceed.

Actions #13

Updated by nicksinger over 6 years ago

  • Status changed from Feedback to Workable
  • Assignee deleted (nicksinger)

Looks workable to me. Unblocking.

Actions #14

Updated by nicksinger over 6 years ago

  • Subject changed from [sle][functional][hard][BLOCKED] New test scenario textmode@ipmi to [sle][functional][hard] New test scenario textmode@ipmi
  • Description updated (diff)
Actions #15

Updated by nicksinger over 6 years ago

  • Description updated (diff)
Actions #16

Updated by riafarov over 6 years ago

  • Assignee set to riafarov
Actions #17

Updated by riafarov over 6 years ago

  • Status changed from Workable to In Progress
Actions #18

Updated by riafarov over 6 years ago

  • Status changed from In Progress to Feedback

So there are 2 kind of issues. First test times out on production. Secondly, first disk selection is called, but there is no second disk.

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4424

Actions #19

Updated by riafarov over 6 years ago

  • Related to action #31132: [sle][functional][u][ipmi][hard] test fails in consoletest_setup - login input is wrong added
Actions #20

Updated by riafarov over 6 years ago

  • Status changed from Feedback to Resolved

https://openqa.suse.de/tests/1475233/ installation works now, further steps will be taken here: https://progress.opensuse.org/issues/31132

Actions #21

Updated by riafarov over 6 years ago

  • Subject changed from [sle][functional][hard] New test scenario textmode@ipmi to [sle][functional][medium] New test scenario textmode@ipmi
Actions #22

Updated by okurz over 6 years ago

  • Subject changed from [sle][functional][medium] New test scenario textmode@ipmi to [sle][functional][hard][epic] New test scenario textmode@ipmi
  • Description updated (diff)
  • Status changed from Resolved to In Progress

A bit sneaky because my originally expected result was to have that "new test scenario" covered on that machine. I doubt that https://progress.opensuse.org/issues/31132 will cover all necessary steps and we should not hide that my just creating tickets on the go. We should have one ticket which clearly states that the new scenario "textmode@ipmi" is not yet completed. Hence reopening, making it an epic and we can link all necessary steps in between subtickets.

Actions #23

Updated by riafarov over 6 years ago

  • Assignee deleted (riafarov)

I've discussed that is what we do in this ticket. Please, schedule subtasks for the sprints.

Actions #24

Updated by riafarov over 6 years ago

  • Related to deleted (action #31132: [sle][functional][u][ipmi][hard] test fails in consoletest_setup - login input is wrong)
Actions #25

Updated by riafarov over 6 years ago

  • Blocked by action #31132: [sle][functional][u][ipmi][hard] test fails in consoletest_setup - login input is wrong added
Actions #26

Updated by riafarov over 6 years ago

  • Status changed from In Progress to Blocked
Actions #29

Updated by okurz over 6 years ago

  • Subject changed from [sle][functional][hard][epic] New test scenario textmode@ipmi to [sle][functional][u][hard][epic] New test scenario textmode@ipmi
  • Target version changed from Milestone 14 to Milestone 16

according to subtask

Actions #30

Updated by okurz about 6 years ago

  • Assignee set to okurz
Actions #31

Updated by okurz about 6 years ago

  • Blocks action #33556: [ipmi]New test scenario: textmode+kvm_server_role@ipmi added
Actions #32

Updated by okurz about 6 years ago

  • Related to action #34699: [qe-core][functional][ipmi] access to serial log during installation added
Actions #33

Updated by okurz about 6 years ago

  • Due date changed from 2018-05-15 to 2018-05-22

due to changes in a related task

Actions #34

Updated by mgriessmeier about 6 years ago

  • Due date changed from 2018-05-22 to 2018-06-05

due to changes in a related task

Actions #35

Updated by mgriessmeier almost 6 years ago

  • Due date changed from 2018-06-05 to 2018-06-19

due to changes in a related task

Actions #36

Updated by okurz almost 6 years ago

  • Due date changed from 2018-06-19 to 2018-08-28

due to changes in a related task

Actions #37

Updated by okurz almost 6 years ago

  • Target version changed from Milestone 16 to Milestone 18

based on #31375

Actions #38

Updated by okurz almost 6 years ago

  • Parent task set to #37339
Actions #39

Updated by okurz almost 6 years ago

  • Target version changed from Milestone 18 to Milestone 18
Actions #40

Updated by okurz almost 6 years ago

  • Due date changed from 2018-08-28 to 2018-12-31

due to changes in a related task

Actions #41

Updated by okurz almost 6 years ago

  • Target version changed from Milestone 18 to Milestone 21
Actions #42

Updated by okurz over 5 years ago

  • Target version changed from Milestone 21 to Milestone 23
Actions #43

Updated by okurz over 5 years ago

  • Due date changed from 2018-12-31 to 2019-12-31

due to changes in a related task

Actions #44

Updated by okurz about 5 years ago

  • Target version changed from Milestone 23 to Milestone 25
Actions #45

Updated by okurz about 5 years ago

  • Assignee changed from okurz to mgriessmeier

Move to new QSF-u PO after I moved to the "tools"-team. I mainly checked the subject line so in individual instances you might not agree to take it over completely into QSF-u. Feel free to discuss with me or reassign to me or someone else in this case. Thanks.

Actions #46

Updated by mgriessmeier almost 5 years ago

  • Target version changed from Milestone 25 to Milestone 26
Actions #47

Updated by mgriessmeier almost 5 years ago

  • Status changed from Blocked to New
  • Assignee deleted (mgriessmeier)
  • Target version changed from Milestone 26 to Milestone 30+

idk... a blocked ticket, with a subtask which is blocked by a blocked ticket by another blocked one, where no one took a look at for over a year looks to me like no one is really interested that this is working - we will come back to this on a later date

Actions #48

Updated by mgriessmeier over 4 years ago

  • Status changed from New to Rejected
Actions #49

Updated by SLindoMansilla about 4 years ago

  • Due date changed from 2019-12-31 to 2018-02-26

due to changes in a related task: #32305

Actions #50

Updated by szarate over 3 years ago

  • Tracker changed from action to coordination
Actions

Also available in: Atom PDF