Project

General

Profile

action #19414

[functional][sle][ppc64le] Unstable alt and shift key presses on PowerPC on QA-Power8-5-kvm worker host

Added by riafarov over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-05-29
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Instead of expected redirection to /dev/hvc0, ?DEV?HVC) is typed.
Is sporadic issue
openQA test in scenario sle-12-SP3-Server-DVD-ppc64le-migration_offline_sle12sp2-sdk+allpatterns_fullupdate@ppc64le fails in
patch_before_migration

Reproducible

https://openqa.suse.de/tests/958514#step/patch_before_migration/14
Fails since (at least) Build 0400

Expected result

In previous run it's different error.
Last good: (unknown) (or more recent)

Further details

In the autoinst logs values are correct:
04:36:43.7336 Debug: /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/update/patch_before_migration.pm:41 called testapi::assert_script_run
04:36:43.7337 12511 <<< testapi::assert_script_run(cmd='zypper lr && zypper mr --disable --all', wait=90, fail_message=undef)
04:36:43.7337 Debug: /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/update/patch_before_migration.pm:41 called testapi::assert_script_run
04:36:43.7338 12511 <<< testapi::type_string(string='zypper lr && zypper mr --disable --all', max_interval=250, wait_screen_changes=0)
04:36:47.7009 Debug: /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/update/patch_before_migration.pm:41 called testapi::assert_script_run
04:36:47.7011 12511 <<< testapi::type_string(string=' ; echo 67Jpw-$?- > /dev/hvc0
', max_interval=250, wait_screen_changes=0)

Always latest result in this scenario: latest

Maybe related to https://progress.opensuse.org/issues/19194 as on malbec issue doesn't appear


Related issues

Related to openQA Project - action #19194: [tools] figure out why QA-Power8-5-kvm fails more than malbecResolved2017-05-17

Related to openQA Tests - action #19410: [sles][ppc64le] - test fails in install_and_rebootResolved2017-05-29

Related to openQA Tests - action #19228: [sle][migration][backlog]Fails in patch_before_migration- device name format incorrectRejected2017-05-19

Related to openQA Tests - action #18020: [sle][migration][backlog] test fails in hostname by typing uppercase commandsRejected2017-03-27

Related to openQA Tests - action #19698: [ppc64le] test fails in reboot_gnome on PowerPC, no reboot window after ctrl-alt-delete key pressesRejected2017-06-09

Related to openQA Tests - action #19784: [sle][functional][ppc64le] test fails in addon_products_via_SCC_yast2 due to missing alt-i key combo on QA-Power8-5-kvmRejected2017-06-13

Has duplicate openQA Tests - action #19266: [functional][sle][ppc64le] search in select_patterns_and_packages cause of not released alt keyRejected2017-05-19

History

#1 Updated by okurz over 4 years ago

  • Related to action #19194: [tools] figure out why QA-Power8-5-kvm fails more than malbec added

#2 Updated by riafarov over 4 years ago

  • Related to action #19266: [functional][sle][ppc64le] search in select_patterns_and_packages cause of not released alt key added

#3 Updated by riafarov over 4 years ago

  • Subject changed from Shift key pressed during the assert_script_execution call in patch_before_migration to Shift key pressed during the assert_script_execution call in patch_before_migration on PowerPC

#4 Updated by riafarov over 4 years ago

  • Subject changed from Shift key pressed during the assert_script_execution call in patch_before_migration on PowerPC to Unstable key presses on PowerPC on QA-Power8-5-kvm worker host

Using single ticket, as multiple failures have same symptoms and most likely same root cause, which is unstable typing which is replicates on QA-Power8-5-kvm, but not on malbec.

In https://progress.opensuse.org/issues/19230 ">" is not typed, which caused "?DEV?HVC)" as shift key was still pressed.

In https://progress.opensuse.org/issues/19266 alt-s combination is used to press "Search" button and then alt key is not released when arrow key is pressed which results in navigation in File menu.

As an experiment we'll try to lower VNC_TYPING_LIMIT value on affected worker to see if it helps.

#5 Updated by riafarov over 4 years ago

  • Related to action #19230: Fails in patch_before_migration - missing redirection operator added

#6 Updated by riafarov over 4 years ago

  • Related to deleted (action #19266: [functional][sle][ppc64le] search in select_patterns_and_packages cause of not released alt key)

#7 Updated by riafarov over 4 years ago

  • Related to deleted (action #19230: Fails in patch_before_migration - missing redirection operator)

#8 Updated by riafarov over 4 years ago

  • Has duplicate action #19230: Fails in patch_before_migration - missing redirection operator added

#9 Updated by riafarov over 4 years ago

  • Has duplicate action #19266: [functional][sle][ppc64le] search in select_patterns_and_packages cause of not released alt key added

#10 Updated by riafarov over 4 years ago

  • Subject changed from Unstable key presses on PowerPC on QA-Power8-5-kvm worker host to [functional][sle][ppc64le] Unstable key presses on PowerPC on QA-Power8-5-kvm worker host

#11 Updated by riafarov over 4 years ago

  • Has duplicate deleted (action #19230: Fails in patch_before_migration - missing redirection operator)

#12 Updated by riafarov over 4 years ago

  • Subject changed from [functional][sle][ppc64le] Unstable key presses on PowerPC on QA-Power8-5-kvm worker host to [functional][sle][ppc64le] Unstable alt and shift key presses on PowerPC on QA-Power8-5-kvm worker host

#13 Updated by riafarov over 4 years ago

Nick and I try to fix test runs on QA-Power8-5-kvm and slow down typing speed to see if it helps (see https://progress.opensuse.org/issues/19414) For that we'll hardcode VNC_TYPING_LIMIT variable value in the worker code to get couple of runs. VNC_TYPING_LIMIT value was changed from 10, which is default for PPC to 3.

#14 Updated by RBrownSUSE over 4 years ago

Where/how did you try and set the typing limit? I cannot see any changes on QA-Power8-5-kvm

#15 Updated by riafarov over 4 years ago

Hi Richard,

We've modified /usr/lib/os-autoinst/consoles/vnc_base.pm perl module by changing $seconds_per_keypress variable value. It's the only usage of VNC_TYPING_LIMIT variable we could find in workers code. We did it this way, as it's easiest one and can be easily reverted, as we are not sure if it helps at all. Otherwise we need new machine and new worker class, which is tricky as we already define VNC_TYPING_LIMIT as 10 for all PPC jobs.

Note: these changes could be already reverted with salt, but we got 3 runs yesterday where this "known" issue hasn't taken place.

#16 Updated by riafarov over 4 years ago

  • Related to action #19410: [sles][ppc64le] - test fails in install_and_reboot added

#17 Updated by okurz over 4 years ago

  • Status changed from New to In Progress

riafarov are you tracking this ticket or not? if yes, please assign to yourself

#18 Updated by riafarov over 4 years ago

  • Assignee set to riafarov

Found this ticket here: https://progress.opensuse.org/issues/18020
So, actually it is common problem for workers on malbec also, but it's much more stable there.

#19 Updated by riafarov over 4 years ago

  • Related to action #19228: [sle][migration][backlog]Fails in patch_before_migration- device name format incorrect added

#20 Updated by riafarov over 4 years ago

  • Related to action #18020: [sle][migration][backlog] test fails in hostname by typing uppercase commands added

#21 Updated by RBrownSUSE over 4 years ago

riafarov wrote:

Hi Richard,

We've modified /usr/lib/os-autoinst/consoles/vnc_base.pm perl module by changing $seconds_per_keypress variable value. It's the only usage of VNC_TYPING_LIMIT variable we could find in workers code. We did it this way, as it's easiest one and can be easily reverted, as we are not sure if it helps at all. Otherwise we need new machine and new worker class, which is tricky as we already define VNC_TYPING_LIMIT as 10 for all PPC jobs.

Note: these changes could be already reverted with salt, but we got 3 runs yesterday where this "known" issue hasn't taken place.

Oh my..please don't do that sort of hotfixing again..

You could have set VNC_TYPING_LIMIT in the workers.ini via salt

That is what I would have recommended...

#22 Updated by RBrownSUSE over 4 years ago

I'm actively reverting the hotpatch, as it totally prevents any effort by me to diagnose anything

#23 Updated by riafarov over 4 years ago

We've tried to set it in workers.ini manually, but it was not picked up by the worker as is already defined in machine settings. Tried both as global and per worker setting. Anyways, this setting helps pnly when command is typed, but not with unreleased alt/shift keys. Let me know if I can assist you in investigation, as there are around 5 tickets which point us to same issue. I've also created a bug for qemu to get some feedback how we can trace the issue if it's a bug in qemu/kvm.

#25 Updated by RBrownSUSE over 4 years ago

  • Status changed from In Progress to Resolved

#26 Updated by riafarov over 4 years ago

  • Related to action #19698: [ppc64le] test fails in reboot_gnome on PowerPC, no reboot window after ctrl-alt-delete key presses added

#27 Updated by riafarov over 4 years ago

  • Related to action #19784: [sle][functional][ppc64le] test fails in addon_products_via_SCC_yast2 due to missing alt-i key combo on QA-Power8-5-kvm added

Also available in: Atom PDF