Project

General

Profile

action #19194

[tools] figure out why QA-Power8-5-kvm fails more than malbec

Added by RBrownSUSE about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Feature requests
Target version:
Start date:
2017-05-17
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

misbehaving worker, nearly screwed up Beta3, something must be different from malbec which is fine.


Related issues

Related to openQA Tests - action #19252: [tools] SUT is to fast for wait_boot at initial startup (SLOF on QA-Power8 related?)Resolved2017-05-19

Related to openQA Tests - action #19414: [functional][sle][ppc64le] Unstable alt and shift key presses on PowerPC on QA-Power8-5-kvm worker hostResolved2017-05-29

Related to openQA Tests - action #19230: Fails in patch_before_migration - missing redirection operatorResolved2017-05-19

Related to openQA Tests - action #19410: [sles][ppc64le] - test fails in install_and_rebootResolved2017-05-29

Precedes openQA Tests - action #18924: [tools][sles][functional] test fails in grub_test - grub screen was not matched in timeResolved2017-05-18

History

#1 Updated by nicksinger about 3 years ago

  • Precedes action #18924: [tools][sles][functional] test fails in grub_test - grub screen was not matched in time added

#2 Updated by nicksinger about 3 years ago

  • Related to action #19252: [tools] SUT is to fast for wait_boot at initial startup (SLOF on QA-Power8 related?) added

#3 Updated by riafarov about 3 years ago

https://openqa.suse.de/tests/950472#previous is a good example for this issue, as it works on malbec, but fails on QA-Power8-5-kvm even though not always. I tried to reproduce this locally on qemu, but could successfully open install console, so doesn't appear like a product issue.

#4 Updated by nicksinger about 3 years ago

Me and riafarov ran "Build0396-cryptlvm+activate_existing" multiple times on multiple workers with the same build. (Also a previous build ran twice on QA-Power8-5 with two failures)
Turns out that the QA-Power8-5 worker fails quiet often to switch console while installing (module "install_and_reboot"). Malbec on the other hand runs this job pretty solid and succeeds in switching the console.

So maybe that's a hint; the broken part on QA-Power8-5 somehow influences console switching in the SUT.

#5 Updated by okurz about 3 years ago

https://openqa.suse.de/tests/952003/file/autoinst-log.txt shows 08:12:40.8553 121412 WARNING: There is some problem with your environment, we detected a stall for 16.276829957962 seconds which is really bad. Means we missed the grub screen for sure. I am wondering why there is no "stall detected" popup in the thumbnails. Shouldn't there be one?

#6 Updated by SLindoMansilla about 3 years ago

Hello Richard,

I have found tickets about this error for aarch64 but not for ppc. Could you take a look?

Tests failing on: sle-12-SP3-Server-DVD-ppc64le-Build0399-toolchain_zypper@ppc64le-smp

DIE ERROR: timeout reading hmp socket

https://openqa.suse.de/tests/957378

#7 Updated by okurz about 3 years ago

  • Category set to 168

#8 Updated by okurz about 3 years ago

  • Related to action #19414: [functional][sle][ppc64le] Unstable alt and shift key presses on PowerPC on QA-Power8-5-kvm worker host added

#9 Updated by riafarov about 3 years ago

  • Related to action #19230: Fails in patch_before_migration - missing redirection operator added

#10 Updated by riafarov about 3 years ago

  • Related to action #19410: [sles][ppc64le] - test fails in install_and_reboot added

#11 Updated by RBrownSUSE about 3 years ago

  • Target version set to Milestone 8

#12 Updated by nicksinger about 3 years ago

  • Related to action #19544: [tools] Checksum/size comparison of autoinst.xml FAILED added

#13 Updated by RBrownSUSE about 3 years ago

  • Related to deleted (action #19544: [tools] Checksum/size comparison of autoinst.xml FAILED)

#14 Updated by RBrownSUSE about 3 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF