Project

General

Profile

action #19266

[functional][sle][ppc64le] search in select_patterns_and_packages cause of not released alt key

Added by nicksinger about 4 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-05-19
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-ppc64le-package-dependency@ppc64le fails in
select_patterns_and_packages

The test fails to click on the search field and then cycles through the context menu. I've not investigated further why exactly this test misses the key press but in general I think this test can be made more solid and more bulletproof.

Reproducible

First occurrence looking at the last good. But it points somehow out where this tests can fail.
Fails since (at least) Build 0389 (current job)

It happened 4 non-consecutive times since the last 20 previous jobs.

Expected result

Last good: 0387 (or more recent)

Further details

Always latest result in this scenario: latest

Workaround

Sporadic issue -> restart the job


Related issues

Is duplicate of openQA Tests - action #19414: [functional][sle][ppc64le] Unstable alt and shift key presses on PowerPC on QA-Power8-5-kvm worker hostResolved2017-05-29

History

#1 Updated by okurz about 4 years ago

  • Subject changed from [functional] test fails in select_patterns_and_packages to [functional][sle][ppc64le] test fails in select_patterns_and_packages to click on search field -> worker or test robustness issue?

by default please provide more information in the subject line than just test fails in foo

#2 Updated by dgutu about 4 years ago

Very related issue here, same worker, strange behave:
https://openqa.suse.de/tests/948861

#3 Updated by SLindoMansilla about 4 years ago

  • Description updated (diff)

#4 Updated by SLindoMansilla about 4 years ago

  • Description updated (diff)

#5 Updated by riafarov about 4 years ago

  • Assignee set to riafarov

#6 Updated by riafarov about 4 years ago

Problem is that alt key is still pressed after "alt-s" combination for search button.

#7 Updated by riafarov about 4 years ago

  • Subject changed from [functional][sle][ppc64le] test fails in select_patterns_and_packages to click on search field -> worker or test robustness issue? to [functional][sle][ppc64le] search in select_patterns_and_packages cause of not released alt key

#8 Updated by riafarov about 4 years ago

  • Related to action #19414: [functional][sle][ppc64le] Unstable alt and shift key presses on PowerPC on QA-Power8-5-kvm worker host added

#9 Updated by riafarov about 4 years ago

  • Related to deleted (action #19414: [functional][sle][ppc64le] Unstable alt and shift key presses on PowerPC on QA-Power8-5-kvm worker host)

#10 Updated by riafarov about 4 years ago

  • Is duplicate of action #19414: [functional][sle][ppc64le] Unstable alt and shift key presses on PowerPC on QA-Power8-5-kvm worker host added

#11 Updated by riafarov about 4 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF