Project

General

Profile

action #19230

Fails in patch_before_migration - missing redirection operator

Added by whdu over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-05-19
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Should be something like "yast-scc-done-\d+- > /dev/hvc0"

Observation

openQA test in scenario sle-12-SP3-Server-DVD-ppc64le-migration_offline_sle12sp2-sdk+allpatterns_fullupdate@ppc64le fails in
patch_before_migration

Reproducible

Fails since (at least) Build 0303

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Project - action #19194: [tools] figure out why QA-Power8-5-kvm fails more than malbecResolved2017-05-17

Has duplicate openQA Tests - action #19290: test fails in patch_before_migration because of missing keysRejected2017-05-22

History

#1 Updated by JWSun over 4 years ago

  • Has duplicate action #19290: test fails in patch_before_migration because of missing keys added

#2 Updated by riafarov over 4 years ago

  • Assignee set to riafarov

#3 Updated by riafarov over 4 years ago

  • Status changed from New to In Progress

JWSun wrote:

Observation

openQA test in scenario sle-12-SP3-Server-DVD-ppc64le-migration_offline_sle12sp2_fullupdate@ppc64le fails in
patch_before_migration
Openqa typed "echo yast-scc-done-$?- /dev/hvc0" instead of "echo yast-scc-done-$?- > /dev/hvc0"
The command printed the result "yast-scc-done-$?- /dev/hvc0" to console yast-scc-done-$?- /dev/hvc0 (https://openqa.suse.de/tests/946820#step/patch_before_migration/20), and the serial didn't get the result as expect.

Reproducible

Fails since (at least) Build 0390

Expected result

Last good: 0389 (or more recent)

Further details

Always latest result in this scenario: latest

#4 Updated by riafarov over 4 years ago

Last run fails for different reason: https://openqa.suse.de/tests/960859#step/patch_before_migration/14
Look like variable expansion didn't work well.

Ninja keys issues, worked fine in next run: https://openqa.suse.de/tests/965911#

Slow down typing to avoid failure in future.

#5 Updated by riafarov over 4 years ago

Attempt to gain more stability: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2976

Root cause are ninja keys for ">" symbol on PPC.

#6 Updated by riafarov over 4 years ago

  • Status changed from In Progress to Feedback

#7 Updated by riafarov over 4 years ago

  • Related to action #19414: [functional][sle][ppc64le] Unstable alt and shift key presses on PowerPC on QA-Power8-5-kvm worker host added

#8 Updated by riafarov over 4 years ago

  • Related to deleted (action #19414: [functional][sle][ppc64le] Unstable alt and shift key presses on PowerPC on QA-Power8-5-kvm worker host)

#9 Updated by riafarov over 4 years ago

  • Is duplicate of action #19414: [functional][sle][ppc64le] Unstable alt and shift key presses on PowerPC on QA-Power8-5-kvm worker host added

#10 Updated by riafarov over 4 years ago

  • Status changed from Feedback to Rejected

#11 Updated by riafarov over 4 years ago

  • Status changed from Rejected to New

Reopened after discussion with Santi, as not released alt and shift keys are not related to typing problems observed here.

#12 Updated by riafarov over 4 years ago

  • Is duplicate of deleted (action #19414: [functional][sle][ppc64le] Unstable alt and shift key presses on PowerPC on QA-Power8-5-kvm worker host)

#13 Updated by riafarov over 4 years ago

  • Related to action #19194: [tools] figure out why QA-Power8-5-kvm fails more than malbec added

#14 Updated by riafarov over 4 years ago

Not reproduced in last 5 runs. Keep tracking.

#15 Updated by RBrownSUSE over 4 years ago

  • Status changed from New to Resolved

#16 Updated by riafarov over 4 years ago

In one of the runs first symbol got duplicated, which is opposite issue, but probably related:
https://openqa.suse.de/tests/975782#step/snapper_cleanup/40
https://openqa.suse.de/tests/975782#step/snapper_create/116

There snapper was typed with double "s"
and ( $snapper list | tail -n1 | awk \'{ print \$3 }\'; echo snapper-post-\$?; ) > /dev/$serialdev\n")
was typed with "((", which failed the tests.

Test was executed before the fix.

Also available in: Atom PDF