Project

General

Profile

action #14818

[EPIC] Interactive mode is an usability disaster

Added by asmorodskyi over 3 years ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
-
Start date:
2018-05-23
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:
Duration:

Description

observation

https://openqa.suse.de/tests/635851/file/autoinst-log.txt

steps to reproduce

  • Start test
  • Go in interactive mode in very beginning
  • Pause test
  • Test times out

problem

H1. a regression in os-autoinst


Subtasks

action #36442: Access to running SUTs for System DevelopersResolvedmkittler

action #36454: Move 'Minimal developer mode' to openQA web UIResolvedmkittler

action #36574: Display instructions how to connect when a job is in status waitingResolvedszarate

action #36613: Implement WS connection from web UI to command serverResolvedmkittler

action #37375: Create UI elements for developer sessions and update them via WS connectionResolvedmkittler

action #38120: Make developer mode accesible to non-adminsResolvedmkittler

action #38510: Allow os-autoinst to pause on next assert_screen timeoutResolvedmkittler


Related issues

Has duplicate openQA Project - action #14832: reload needles and retry does not workRejected2016-11-16

Has duplicate openQA Project - action #18364: interactive mode - needle editor - reload needles and retry doesn't work on most casesClosed2017-04-05

Has duplicate openQA Project - action #18700: openQA worker doesn't work reliable anymore after needle created in interactive mode and reloadedClosed2017-04-21

Has duplicate openQA Project - action #18880: fix interactive mode with cachingClosed2017-04-29

Has duplicate openQA Project - action #19294: openQA webUI - interactive mode - needle editor icon doesn't show up after new needle reloadedClosed2017-05-22

Has duplicate openQA Project - action #17786: [tools]NFS-less mode: Interactive mode needs to resync needlesClosed2017-03-19

History

#1 Updated by okurz over 3 years ago

  • Subject changed from Test got timeout in pause mode to [interactive] Test got timeout in pause mode

#2 Updated by mkittler over 3 years ago

I can not reproduce it here.

#4 Updated by asmorodskyi over 3 years ago

  • Status changed from In Progress to Rejected

#5 Updated by okurz over 3 years ago

  • Status changed from Rejected to In Progress

it's interactive mode so the verification with 20 builds does not apply here.

#6 Updated by coolo over 3 years ago

  • Assignee set to coolo

#7 Updated by coolo over 3 years ago

  • Subject changed from [interactive] Test got timeout in pause mode to Interactive mode is an usability desaster
  • Category changed from Concrete Bugs to 124
  • Status changed from In Progress to New
  • Priority changed from High to Normal

As a matter of fact: there is no "pause mode". The button you pressed is titled 'Stop waiting for needle' - and if you press it, the job will fail unless you create a new needle and reload.

#8 Updated by okurz about 3 years ago

  • Related to action #18700: openQA worker doesn't work reliable anymore after needle created in interactive mode and reloaded added

#9 Updated by coolo over 2 years ago

  • Subject changed from Interactive mode is an usability desaster to [EPIC] Interactive mode is an usability desaster
  • Status changed from New to In Progress

I did some research on it during HW - https://hackweek.suse.com/16/projects/openqa-ide

But a severe cold stopped me from any real progress :(

#10 Updated by coolo over 2 years ago

  • Has duplicate action #14832: reload needles and retry does not work added

#11 Updated by coolo over 2 years ago

  • Has duplicate action #18364: interactive mode - needle editor - reload needles and retry doesn't work on most cases added

#12 Updated by coolo over 2 years ago

  • Related to deleted (action #18700: openQA worker doesn't work reliable anymore after needle created in interactive mode and reloaded)

#13 Updated by coolo over 2 years ago

  • Has duplicate action #18700: openQA worker doesn't work reliable anymore after needle created in interactive mode and reloaded added

#14 Updated by coolo over 2 years ago

  • Has duplicate action #18880: fix interactive mode with caching added

#15 Updated by coolo over 2 years ago

  • Has duplicate action #19294: openQA webUI - interactive mode - needle editor icon doesn't show up after new needle reloaded added

#16 Updated by coolo over 2 years ago

  • Has duplicate action #17786: [tools]NFS-less mode: Interactive mode needs to resync needles added

#17 Updated by coolo about 2 years ago

First branches are set to remove what we have - and add a WS to isotovideo for remote control

#18 Updated by coolo about 2 years ago

User Stories for openQA Developer Mode

We have different developers:

  • Reviewer  Ray wants a way to update needles without job restarts
  • Test Developer Tim wants a way to maintain tests and needles
  • System Developer Lea wants a way to access running SUTs

User Stories:

  1. Lea learned from a bug report that gnucash crashes on startup, but can't reproduce in her system. As such she wants openQA to pause before the gnucash test and give her a chance to step through the test process until the crash to continue manually collecting logs. Lea prefers to have direct access to the SUT - vnc or ssh. She does not need nor know openQA test API in general.
  2. Ray reviews the latest build of Tumbleweed and notices a font change breaking all old needles in GUI applications. He wants openQA to pause whenever an assert_screen would timeout to update the needle and redo the assert_screen with that new needle. Ray is working at about 3 scenarios at the same time - covering different areas of needles.
  3. Tim got a ticket from Ray that the docker test failed and wants openQA  to reproduce the issue and pause at the beginning of the docker test. Afterwards he wants openQA to make a disk snapshot and step through the test  execution to find out where the problem is. After he found out, he reloads the snapshot to tweak the execution. During this process, openQA records his   steps and allows to add needles.

#19 Updated by SLindoMansilla about 2 years ago

  • Subject changed from [EPIC] Interactive mode is an usability desaster to [EPIC] Interactive mode is an usability disaster

#20 Updated by coolo almost 2 years ago

  • Assignee deleted (coolo)

#21 Updated by mkittler over 1 year ago

  • Assignee set to mkittler

#22 Updated by okurz about 1 year ago

  • Category changed from 124 to Feature requests

#23 Updated by coolo 10 months ago

  • Status changed from In Progress to Resolved

We're done with this epic.

Also available in: Atom PDF