Project

General

Profile

action #17786

[tools]NFS-less mode: Interactive mode needs to resync needles

Added by coolo about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Concrete Bugs
Target version:
Start date:
2017-03-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

As the needles are only synced on job start, interactive mode needs some resyncing.


Related issues

Related to openQA Project - action #14832: reload needles and retry does not workRejected2016-11-16

Related to openQA Project - action #18880: fix interactive mode with cachingClosed2017-04-29

Related to openQA Project - action #18700: openQA worker doesn't work reliable anymore after needle created in interactive mode and reloadedClosed2017-04-21

Has duplicate openQA Project - action #19408: interactive mode: stopped live view shows current needle, needle editor shows old needleClosed2017-05-29

Is duplicate of openQA Project - action #14818: [EPIC] Interactive mode is an usability disasterResolved2018-05-23

History

#1 Updated by RBrownSUSE about 3 years ago

  • Subject changed from NFS-less mode: Interactive mode needs to resync needles to [tools]NFS-less mode: Interactive mode needs to resync needles

#2 Updated by okurz about 3 years ago

  • Blocks action #18364: interactive mode - needle editor - reload needles and retry doesn't work on most cases added

#3 Updated by okurz about 3 years ago

  • Blocks action #18700: openQA worker doesn't work reliable anymore after needle created in interactive mode and reloaded added

#4 Updated by okurz about 3 years ago

  • Related to action #18880: fix interactive mode with caching added

#5 Updated by okurz about 3 years ago

  • Priority changed from Normal to High

normal->high as we have more tickets reporting about that.

#6 Updated by okurz about 3 years ago

  • Related to action #14832: reload needles and retry does not work added

#7 Updated by okurz about 3 years ago

  • Target version set to Milestone 9

As discussed during M8 RRP.

Suggested short-term approach: If caching is enabled in a job, do not allow to save a needle or report an info message or prevent needle reload
mid-term: fix it

#8 Updated by szarate almost 3 years ago

  • Has duplicate action #19408: interactive mode: stopped live view shows current needle, needle editor shows old needle added

#9 Updated by szarate almost 3 years ago

  • Related to deleted (action #18880: fix interactive mode with caching)

#10 Updated by szarate almost 3 years ago

  • Related to action #18880: fix interactive mode with caching added

#11 Updated by szarate almost 3 years ago

  • Related to deleted (action #18880: fix interactive mode with caching)

#12 Updated by szarate almost 3 years ago

  • Related to action #18880: fix interactive mode with caching added

#13 Updated by coolo over 2 years ago

  • Blocks deleted (action #18700: openQA worker doesn't work reliable anymore after needle created in interactive mode and reloaded)

#14 Updated by coolo over 2 years ago

  • Related to action #18700: openQA worker doesn't work reliable anymore after needle created in interactive mode and reloaded added

#15 Updated by coolo over 2 years ago

  • Blocks deleted (action #18364: interactive mode - needle editor - reload needles and retry doesn't work on most cases)

#16 Updated by coolo over 2 years ago

  • Is duplicate of action #14818: [EPIC] Interactive mode is an usability disaster added

#17 Updated by coolo over 2 years ago

  • Status changed from New to Closed

refusing to work on old interactive mode

Also available in: Atom PDF