Project

General

Profile

action #12758

Reboot gnome scenario fails

Added by sebchlad over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Start date:
2016-07-19
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Please see following: https://openqa.suse.de/tests/479007#step/reboot_gnome/8

Logs does not indicate well enough what could possibly go wrong. One could see events like right-click present. Seems like correct place on the screen however reboot is not happening.

This should be investigated further as I can't conclusively state if this is openQA issue or perhaps product bug.


Related issues

Related to openQA Tests - action #13874: [Build 2141] test reboot_gnome fails in reboot, should press "esc" to show detailsResolved2016-09-23

Related to openQA Tests - action #18234: [tools][zkvm] test fails to rightclick in reboot_gnomeRejected2017-03-31

History

#1 Updated by okurz over 5 years ago

  • Priority changed from Normal to High

#2 Updated by okurz over 5 years ago

  • Priority changed from High to Urgent

#3 Updated by sebchlad over 5 years ago

  • Priority changed from Urgent to High

okurz wrote:

recent example: https://progress.opensuse.org/issues/12758

directing issue to itself? I guess it is a mistake then on which prio was changed. I'm switching to last state.

#4 Updated by sebchlad over 5 years ago

sebchlad wrote:

okurz wrote:

recent example: https://progress.opensuse.org/issues/12758

directing issue to itself? I guess it is a mistake then on which prio was changed. I'm switching to the last state.

#5 Updated by okurz over 5 years ago

  • Priority changed from High to Urgent

yes, I was trying to reference some failing openqa tests. I found other errors on which the same applies: We don't know for sure if it's a product issue or not and we should investigate more:

Please take care or assign to someone who could investigate more. sysrich was the one that added the "show text" functionality.

#9 Updated by dzedro over 5 years ago

  • Status changed from New to In Progress
  • Assignee set to dzedro

#10 Updated by mkravec over 5 years ago

Reboot gnome does not trigger to ctrl+alt+del, this is new behavior, needs more investigation (bug or openqa problem).
https://openqa.suse.de/tests/539331

#11 Updated by mgriessmeier over 5 years ago

slightly different but might be related
https://openqa.suse.de/tests/562691

#12 Updated by okurz over 5 years ago

last PR from you https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/1823 was merged but it looks like tests still fail, e.g. https://openqa.suse.de/tests/569357#step/reboot_gnome/9, please take a look

#13 Updated by dzedro over 5 years ago

okurz, I'm working on it, I tried reboot_gnome without assert_and_click I don't know why but the password gets deleted same as in your last update, I can't reproduce it manually. I will try to do some magic ...

http://10.100.98.90/tests/3246#step/reboot_gnome/8

#14 Updated by dzedro over 5 years ago

I don't know how, but wait_still_screen deleted typed password.

#15 Updated by okurz over 5 years ago

I think by waiting for long enough the password is deleted and the user has to try again. The solution should be wait less or explicitly wait for the password dots to appear.

#16 Updated by dzedro over 5 years ago

The password will 'shortly' disappear after it is authenticated, mentioned case got stuck at reboot, maybe question is why don't we have logs after reboot_gnome fail.

#17 Updated by dzedro over 5 years ago

  • % Done changed from 0 to 50

#18 Updated by okurz about 5 years ago

  • Category set to Bugs in existing tests

#19 Updated by maritawerner about 5 years ago

As Jozef said it might help to get more logs. Maybe szarate can help with his memory dump feature.

#20 Updated by maritawerner about 5 years ago

  • Related to action #13874: [Build 2141] test reboot_gnome fails in reboot, should press "esc" to show details added

#21 Updated by dzedro about 5 years ago

This issue is still bsc#981299, but i has been workaround to just show soft fail
Problem is that workaround behaves different on different architectures, so it can happen that it will fail.

#22 Updated by okurz about 5 years ago

  • Target version set to Milestone 5

#23 Updated by dzedro about 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

Workaround have been applied for bsc#981299

#24 Updated by nicksinger almost 5 years ago

  • Related to action #18234: [tools][zkvm] test fails to rightclick in reboot_gnome added

Also available in: Atom PDF