Project

General

Profile

action #13874

action #14068: [tools] Gather more system information and logs in case of boot/reboot times out

[Build 2141] test reboot_gnome fails in reboot, should press "esc" to show details

Added by okurz about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Enhancement to existing tests
Target version:
-
Start date:
2016-09-23
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Server-DVD-aarch64-lvm@aarch64 fails in
http://openqa.suse.de/tests/588123#step/reboot_gnome/13
with
Failed needles: ['displaymanager-20140621', 'displaymanager-20160502', 'displaymanager-20160506', 'displaymanager-sles4sap-nousers-20160513', 'text-logged-in-root-20151204', 'text-logged-in-root-kgraft-20160727', 'text-logged-in-root-kgraft-20160728', 'text-logged-in-root-kgraft-ltp-20160727', 'text-logged-in-root-other-font-20151205', 'text-logged-in-root-ssh-20160508', 'text-login-20140219', 'text-login-20160416', 'tty2-selected-20151201', 'tty2-selected-20160508']

Reproducible

Fails since (at least) Build 2141 (current job)

Expected result

Last good: 2137 (or more recent)

suggestion

as in "first_boot" we should try to debug what's the problem, e.g. press esc to let the splash screen go away. Probably first_boot and reboot_gnome need to share more common code, e.g. both call "wait_boot"

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #12758: Reboot gnome scenario failsResolved2016-07-19

History

#1 Updated by maritawerner about 6 years ago

#3 Updated by mkravec almost 6 years ago

  • Assignee set to mkravec

#4 Updated by okurz almost 6 years ago

  • Status changed from In Progress to Resolved
  • Parent task set to #14068

the commits you referenced are only changing first_boot but my change in https://github.com/os-autoinst/os-autoinst-distri-opensuse/commit/4ad89cd94ab167c9159e0dd82941ce69469e430e applied the same for reboot_gnome. IMHO just set ticket to resolved, rest can be done in what I set to be the new parent task which is #14068. Please open again if you disagree.

Also available in: Atom PDF