Project

General

Profile

Actions

action #46967

closed

[functional][u][tools] warning in bootloader_zkvm: Calling Net::SSH2::Channel::readline in non-blocking mode is usually a programming error

Added by mgriessmeier about 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2019-02-01
Due date:
% Done:

0%

Estimated time:

Description

Observation

openQA test in scenario OpenQA::Schema::Result::TestSuites=HASH(0xaeb1b28) fails in
bootloader_zkvm

[2019-02-01T10:03:04.876 CET] [debug] Connection to root@s390p8.suse.de established
Calling Net::SSH2::Channel::readline in non-blocking mode is usually a programming error at /usr/lib/os-autoinst/backend/baseclass.pm line 1221.

First time seeing this in Beta2 Candidate of SLE15-SP1, restarting worked though

Workaround

  • restarting the test

Reproducible

Fails since (at least) Build 158.4 (current job)

Expected result

Last good: 157.1 (or more recent)

Further details

Always latest result in this scenario: latest

UPDATE

bootloader_zkvm failures are not related to this warning. This warning comes from perl-Net-SSH2 version 0.66 (commit ad5f9f0 ("Warn about readline being called in non-blocking mode"). I guess 157.1 (last good) also had this warning, just didn't fail due some other reason. I'll fix this issue during fixing #45863.


Related issues 3 (1 open2 closed)

Related to openQA Tests - action #46919: [functional][u][svirt][sporadic] auto_review:"IO::Socket::INET: connect: Connection timed out"Rejectedszarate2018-12-01

Actions
Related to openQA Project - action #45863: [s390x][svirt][ltp] Fix serial terminal console implementation for svirt backend and use it's outputResolvedpvorel

Actions
Related to openQA Project - action #49394: [s390x][svirt] Print content of kernel log and serial console into "Serial output" fieldNew2019-03-15

Actions
Actions

Also available in: Atom PDF