Project

General

Profile

Actions

coordination #43706

closed

coordination #80142: [saga][epic] Scale out: Redundant/load-balancing deployments of openQA, easy containers, containers on kubernetes

[epic] Generate "download&use" docker image of openQA for SUSE QA

Added by SLindoMansilla over 5 years ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2018-11-13
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)

Description

Motivation

A clean installation and configuration of openQA takes a lot of effort and time. Even more the first time you do. As a developer who wants to reproduce the bug identified by openQA or want to get started writing new tests as a QA engineer, to get this up and running without investing to much time for the configuration.

openQA is not maintained for openSUSE Leap. And there is no proper version scheme for Tumbleweed. EDIT: 2019-12-13 (okurz): There is a stable openQA version within Leap and there are periodic submissions to Tumbleweed.

The last stable version can be found only on the devel repository in OBS: https://build.opensuse.org/package/show/devel:openQA/openQA

Internal deployments of openQA into openqa.opensuse.org and openqa.suse.de are not based on releases from devel:openQA. But, they can be found here: https://wiki.suse.net/index.php?title=OpenQA/Production_Deployment_Schedule done periodically on a daily/weekly schedule.

For QA, the need of local openQA instances brings the need of having an easy way of installing, configuring and deploy with a proper version scheme.
This ticket proposed to achieve it using docker containers. For that, a proper docker image for the webui and for the workers needs to be done.

Existing projects:

Acceptance criteria

  • AC1: Sub-Task are closed (resolved or rejected)

Subtasks 9 (0 open9 closed)

action #43712: Update upstream dockerfiles to provide an easy to use docker image of openQA-webuiResolvedilausuch2018-11-13

Actions
action #43715: Update upstream dockerfiles to provide an easy to use docker image of workersResolvedilausuch2018-11-13

Actions
action #43718: Docker image for webui and workers are versioned and uploaded to obs registryResolvedilausuch2018-11-13

Actions
action #80518: provide container images for aarch64Resolvedokurz2020-11-27

Actions
action #80520: Automatic tests for our openQA containers - webUI onlyResolvedilausuch2020-11-27

Actions
action #80534: publication+demo for updated openQA containersResolvedokurz2020-11-27

Actions
action #80682: Automatic tests for our openQA containers - worker onlyResolvedilausuch2020-11-27

Actions
action #80684: Automatic tests for our openQA containers - worker+webui connectionResolvedokurz2020-11-27

Actions
action #81118: automatic container tests for os-autoinstResolvedokurz2020-12-16

Actions

Related issues 3 (0 open3 closed)

Related to openQA Project - action #45365: [functional][u] Provide an option to set up openQA very easilyResolveddheidler2018-12-19

Actions
Related to openQA Project - action #73450: POC: Create openQA worker container image (feature)Resolvedilausuch2020-10-16

Actions
Related to openQA Project - action #73447: POC: Create openQA Web Application container image (feature)Resolvedilausuch2020-10-16

Actions
Actions #1

Updated by SLindoMansilla over 5 years ago

  • Subject changed from [functional][u] Generate "download&use" docker image of openQA for SUSE QA to [functional][epic][u] Generate "download&use" docker image of openQA for SUSE QA
Actions #2

Updated by riafarov over 5 years ago

  • Description updated (diff)
Actions #3

Updated by EDiGiacinto over 5 years ago

I have this one around as well, based on 42.3 (but lacks dbus support) https://github.com/gentoo-openqa/dockerfiles

Actions #4

Updated by okurz over 5 years ago

  • Target version set to Milestone 22

If you don't mind can you avoid the word "docker" and keep it generic, e.g. as containers :)

SLindoMansilla wrote:

openQA is not maintained for openSUSE Leap. And there is no proper version scheme for Tumbleweed.

The last stable version can be found only on the devel repository in OBS: https://build.opensuse.org/package/show/devel:openQA/openQA

Not sure I understand what you mean there. #18006 describes the details of what I would consider a "stable, properly versioned" version of openQA which are in openSUSE Tumbleweed whenever openQA-in-openQA tests pass. What that be sufficient?

Actions #5

Updated by SLindoMansilla over 5 years ago

@okurz, the openQA-in-openQA tests doesn't cover a complete use case. It is not enough and this is one of the problems we have when people update to a "broken" openQA version.

About docker, well we are creating docker images, so, why confusing people by using a general term?

Actions #6

Updated by SLindoMansilla over 5 years ago

  • Status changed from New to Workable
Actions #7

Updated by okurz over 5 years ago

SLindoMansilla wrote:

@okurz, the openQA-in-openQA tests doesn't cover a complete use case. It is not enough and this is one of the problems we have when people update to a "broken" openQA version.

My point is not that the openQA-in-openQA tests will fix all your problems but rather: More tests are better than less. I would not call the version in "devel:openQA" "last stable version", you did :)

About docker, well we are creating docker images, so, why confusing people by using a general term?

Because https://www.youtube.com/watch?v=YkBk52MGV0Y

Actions #8

Updated by dheidler over 5 years ago

  • Related to action #45365: [functional][u] Provide an option to set up openQA very easily added
Actions #9

Updated by okurz over 5 years ago

  • Target version changed from Milestone 22 to future
Actions #10

Updated by okurz about 5 years ago

  • Project changed from openQA Infrastructure to openQA Project
  • Subject changed from [functional][epic][u] Generate "download&use" docker image of openQA for SUSE QA to [epic] Generate "download&use" docker image of openQA for SUSE QA
  • Category set to Feature requests
  • Assignee deleted (SLindoMansilla)

As we are talking about containers that are already maintained within the openQA upstream repo I think it fits better in the according issue tracker. Also, currently out of scope for QSF-u.

Actions #11

Updated by SLindoMansilla about 5 years ago

Just info: Andrii told me about his solution to launch openQA in a non-intrusive way and without needing root: https://github.com/andrii-suse/environs/tree/master/.product/qa/branch

Actions #12

Updated by okurz over 4 years ago

  • Description updated (diff)
Actions #13

Updated by szarate over 3 years ago

  • Tracker changed from action to coordination
  • Status changed from Workable to New
Actions #15

Updated by okurz over 3 years ago

  • Related to action #73450: POC: Create openQA worker container image (feature) added
Actions #16

Updated by okurz over 3 years ago

  • Related to action #73447: POC: Create openQA Web Application container image (feature) added
Actions #17

Updated by okurz over 3 years ago

  • Parent task set to #80142
Actions #18

Updated by okurz over 3 years ago

  • Status changed from New to Blocked
  • Assignee set to okurz
Actions #19

Updated by okurz 11 months ago

  • Status changed from Blocked to Resolved

All subtasks resolved hence all ACs covered

Actions

Also available in: Atom PDF