Project

General

Profile

action #45365

[functional][u] Provide an option to set up openQA very easily

Added by dheidler over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
SUSE QA tests - Milestone 23
Start date:
2018-12-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Motivation

Setting up openQA can be a bit complicated.
Therefore we should provide a way for users to do this with a single command.
This would allow non-qa engineers to reproduce openqa jobs.

Acceptance criteria

  • AC1: There is a reasonably long one-line command that we feel confident to provide in bug reports to help non-openQA experienced users to reproduce openQA tests

Related issues

Related to openQA Project - action #43706: [epic] Generate "download&use" docker image of openQA for SUSE QAWorkable2018-11-13

Copied to openQA Project - action #48425: [functional][u] Provide an option to set up openQA *and* immediately clone a job very easilyResolved2018-12-19

History

#1 Updated by dheidler over 1 year ago

https://w3.suse.de/~dheidler/openqa-container.html

Created two scripts:

https://w3.suse.de/~dheidler/openqa-bootstrap-container.sh will setup a container and run the 2nd script within the container.

https://w3.suse.de/~dheidler/openqa-bootstrap.sh will setup openQA (including a worker). This works in a container as well as on a normal linux system.

#2 Updated by dheidler over 1 year ago

  • Related to action #43706: [epic] Generate "download&use" docker image of openQA for SUSE QA added

#3 Updated by dheidler over 1 year ago

  • Subject changed from Provide an option to set up openQA very easy to [functional] Provide an option to set up openQA very easy
  • Assignee set to dheidler

#4 Updated by mkittler over 1 year ago

This sound like a much simpler and therefore better approach than using Docker. I haven't tested the scripts yet, but they look clean and one understands what is done. Likely easier and faster to read than the setup guide.

So I would say this could be added to the openQA repository similar to the Dockerfiles we have there as well. Or you create an own repo for now. Since it is containing URLs to internal services the internal GitLab would make most sense.

This is basically the same idea, just for creating a development setup where everything comes from Git and is executed as the regular user: https://github.com/martchus/openQA-helper

Maybe I copy your way of dealing with the API key :-)

#5 Updated by dheidler over 1 year ago

Note that this won't really work well within docker as it is not designed to run systemd unless you do this:

docker run -d --cap-add=SYS_ADMIN -v /sys/fs/cgroup:/sys/fs/cgroup: ro tumbleweed /bin/systemd

Also you would need to make sure that /dev/kvm is available within the container.

#6 Updated by okurz over 1 year ago

  • Subject changed from [functional] Provide an option to set up openQA very easy to [functional][u] Provide an option to set up openQA very easily
  • Description updated (diff)
  • Category set to Feature requests
  • Target version set to Milestone 22

dheidler I added an acceptance criterion, please provide me feedback if you think it's wrong

#7 Updated by dheidler over 1 year ago

  • Status changed from New to In Progress

#9 Updated by dheidler over 1 year ago

  • Status changed from In Progress to Resolved

Tested on tumbleweed.
Added some docs.

#10 Updated by okurz over 1 year ago

  • Status changed from Resolved to Feedback

dheidler wrote:

  • AC1: There is a reasonably long one-line command that we feel confident to provide in bug reports to help non-openQA experienced users to reproduce openQA tests

Can you provide that "one-line" command that would also work on other operating system versions, e.g. Leap 15.1 (15.0?), as part of the documentation as we discussed today? E.g. something like curl … | bash -

If you prefer you can mention that in another ticket and close this one again

#12 Updated by okurz over 1 year ago

documentation PR merged. Now what is still missing is an automatic test for the new command.

#13 Updated by dheidler over 1 year ago

  • Status changed from Feedback to In Progress

Now creating test for openQA-bootstrap that runs within openQA.

#14 Updated by dheidler over 1 year ago

  • Status changed from In Progress to Feedback

#15 Updated by okurz over 1 year ago

PR merged. However, the tests https://openqa.opensuse.org/tests/840027 and https://openqa.opensuse.org/tests/840026 did not work and can not work because they want to boot an image that is not available on that machine selection. I delete these scenarios from the job group for now to not interfer with the Tumbleweed release process. You can experiment in the Development Tumbleweed job group. At best we can reuse an existing image to not use too much space. That means no "4G-40GB" machine but one of the existing ones if that works reliably.

#16 Updated by okurz over 1 year ago

  • Target version changed from Milestone 22 to Milestone 23

ping

#17 Updated by dheidler over 1 year ago

  • Status changed from Feedback to Resolved

https://openqa.opensuse.org/tests/855997
https://openqa.opensuse.org/tests/855996

This is done and there are tests running on openqa.

#18 Updated by okurz over 1 year ago

Thank you. For reference: http://open.qa/docs/#_openqa_quick_bootstrap describes the easy and fast way to setup openQA. This is what we should also suggest to anyone that wants to quickly setup openQA, e.g. in bug reports, as mentioned in the motivation/AC

#19 Updated by okurz over 1 year ago

  • Copied to action #48425: [functional][u] Provide an option to set up openQA *and* immediately clone a job very easily added

Also available in: Atom PDF