Project

General

Profile

action #43718

coordination #80142: [saga][epic] Scale out: Redundant/load-balancing deployments of openQA, easy containers, containers on kubernetes

coordination #43706: [epic] Generate "download&use" docker image of openQA for SUSE QA

Docker image for webui and workers are versioned and uploaded to obs registry

Added by SLindoMansilla over 2 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Feature requests
Target version:
Start date:
2018-11-13
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Motivation

To avoid QA employee getting blocked by a malfunctioning new openQA version, we should have container images available, ideally versioned so people can always use a known to be working openQA version.

Acceptance criteria

  • AC1: (DONE) An x86-64 container image for the webui is available on OBS.
  • AC2: (DONE) An x86-64 container image for the worker is available on OBS.
  • AC3: (IMPLICIT IN OBS) Container images are versioned.

Suggestions


Related issues

Related to openQA Project - action #43619: Improve workflow for dealing with openQA's dependenciesResolved2018-11-09

Copied to openQA Project - action #80516: Docker image for webui and workers on docker hub reflect current stateWorkable

History

#1 Updated by okurz over 2 years ago

  • Target version set to Milestone 23

#2 Updated by szarate over 2 years ago

  • Subject changed from [functional[u] Docker image for webui and workers are versioned and uploaded to docker hub to [functional][u] Docker image for webui and workers are versioned and uploaded to docker hub / obs registry
  • Description updated (diff)

I'd like to set this to a later milestone, there are upcomming changes to openQA that would help a lot with the containerization process, but with the openqa bootstrap scripts provided by poo#45365 there's already a start

#3 Updated by szarate over 2 years ago

  • Related to action #43715: Update upstream dockerfiles to provide an easy to use docker image of workers added

#4 Updated by szarate over 2 years ago

  • Related to deleted (action #43715: Update upstream dockerfiles to provide an easy to use docker image of workers)

#5 Updated by okurz over 2 years ago

good idea, can we relate these tickets then?

#6 Updated by okurz over 2 years ago

  • Subject changed from [functional][u] Docker image for webui and workers are versioned and uploaded to docker hub / obs registry to Docker image for webui and workers are versioned and uploaded to docker hub / obs registry
  • Category set to Feature requests
  • Target version deleted (Milestone 23)

As per #43718#note-5 , no response on the relations. I think it's a nice idea but currently out of scope for QSF-u.

#7 Updated by okurz about 1 year ago

  • Priority changed from Normal to Low
  • Target version set to future

#8 Updated by okurz 11 months ago

  • Related to action #43619: Improve workflow for dealing with openQA's dependencies added

#9 Updated by cdywan 9 months ago

  • Description updated (diff)
  • Assignee set to ilausuch

#10 Updated by cdywan 9 months ago

I created the devel:openQA:container packageproject, so we have a place to publish images there. And once that works we'll do the same for the web UI.

#11 Updated by okurz 9 months ago

please do not work on this ticket, it's not on our backlog. And I would really appreciate if we can resolve the other tickets first. Of course it's ok if you already have some intermediate steps. You can just keep them.

#12 Updated by ilausuch 8 months ago

  • Assignee deleted (ilausuch)

#13 Updated by ilausuch 8 months ago

  • Assignee set to ilausuch

#14 Updated by ilausuch 8 months ago

Now https://build.opensuse.org/project/show/devel:openQA:container is configured properly and I created two packages
https://build.opensuse.org/package/show/devel:openQA:container/openQA_container_webUI
https://build.opensuse.org/package/show/devel:openQA:container/openQA_container_worker

For now, I didn't created the Load Balancer package, but I guess we'll need this in the future.

Both build the images.
obs://build.opensuse.org/devel:openQA:container/containers15.2/6912e7418a7fee7d67a96990f0970e63-openQA_container_webUI
obs://build.opensuse.org/devel:openQA:container/containers15.2/feae4bf90cfbc2366f76f357f21f7f60-openQA_container_worker

Now I am trying to adjust the configuration to publish the images in the public registry

#15 Updated by ilausuch 8 months ago

  • Description updated (diff)

#16 Updated by ilausuch 8 months ago

The container images are already in the registry

podman pull registry.opensuse.org/devel/openqa/container/containers15.2/openqa_webui:latest
podman pull registry.opensuse.org/devel/openqa/container/containers15.2/openqa_worker:latest

#17 Updated by okurz 8 months ago

good. I have not updated #43718 as it is not on our backlog but my suggestion (elsewhere) was to not have packages within the subproject ":container" to prevent the repeated word "container" in the URL. Can you please move the packages to devel:openQA directly?

EDIT: After that I suggest to remove the project again.

#19 Updated by okurz 8 months ago

looks good. I can find the images on https://registry.opensuse.org/cgi-bin/cooverview?srch_term=project%3Ddevel%3AopenQA

But when I try to run the worker image I get:

podman run --rm -it registry.opensuse.org/devel/openqa/containers15.2/openqa_worker
Trying to pull registry.opensuse.org/devel/openqa/containers15.2/openqa_worker...
Getting image source signatures
Copying blob 03155e773b90 done  
Copying blob 9ae21f77663e done  
Copying config 6083cf2534 done  
Writing manifest to image destination
Storing signatures
Error: container_linux.go:349: starting container process caused "exec: \"/run_openqa_worker.sh\": permission denied": OCI runtime permission denied error

I assume the problem is that https://github.com/os-autoinst/openQA/pull/3547 works when building images locally but when we download a simple file within OBS then permissions of the file are lost. Sorry about that. I created https://github.com/os-autoinst/openQA/pull/3594 but now with a comment so that we know why we need that chmod call :)

#20 Updated by okurz 8 months ago

  • Copied to action #80516: Docker image for webui and workers on docker hub reflect current state added

#21 Updated by okurz 8 months ago

  • Subject changed from Docker image for webui and workers are versioned and uploaded to docker hub / obs registry to Docker image for webui and workers are versioned and uploaded to obs registry
  • Description updated (diff)
  • Target version changed from future to Ready

As we could not get a hold of maintainers of the docker hub account "openqa" we split out the complete "docker hub story" to #80516 . aarch64 moved to #43706

#22 Updated by okurz 8 months ago

  • Description updated (diff)

#23 Updated by ilausuch 8 months ago

  • Description updated (diff)

As far as I know versioning is controlled directly by the OBS. When a merge is performed against the master, the image creation will be launched. The latest build made with the latest tag and indicating the date of publication will be published in the registry. So we can consider it taken for granted.

#24 Updated by ilausuch 8 months ago

In order to list where we can find the build images:

registry.opensuse.org/devel/openqa/containers15.2/openqa_webui:latest
registry.opensuse.org/devel/openqa/containers15.2/openqa_worker:latest

#25 Updated by ilausuch 8 months ago

#26 Updated by okurz 8 months ago

  • Description updated (diff)
  • Due date set to 2020-12-02
  • Status changed from Workable to Feedback

With my PR contribution https://github.com/os-autoinst/openQA/pull/3595 merged we prominently mention the Dockerfile based containers in our documentation. We sholud wait until this is deployed to open.qa/docs . More of announcements can be done as part of #80534 . Setting due to to 2020-12-02 as I assume at the latest until then the documentation should be published. Normally that should happen anyway tomorrow morning by an automatic circleCI job creating a PR.

#27 Updated by ilausuch 8 months ago

  • Status changed from Feedback to Resolved

After checking that https://github.com/os-autoinst/openQA/pull/3595 is published then I put the status as resolved

#28 Updated by okurz 4 months ago

  • Due date deleted (2020-12-02)

Also available in: Atom PDF