Project

General

Profile

Actions

action #40799

open

[opensuse] test fails in await_install – times out after 2h in await_install – MAX_JOB_TIME should be higher than sum of all internal timeouts

Added by favogt over 5 years ago. Updated over 2 years ago.

Status:
Feedback
Priority:
Low
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-09-10
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

It thinks the screen is locked and tries to enter the password. It isn't locked though and presses abort in YaST instead.
Black screen just means "display turned off".

Observation

openQA test in scenario opensuse-15.0-KDE-Live-x86_64-kde-live_installation@64bit-2G fails in
await_install

Reproducible

Fails since (at least) Build 20.40

Expected result

Last good: 20.24 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 3 (0 open3 closed)

Related to openQA Tests - action #53534: [opensuse][kde] test fails in await_install - timeout not working properlyResolvedokurz2019-06-26

Actions
Has duplicate openQA Tests - action #41753: [opensuse][krypton] test times out after 2h in await_install – MAX_JOB_TIME should be higher than sum of all internal timeoutsRejected2018-09-28

Actions
Has duplicate openQA Tests - action #40385: [functional][y][opensuse] test fails in await_install on Live installRejectedriafarov2018-08-29

Actions
Actions #1

Updated by favogt over 5 years ago

The screenlock-xscreensaver needle is either wrong or the await_install module needs to be adjusted to move the mouse first, wait a bit and then only look for needles.

Actions #2

Updated by okurz over 5 years ago

  • Subject changed from test fails in await_install to [functional][y] test fails in await_install
  • Target version set to Milestone 19
Actions #3

Updated by ggardet_arm over 5 years ago

The problem comes from screenlock-xscreensaver which is just a black screen. await_install should check if it is a blackscreen and then just skip the unlocking in this case.
https://github.com/ggardet/os-autoinst-distri-opensuse/blob/master/tests/installation/await_install.pm#L128

Actions #4

Updated by favogt over 5 years ago

  • Has duplicate action #41753: [opensuse][krypton] test times out after 2h in await_install – MAX_JOB_TIME should be higher than sum of all internal timeouts added
Actions #5

Updated by okurz over 5 years ago

  • Subject changed from [functional][y] test fails in await_install to [functional][y] test fails in await_install – times out after 2h in await_install – MAX_JOB_TIME should be higher than sum of all internal timeouts
  • Target version changed from Milestone 19 to Milestone 20

please try to come up with better subject lines.

@favogt would you like to help fix that yourself? I doubt QSF can deliver this faster than 3-6 weeks

Actions #6

Updated by okurz over 5 years ago

  • Status changed from New to Feedback
  • Assignee set to favogt
Actions #7

Updated by okurz over 5 years ago

  • Subject changed from [functional][y] test fails in await_install – times out after 2h in await_install – MAX_JOB_TIME should be higher than sum of all internal timeouts to [opensuse] test fails in await_install – times out after 2h in await_install – MAX_JOB_TIME should be higher than sum of all internal timeouts
Actions #8

Updated by okurz over 5 years ago

  • Blocks action #40385: [functional][y][opensuse] test fails in await_install on Live install added
Actions #9

Updated by favogt over 5 years ago

  • Blocks deleted (action #40385: [functional][y][opensuse] test fails in await_install on Live install)
Actions #10

Updated by favogt over 5 years ago

  • Has duplicate action #40385: [functional][y][opensuse] test fails in await_install on Live install added
Actions #11

Updated by favogt over 5 years ago

okurz wrote:

not better -> https://openqa.opensuse.org/tests/771607

No, the bug is fixed. The failure is a libzypp bug: https://bugzilla.opensuse.org/show_bug.cgi?id=1111050

Actions #12

Updated by okurz over 5 years ago

Ok, did you see a submission pending somewhere?

Actions #13

Updated by okurz about 5 years ago

@favogt the mentioned bug as well as the duplicatee https://bugzilla.opensuse.org/show_bug.cgi?id=1109877 are fixed. Now it seems to be https://bugzilla.opensuse.org/show_bug.cgi?id=1125016 blocking us

Actions #14

Updated by okurz about 5 years ago

  • Target version deleted (Milestone 20)
Actions #15

Updated by okurz over 4 years ago

  • Related to action #53534: [opensuse][kde] test fails in await_install - timeout not working properly added
Actions #16

Updated by okurz over 2 years ago

  • Priority changed from Normal to Low

This ticket was set to "Normal" priority but was not updated within 730 days which is 2 times the period of the SLO for "Normal" tickets (365 days) as described on https://progress.opensuse.org/projects/openqatests/wiki/Wiki#SLOs-service-level-objectives . The ticket will be set to the next lower priority of "Low".

Actions

Also available in: Atom PDF