Project

General

Profile

action #53534

[opensuse][kde] test fails in await_install - timeout not working properly

Added by StefanBruens about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2019-06-26
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-KDE-Live-x86_64-kde_live_upgrade_leap_42.3@64bit-2G fails in
await_install

The underlying issue is probably a missed 'reboot_now' screen, and the system has already rebooted. Though, the same would happen if the live install were stuck.

For live installs, the timeout is no more checked after the first lock screen, as it just wiggles the mouse and repeats the loop.

Test suite description

Uses the live installer on the kde live media for upgrading the system.

Reproducible

Fails since (at least) Build 20190625 (current job)

Expected result

Last good: 20190624 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #50615: [functional][y] test fails in await_install - does not catch rebootnowResolved2019-04-22

Related to openQA Tests - action #51983: [functional][y][sporadic] test fails in "await_install" to detect the end of installationRejected2019-05-25

Related to openQA Tests - action #40799: [opensuse] test fails in await_install – times out after 2h in await_install – MAX_JOB_TIME should be higher than sum of all internal timeoutsFeedback2018-09-10

History

#1 Updated by okurz about 2 years ago

  • Status changed from New to In Progress
  • Assignee set to StefanBruens

seems like you are adressing this on your own :) -> https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7756

#2 Updated by SLindoMansilla about 2 years ago

  • Subject changed from test fails in await_install - timeout not working properly to [opensuse][kde] test fails in await_install - timeout not working properly

Triaging comment

As a result of backlog triaging (see https://progress.opensuse.org/projects/openqatests/wiki#ticket-backlog-triaging for more information).

Please, feel free to adjust the category or the "[label]" if you think different.

#3 Updated by okurz about 2 years ago

  • Related to action #50615: [functional][y] test fails in await_install - does not catch rebootnow added

#4 Updated by okurz about 2 years ago

  • Related to action #51983: [functional][y][sporadic] test fails in "await_install" to detect the end of installation added

#5 Updated by okurz about 2 years ago

  • Related to action #40799: [opensuse] test fails in await_install – times out after 2h in await_install – MAX_JOB_TIME should be higher than sum of all internal timeouts added

#6 Updated by okurz almost 2 years ago

  • Status changed from In Progress to Feedback

Hi StefanBruens, it does not look like you are still working on this? I can see that the failing scenario fails now in https://openqa.opensuse.org/tests/1068929#step/disable_grub_timeout/14 . I reported a bug https://bugzilla.opensuse.org/show_bug.cgi?id=1155515 and labeled the failing scenario accordingly. Also I realized that due to https://github.com/yast/yast-installation/blob/master/src/lib/installation/clients/inst_finish.rb#L153 the installer should actually have no timeout for reboot in "live installation" mode anyway. I reported https://bugzilla.opensuse.org/show_bug.cgi?id=1155516 for this. For the handling in test you might want to close your ticket in favor of #50615 ?

#7 Updated by okurz almost 2 years ago

  • Assignee changed from StefanBruens to okurz
  • Target version set to Current Sprint

I am on a different approach now using a change in yast to ask for an explicit disable of the reboot timeout.

#8 Updated by okurz almost 2 years ago

  • Status changed from Feedback to Blocked

wait for #50615

#9 Updated by okurz almost 2 years ago

  • Status changed from Blocked to Resolved
  • Target version changed from Current Sprint to Done

the solution in #50615 should be sufficient enough to cover this problem. Right now the affected test scenario is blocked by https://bugzilla.suse.com/show_bug.cgi?id=1155545 which relates to a discussion about "who should fix live installer bugs at all"

Also available in: Atom PDF