Project

General

Profile

action #25380

[sle][functional][epic] test fails in install - tries to install SLE12 packages -> update test for sle15

Added by jorauch over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Start date:
2017-12-05
Due date:
2018-02-27
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:
Duration: 61

Description

Observation

The test adds repos for SLE12 and therefore it fails on SLE15.
To make this work the test needs to distinguish for which system it is run.

Related bug: bsc#1070151

openQA test in scenario sle-15-Leanos-DVD-aarch64-toolchain_zypper@aarch64 fails in
install

Reproducible

Fails since (at least) Build 96.4

Expected result

Last good: https://openqa.suse.de/tests/1058303#

Should install GCC on SLE 15

Acceptance criteria

  • AC: The sub tasks are resolved

Further details

These settings should be use:

BOOT_HDD_IMAGE=1
DESKTOP=textmode
HDDSIZEGB=20
HDD_1=sle-%VERSION%-%ARCH%-%BUILD%-textmode@%MACHINE%.qcow2
INSTALLONLY=1
MAX_JOB_TIME=14400
QEMUCPUS=4
QEMURAM=4096
START_AFTER_TEST=create_hdd_textmode
TCM=1

Github repo with current changes by jrauch: https://github.com/DrMullings/os-autoinst-distri-opensuse/tree/FIX_Toolchain

Always latest result in this scenario: latest


Subtasks

action #28893: [sle][functional][story][hard] Adapt test suite toolchain_zypper to boot from a hdd with an already installed systemResolvedSLindoMansilla

action #28896: [sle][functional][story][hard] Adapt the test suite toolchain_zypper to install the right patterns and packages for SLE 12-SP4 and 15ResolvedJERiveraMoya

action #29235: [sle][functional][12sp4][easy] test fails in partitioning_togglehome - There is no proposal for separated home partitionResolved

action #29366: [functional][easy][bsc#1073238] Add toolchain test for openSUSEResolvedSLindoMansilla


Related issues

Related to openQA Project - action #28328: job was triggered trying to download HDD image but it's already goneRejected2017-11-24

Has duplicate openQA Tests - action #25720: [sle][functional] test fails in installation of gcc5 because of wrong repositoryRejected2017-10-02

History

#1 Updated by okurz over 2 years ago

  • Status changed from New to In Progress
  • Priority changed from Normal to High

workable item, should be easy to find the corresponding module/repos and add these for the toolchain test. It wasn't done properly in before anyway also for SLE12 by adding custom repos which are not synchronized to osd instead of using assets on osd and proxy-SCC

#2 Updated by okurz over 2 years ago

  • Target version set to Milestone 11

#3 Updated by okurz over 2 years ago

  • Has duplicate action #25720: [sle][functional] test fails in installation of gcc5 because of wrong repository added

#4 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: toolchain_zypper
https://openqa.suse.de/tests/1192449

#5 Updated by jorauch over 2 years ago

Still fails in: https://openqa.suse.de/tests/1212999#step/install/13
IBS directory for toolchain does not contain a version for SLE15
Next steps:

  • Find out where/when/how to get access to the IBS directory for SLE15 -> softfail the module if not possible
  • Implement the distinction between SLE12 and SLE15 in the test code

#6 Updated by jorauch over 2 years ago

  • Assignee set to jorauch

#7 Updated by okurz over 2 years ago

  • Due date set to 2017-11-08

#8 Updated by jorauch over 2 years ago

The new location of gcc:
http://download.suse.de/ibs/SUSE/Products/SLE-Module-Development-Tools/15/
Test Suite has to be adapted to install the Development Tools module

#9 Updated by okurz over 2 years ago

IMHO the testsuite could boot an already installed image and either add the correct repo (e.g. for SLE12) or module (e.g. for SLE15) for the right packages.

http://download.suse.de/ibs/SUSE/Products/SLE-Module-Development-Tools/15/ is not the right location because it is not build specific.

#10 Updated by jorauch over 2 years ago

  • Description updated (diff)

#11 Updated by jorauch over 2 years ago

  • Description updated (diff)

#12 Updated by jorauch over 2 years ago

  • Description updated (diff)

Having problems with boot_to_desktop

#13 Updated by jorauch over 2 years ago

  • Assignee deleted (jorauch)

#14 Updated by jorauch over 2 years ago

  • Assignee set to jorauch

#15 Updated by jorauch over 2 years ago

  • Description updated (diff)

#16 Updated by jorauch over 2 years ago

  • Description updated (diff)

#17 Updated by okurz over 2 years ago

  • Due date deleted (2017-11-08)
  • Target version deleted (Milestone 11)

not done, needs re-evaluation

#18 Updated by jorauch over 2 years ago

  • Target version set to Milestone 11

Very important point when evaluating:
Should we keep the gcc5-fortran test for SLE15?

#19 Updated by okurz over 2 years ago

  • Due date set to 2017-11-22
  • Target version changed from Milestone 11 to Milestone 12

I thought I wrote a comment already: Generalize the test to use the default gcc version of whatever product we test on. Yes, a fortran compile test is important.

#20 Updated by jorauch over 2 years ago

  • Description updated (diff)
  • Target version deleted (Milestone 12)

#21 Updated by jorauch over 2 years ago

  • Subject changed from [sle][functional] test fails in install - tries to install SLE12 packages -> update test for sle15 to [sle][functional][hard] test fails in install - tries to install SLE12 packages -> update test for sle15
  • Description updated (diff)
  • Due date deleted (2017-11-22)
  • Assignee deleted (jorauch)
  • Target version set to Milestone 12

removed from sprint after estimating as "hard" together with okurz

#22 Updated by okurz over 2 years ago

  • Due date set to 2017-12-06

failing in current tests, let's try to handle in next sprint

#23 Updated by JERiveraMoya over 2 years ago

Currently cloning parent & children job, as discussed with Sergio, it needs some tricky way to do it due to is a new children and clone_job does not recognize it out-of-the-box.

#24 Updated by SLindoMansilla over 2 years ago

  • Related to action #28328: job was triggered trying to download HDD image but it's already gone added

#25 Updated by SLindoMansilla over 2 years ago

jrivera, here the reason why the childs don't have the qcow2: https://progress.opensuse.org/issues/28328

#26 Updated by JERiveraMoya over 2 years ago

Not even in the parent openQA, the qcow2 is not found, neither in previous job runs. But in my local test, clonning the parent I can see the image but there is a 404 when downloading. I retriggered the job https://openqa.suse.de/tests/1274100#downloads and now I can see the qcow2 before is cleanned wrongly by openQA as described in the bug you mentioned. I am going to try to use it.

#27 Updated by SLindoMansilla over 2 years ago

  • Description updated (diff)
  • Assignee set to JERiveraMoya

jrivera, if you are working on this ticket, please assign it to you.

#28 Updated by JERiveraMoya over 2 years ago

AC2 and AC4 achieved in my local tests.
Created bug related with missing pattern: https://bugzilla.suse.com/show_bug.cgi?id=1070151

#29 Updated by JERiveraMoya over 2 years ago

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3965/files
Pending to complete verification for SLE-15 and SLE-12 SP3.

#30 Updated by SLindoMansilla over 2 years ago

  • Description updated (diff)

#31 Updated by okurz over 2 years ago

  • Description updated (diff)

As stated in #25380#note-9 I suggest to boot an existing image and enable modules on top and not reconduct a whole installation just to enable one module. This was previously mainly done for historical reason when we could not existing images on all architectures. And as we should look at the product from the customers perspective I don't see a need to handle SLE12 different from SLE15 except for the module/addon names. Sorry if that was not clear in before. That means that I don't see a reason why we should only boot from an existing HDD on SLE15. I deleted AC4 therefore from this ticket. It is my suggestion to boot from an existing HDD but it's not an AC for the ticket to be done. If not done then please extract a ticket with this optional task for later. I recommended to boot from an existing HDD to make it easier for you to be done but it's not a necessity.

Now for some more specific task suggestions:

  • Test manual how the current situation on SLE15 looks like and report bugs!
  • Change existing test flow for SLE12+SLE15 to boot existing HDD
  • Make it work for SLE12
  • Make it work for SLE15 unless blocked by bugs
  • Make sure we have a PR at this point even if SLE15 test fails on bugs
  • optional: Add soft fails and workarounds for the SLE15 bugs

And as we identified this ticket as hard, don't try to solve it on your own.

#32 Updated by JERiveraMoya over 2 years ago

Added information to the bug, it seems that a new toolchain pattern could be added to Development Tools module for SLE15, but still in discussion: https://bugzilla.suse.com/show_bug.cgi?id=1070151
In the meantime added verification run only including the boot for existing HDD for sle15:
http://dhcp227/tests/594

#33 Updated by SLindoMansilla over 2 years ago

Test run for SLE 12-SP3:

Command used:

script/client jobs post ARCH=x86_64 BACKEND=qemu BOOT_HDD_IMAGE=1 BUILD=0473 BUILD_HA=0214 BUILD_HA_GEO=0163 BUILD_SDK=0263 BUILD_SLE=0473 BUILD_WE=0168 DESKTOP=textmode DISTRI=sle FLAVOR=Server-DVD HDDSIZEGB=20 HDD_1=sle-12-SP3-x86_64-0473-textmode@64bit.qcow2 INSTALLONLY=1 ISO=SLE-12-SP3-Server-DVD-x86_64-Build0473-Media1.iso ISO_MAXSIZE=4700372992 MACHINE=64bit-smp MAX_JOB_TIME=14400 NAME=01058303-sle-12-SP3-Server-DVD-x86_64-Build0473-toolchain_zypper@64bit-smp QA_HEAD_REPO=http://dist.nue.suse.com/ibs/QA:/Head/SLE-12-SP3 QA_WEB_REPO=http://dist.suse.de/install/SLP/SLE-12-Module-Web-Scripting-LATEST/x86_64/CD1/ QEMUCPU=qemu64 QEMUCPUS=4 QEMURAM=4096 REPO_0=SLE-12-SP3-Server-DVD-x86_64-Build0473-Media1 SCC_REGCODE=XXX SCC_URL=http://Server-0473.proxy.scc.suse.de SHUTDOWN_NEEDS_AUTH=1 SLENKINS_TESTSUITES_REPO=http://download.suse.de/ibs/Devel:/SLEnkins:/testsuites/SLE_12_SP3/ START_AFTER_TEST=create_hdd_textmode TCM=1 TEST=sergio_toolchain_zypper VERSION=12-SP3 WORKER_CLASS=remote_worker-x86_64

#34 Updated by SLindoMansilla over 2 years ago

Test run for SLE 15:

Command used:

script/client jobs post ARCH=x86_64 BACKEND=qemu BOOT_HDD_IMAGE=1 BUILD=360.1 BUILD_HA=360.1 BUILD_SDK=360.1 BUILD_SLE=360.1 DESKTOP=textmode DISTRI=sle FLAVOR=Server-DVD HDDSIZEGB=20 HDD_1=sle-15-x86_64-360.1-textmode@64bit.qcow2 INSTALLONLY=1 ISO=SLE-15-Installer-DVD-x86_64-Build360.1-Media1.iso ISO_MAXSIZE=4700372992 MACHINE=64bit-smp MAX_JOB_TIME=14400 MIRROR_FTP=ftp://openqa.suse.de/SLE-15-Installer-DVD-x86_64-Build360.1-Media1 MIRROR_HTTP=http://openqa.suse.de/assets/repo/SLE-15-Installer-DVD-x86_64-Build360.1-Media1 MIRROR_NFS=nfs://openqa.suse.de/var/lib/openqa/share/factory/repo/SLE-15-Installer-DVD-x86_64-Build360.1-Media1 MIRROR_SMB=smb://openqa.suse.de/inst/SLE-15-Installer-DVD-x86_64-Build360.1-Media1 NAME=01058303-sle-15-Server-DVD-x86_64-Build360.1-toolchain_zypper@64bit-smp QA_HEAD_REPO=http://dist.nue.suse.com/ibs/QA:/Head/SLE-15 QA_WEB_REPO=http://dist.suse.de/install/SLP/SLE-12-Module-Web-Scripting-LATEST/x86_64/CD1/ QEMUCPU=qemu64 QEMUCPUS=4 QEMURAM=4096 REPO_0=SLE-15-Installer-DVD-x86_64-Build360.1-Media1 REPO_10=SLE-15-Module-Desktop-Productivity-POOL-x86_64-Build360.1-Media1 REPO_11=SLE-15-Module-Development-Tools-POOL-x86_64-Build360.1-Media1 REPO_12=SLE-15-Module-HA-POOL-x86_64-Build360.1-Media1 REPO_13=SLE-15-Module-Legacy-POOL-x86_64-Build360.1-Media1 REPO_14=SLE-15-Module-SAP-Applications-POOL-x86_64-Build360.1-Media1 REPO_15=SLE-15-Module-Server-Applications-POOL-x86_64-Build360.1-Media1 REPO_16=SLE-15-Module-Public-Cloud-POOL-x86_64-Build360.1-Media1 REPO_17=SLE-15-Product-SLES-POOL-x86_64-Build360.1-Media1 REPO_18=SLE-15-Product-SLED-POOL-x86_64-Build360.1-Media1 REPO_8=SLE-15-Module-Basesystem-POOL-x86_64-Build360.1-Media1 REPO_9=SLE-15-Module-Desktop-Applications-POOL-x86_64-Build360.1-Media1 REPO_SLE15_MODULE_BASESYSTEM=SLE-15-Module-Basesystem-POOL-x86_64-Build360.1-Media1 REPO_SLE15_MODULE_DESKTOP_APPLICATIONS=SLE-15-Module-Desktop-Applications-POOL-x86_64-Build360.1-Media1 REPO_SLE15_MODULE_DESKTOP_PRODUCTIVITY=SLE-15-Module-Desktop-Productivity-POOL-x86_64-Build360.1-Media1 REPO_SLE15_MODULE_DEVELOPMENT_TOOLS=SLE-15-Module-Development-Tools-POOL-x86_64-Build360.1-Media1 REPO_SLE15_MODULE_HA=SLE-15-Module-HA-POOL-x86_64-Build360.1-Media1 REPO_SLE15_MODULE_LEGACY=SLE-15-Module-Legacy-POOL-x86_64-Build360.1-Media1 REPO_SLE15_MODULE_PUBLIC_CLOUD=SLE-15-Module-Public-Cloud-POOL-x86_64-Build360.1-Media1 REPO_SLE15_MODULE_SAP_APPLICATIONS=SLE-15-Module-SAP-Applications-POOL-x86_64-Build360.1-Media1 REPO_SLE15_MODULE_SERVER_APPLICATIONS=SLE-15-Module-Server-Applications-POOL-x86_64-Build360.1-Media1 REPO_SLE15_PRODUCT_SLED=SLE-15-Product-SLED-POOL-x86_64-Build360.1-Media1 REPO_SLE15_PRODUCT_SLES=SLE-15-Product-SLES-POOL-x86_64-Build360.1-Media1 SCC_REGCODE=XXX SCC_URL=http://Server-360.1.proxy.scc.suse.de SHUTDOWN_NEEDS_AUTH=1 SLENKINS_TESTSUITES_REPO=http://download.suse.de/ibs/Devel:/SLEnkins:/testsuites/SLE_12_SP3/ START_AFTER_TEST=create_hdd_textmode TCM=1 TEST=sergio_toolchain_zypper VERSION=15 WORKER_CLASS=remote_worker-x86_64

#35 Updated by SLindoMansilla over 2 years ago

  • Description updated (diff)

#36 Updated by SLindoMansilla over 2 years ago

Test suite toolchain_zypper updated in osd to not perform an installation, but to boot from an existing hdd (qcow2) with a textmode installation.

Old settings:

DESKTOP=gnome
HDDSIZEGB=20
INSTALLONLY=1
MAX_JOB_TIME=14400
QEMUCPUS=4
QEMURAM=4096
TCM=1

New settings:

BOOT_HDD_IMAGE=1
DESKTOP=textmode
HDDSIZEGB=20
HDD_1=SLES-%VERSION%-%ARCH%-%BUILD%@%MACHINE%-minimal_with_sdk%BUILD_SDK%_installed.qcow2
INSTALLONLY=1
MAX_JOB_TIME=14400
QEMUCPUS=4
QEMURAM=4096
START_AFTER_TEST=create_hdd_textmode
TCM=1

The next build should trigger the new settings.

#37 Updated by JERiveraMoya over 2 years ago

According to bug resolution, it is the right approach to add the packages, given that pattern is correct that is not available (yet). Updated PR.
Pending to test this code after finishing hdd booting.

#38 Updated by okurz over 2 years ago

@Sergio please don't put any SCC regcodes in public p.o.o .

I am not sure, is %BUILD_SDK% defined for SLE15 or are you not using the same test suite for SLE15?

#39 Updated by okurz over 2 years ago

  • Priority changed from High to Urgent

your actions have caused incompletes because you don't reference the right qcow image that is published by the parent: https://openqa.suse.de/tests/1293186, https://openqa.suse.de/tests/1293561, https://openqa.suse.de/tests/1293281

Please fix that urgently

#41 Updated by SLindoMansilla over 2 years ago

  • Description updated (diff)

okurz wrote:

your actions have caused incompletes because you don't reference the right qcow image that is published by the parent: https://openqa.suse.de/tests/1293186, https://openqa.suse.de/tests/1293561, https://openqa.suse.de/tests/1293281

Please fix that urgently

Fixed to: sle-%VERSION%-%ARCH%-%BUILD%-textmode@%MACHINE%.qcow2

Sorry about the regcode.

Job cloned with proper value:

#42 Updated by okurz over 2 years ago

  • Due date changed from 2017-12-06 to 2017-12-19

during SR: we are on good track, move to next sprint suggested

#43 Updated by SLindoMansilla over 2 years ago

  • Subject changed from [sle][functional][hard] test fails in install - tries to install SLE12 packages -> update test for sle15 to [sle][functional][epic] test fails in install - tries to install SLE12 packages -> update test for sle15

Please see sub tasks

#44 Updated by SLindoMansilla over 2 years ago

  • Description updated (diff)

This ticket is an epic and now tasks are split in sub tasks.

#45 Updated by okurz over 2 years ago

  • Due date set to 2017-12-19

due to changes in a related task

#46 Updated by SLindoMansilla over 2 years ago

  • Blocked by action #29405: [sle][functional] test fails in partitioning_togglehome - No proposal for separated home partition on s390x added

#47 Updated by SLindoMansilla over 2 years ago

  • Blocked by deleted (action #29405: [sle][functional] test fails in partitioning_togglehome - No proposal for separated home partition on s390x)

#48 Updated by JERiveraMoya over 2 years ago

  • Status changed from In Progress to Feedback

#49 Updated by SLindoMansilla over 2 years ago

  • Due date changed from 2017-12-19 to 2018-01-16

due to changes in a related task

#50 Updated by JERiveraMoya over 2 years ago

  • Status changed from Feedback to In Progress

openSUSE task from this epic unblocked.

#51 Updated by JERiveraMoya over 2 years ago

  • Status changed from In Progress to Blocked

#52 Updated by okurz over 2 years ago

  • Target version changed from Milestone 12 to Milestone 13

#53 Updated by okurz over 2 years ago

  • Due date changed from 2018-01-16 to 2018-01-30

due to changes in a related task

#54 Updated by riafarov over 2 years ago

  • Target version changed from Milestone 13 to Milestone 14

Move to the next milestone to revisit.

#55 Updated by riafarov over 2 years ago

  • Due date changed from 2018-01-30 to 2018-02-13

due to changes in a related task

#56 Updated by riafarov over 2 years ago

  • Due date changed from 2018-02-13 to 2018-02-27

due to changes in a related task

#57 Updated by JERiveraMoya over 2 years ago

  • Status changed from Blocked to Resolved

All the subtasks are resolved. Resolving this epic.

Also available in: Atom PDF