Project

General

Profile

action #29235

coordination #25380: [sle][functional][epic] test fails in install - tries to install SLE12 packages -> update test for sle15

[sle][functional][12sp4][easy] test fails in partitioning_togglehome - There is no proposal for separated home partition

Added by SLindoMansilla almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Start date:
2017-12-11
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

  • The test module partitioning_togglehome is loaded when the job setting TOGGLEHOME is set to 1.
  • In 12-SP3, there was no test suite create_hdd_textmode for all architectures, only for x86_64, so this settings wasn't affecting s390x.
  • Since 15, the test suite was adapted to be used on all architectures. On SLE 15, the proposal is there sle-15-Installer-DVD-s390x-Build383.1-create_hdd_textmode@s390x-kvm

openQA test in scenario sle-12-SP4-Server-DVD-s390x-create_hdd_textmode@zkvm fails in
partitioning_togglehome

Acceptance criteria

  • AC: The test doesn't fail on partitioning_tooglehome

Tasks

  1. Investigate if there is a bug that on SLE 12-SP4, that the proposal for separated home partition is not shown.
    • 1.1 create a proper product bug.
    • 1.2. Adapt the test to mark the soft-fail.
    • 1.3. Add a workaround.
  2. If it is not a product:
    • 2.1. Adapt the test module partitioning_tooglehome to not check for separated home partition on s390x for SLE 12-SP4.

Reproducible

Fails since (at least) Build 0083

Expected result

Last good: sle-12-SP3-Server-DVD-s390x-Build0473-textmode@zkvm

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #29405: [sle][functional] test fails in partitioning_togglehome - No proposal for separated home partition on s390xResolved2017-12-14

History

#2 Updated by okurz almost 4 years ago

  • Target version set to Milestone 14

#4 Updated by SLindoMansilla almost 4 years ago

  • Related to action #29405: [sle][functional] test fails in partitioning_togglehome - No proposal for separated home partition on s390x added

Also available in: Atom PDF