Project

General

Profile

coordination #23886

[sle][functional][desktop][sle15][epic] initial setup

Added by okurz about 4 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Start date:
2017-10-12
Due date:
2017-11-08
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:

Description

goal

New job group desktop applications which should be filled with a useful test coverage corresponding to what we had in before for "SLED".

current state

we have image creation jobs for sles which should be adapted by selecting the product SLE_PRODUCT=sled


Subtasks

action #25992: [sle][functional][sle15][desktop] The shutdown-auth is not expected in sled15Resolvedokurz

action #27062: [sle][functional][sle15][desktop] Add new QEMUVGA types for Wayland testingResolvedqkzhu

action #27166: [sle15][desktop] Migrate regression-gnome cases to SLED15Resolvedqkzhu

action #27169: [sle15][desktop] Migrate regression-documentation cases to SLED15ResolvedGraceWang

action #34141: [sle15][desktop] Remove libreoffice_pyuno_bridge test dependency from evolution serverResolvedGraceWang

action #34144: [sle15][desktop] Update libreoffice_open_specified_file to fit the changes in Libreoffice 6.0.0.xResolvedGraceWang

action #35272: [sle15][desktop] Make gnote_rename_title, gnote_undo_redo and libreoffice_recent_documents work on X11.ResolvedGraceWang

action #27229: [sle15][desktop] Migrate regression-other cases to SLED15Resolvedqkzhu


Related issues

Related to openQA Tests - coordination #20580: [sle][functional][epic] sle 15 setupResolved2017-07-202017-09-27

Copied to openQA Tests - action #25542: [sle][sles4sap][sle15] initial setupResolved2017-09-01

History

#1 Updated by okurz about 4 years ago

#2 Updated by okurz about 4 years ago

  • Target version set to Milestone 11

#3 Updated by okurz about 4 years ago

  • Copied to action #25542: [sle][sles4sap][sle15] initial setup added

#4 Updated by okurz about 4 years ago

  • Status changed from New to In Progress
  • Assignee set to okurz

I added a new testsuite "create_hdd_sled_gnome" and scheduled it in the Test Development: SLE15 job group. I will see about the first runs and then forward to "Desktop QA"

#5 Updated by okurz about 4 years ago

Also created testsuite "skip_registration+sled" to test explicitly SLED installation with skipped installation

#6 Updated by okurz about 4 years ago

I guess I have to adapt the regcode for SLED -> https://openqa.suse.de/t1184941

#7 Updated by okurz about 4 years ago

  • Assignee changed from okurz to yfjiang

https://openqa.suse.de/tests/1187419 is the first test ending with successfully publishing an image of registered and installed SLED. I suggest to move on from here by adding scenarios to the desktop applications job group which have "START_AFTER_TEST=create_hdd_sled_gnome" -> yfjiang please take over. I can provide help of course or more specific suggestions if needed.

#8 Updated by yfjiang about 4 years ago

  • Assignee changed from yfjiang to qkzhu

Thanks Oliver, Chingkai is taking care of the follow-up.

#9 Updated by qkzhu about 4 years ago

For testsuite create_hdd_sled_gnome:

DESKTOP=gnome
HDDSIZEGB=30
INSTALLONLY=1
PUBLISH_HDD_1=SLE-%VERSION%-%ARCH%-Build%BUILD%-sled-gnome.qcow2
SCC_REGCODE=ce5eb6792d0e95ed
SLE_PRODUCT=sled
TOGGLEHOME=1

I will replace INSTALLONLY=1 with REGRESSION=installation which will schedule

  • x11regressions/x11regressions_setup
  • console/hostname
  • console/force_cron_run
  • shutdown/grub_set_bootargs
  • shutdown/shutdown after the installation.

Then all testsuite named regression-* can reuse/start after create_hdd_sled_gnome

#10 Updated by qkzhu about 4 years ago

Add sle15_workarounds.pm for testsuite create_hdd_sled_gnome

We will replace testsuite regression-installation with create_hdd_sled_gnome in
SLED 15, this commit will schedule sle15_workarounds.pm for the testsuite.

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3704
Validation test: http://10.67.17.30/tests/1940

I will update the testsuite and move it to job group Desktop Applications once the PR is merged.

#11 Updated by qkzhu about 4 years ago

testsuite create_hdd_sled_gnome has been moved to Desktop Applications

#12 Updated by okurz about 4 years ago

If you want to do this ok but I did not recommend it. My proposal was to keep all installation jobs in the functional job group because errors most likely will be related to "installation" so that I think a review is easier done by a QA SLE functional member but of course I also appreciate more help by you :)

#13 Updated by qkzhu almost 4 years ago

okurz wrote:

If you want to do this ok but I did not recommend it. My proposal was to keep all installation jobs in the functional job group because errors most likely will be related to "installation" so that I think a review is easier done by a QA SLE functional member but of course I also appreciate more help by you :)

I see, the testsuite has been moved back to Functinal.

#14 Updated by okurz almost 4 years ago

  • Due date set to 2017-11-08

due to changes in a related task

#15 Updated by okurz almost 4 years ago

  • Subject changed from [sle][functional][desktop][sle15] initial setup to [sle][functional][desktop][sle15][epic] initial setup

#16 Updated by okurz almost 4 years ago

Found a problem when manually trying to enable the desktop modules + development. Will try an openQA test run manually triggered with this combination. If it makes sense I will add it as test suite later.

openqa_clone_job_osd 1236656 TEST=sled+development _GROUP=0 SCC_ADDONS=sdk

-> https://openqa.suse.de/t1236662

We also met this bug, see bsc#1065073

So failing in valid bug, added test suite "create_hdd_sled_gnome+development" and added that to "SLE: Functional" job group.

#17 Updated by qkzhu almost 4 years ago

  • Target version changed from Milestone 11 to Milestone 12

#18 Updated by qkzhu almost 4 years ago

  • Status changed from In Progress to Resolved

Set as resolved since create_hdd_sled_gnome and create_hdd_sled_gnome+development were already created.

All the migrate regression-* subtasks are blocked by poo#27502, bsc#1065945, bsc#1063428, bsc#1065136...
and we are planing fate#324384 Use GNOME Shell "upstream" mode as default, so most of the desktop application
case should be updated, we'd better track the subtasks separately.

#19 Updated by GraceWang over 3 years ago

  • Due date changed from 2017-11-08 to 2018-04-02

due to changes in a related task

#20 Updated by szarate about 1 year ago

  • Tracker changed from action to coordination

Also available in: Atom PDF