Project

General

Profile

action #27169

coordination #23886: [sle][functional][desktop][sle15][epic] initial setup

[sle15][desktop] Migrate regression-documentation cases to SLED15

Added by GraceWang almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Target version:
-
Start date:
2018-04-02
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:

Description

This testsuite will be renamed as desktopapps-documentation and scheduled under Desktop Applications

desktopapps-documentation:
BOOTFROM=c
HDD_1=SLE-%VERSION%-%ARCH%-Build%BUILD%-sled-gnome.qcow2
REGRESSION=documentation
START_AFTER_TEST=create_hdd_sled_gnome

cases:

tests/x11regressions/gnote/gnote_first_run.pm
tests/x11regressions/gnote/gnote_link_note.pm
tests/x11regressions/gnote/gnote_rename_title.pm
tests/x11regressions/gnote/gnote_undo_redo.pm
tests/x11regressions/gnote/gnote_edit_format.pm
tests/x11regressions/gnote/gnote_search_all.pm
tests/x11regressions/gnote/gnote_search_body.pm
tests/x11regressions/gnote/gnote_search_title.pm
tests/x11regressions/evince/evince_open.pm
tests/x11regressions/evince/evince_view.pm
tests/x11regressions/evince/evince_rotate_zoom.pm
tests/x11regressions/evince/evince_find.pm
tests/x11regressions/gedit/gedit_launch.pm
tests/x11regressions/gedit/gedit_save.pm
tests/x11regressions/gedit/gedit_about.pm
tests/x11regressions/libreoffice/libreoffice_mainmenu_favorites.pm
tests/x11regressions/evolution/evolution_prepare_servers.pm
tests/x11regressions/libreoffice/libreoffice_pyuno_bridge.pm
tests/x11regressions/libreoffice/libreoffice_mainmenu_components.pm
tests/x11regressions/libreoffice/libreoffice_recent_documents.pm
tests/x11regressions/libreoffice/libreoffice_default_theme.pm
tests/x11regressions/libreoffice/libreoffice_open_specified_file.pm
tests/x11regressions/libreoffice/libreoffice_double_click_file.pm


Subtasks

action #34141: [sle15][desktop] Remove libreoffice_pyuno_bridge test dependency from evolution serverResolvedGraceWang

action #34144: [sle15][desktop] Update libreoffice_open_specified_file to fit the changes in Libreoffice 6.0.0.xResolvedGraceWang

action #35272: [sle15][desktop] Make gnote_rename_title, gnote_undo_redo and libreoffice_recent_documents work on X11.ResolvedGraceWang

History

#1 Updated by GraceWang almost 4 years ago

tests/x11regressions/evince/evince_rotate_zoom.pm is blocked by:
https://bugzilla.suse.com/show_bug.cgi?id=1066138 [Build 321.5] evince document viewer zoom function is broken in wayland session

#2 Updated by okurz almost 4 years ago

  • Subject changed from [sle15][functional][desktop] Migrage regression-documentation cases to SLED15 to [sle15][desktop] Migrate regression-documentation cases to SLED15

#3 Updated by okurz almost 4 years ago

  • Category set to New test

Removing "[functional]" because I think only the initial setup was concerning the installation of SLED as a product. This subticket is more specific and can be followed outside the scope of QA SLE functional. I hope you don't mind.

#4 Updated by GraceWang almost 4 years ago

  • % Done changed from 0 to 90

modified: ../lib/x11regressiontest.pm DONE
modified: x11regressions/gnote/gnote_link_note.pm DONE
modified: x11regressions/gnote/gnote_rename_title.pm DONE
modified: x11regressions/gnote/gnote_undo_redo.pm DONE
modified: x11regressions/libreoffice/libreoffice_default_theme.pm DONE
modified: x11regressions/libreoffice/libreoffice_double_click_file.pm DONE
modified: x11regressions/libreoffice/libreoffice_mainmenu_components.pm DONE
modified: x11regressions/libreoffice/libreoffice_mainmenu_favorites.pm DONE
modified: x11regressions/libreoffice/libreoffice_recent_documents.pm DONE

And added new needles for test suite gnote, evince, gedit and libreoffice.

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4133
Needles: https://gitlab.suse.de/openqa/os-autoinst-needles-sles/merge_requests/630
Verification run: http://10.67.17.21/tests/223

#5 Updated by GraceWang almost 4 years ago

  • evolution_prepare_servers N/A
  • libreoffice_pyuno_bridge N/A
  • libreoffice_open_specified_file (In Progress, it fails randomly)

#6 Updated by GraceWang over 3 years ago

  • Status changed from In Progress to Blocked

On SLED15 RC1 build 489.2 https://bugzilla.suse.com/show_bug.cgi?id=1084826 blocks test case libreoffice_open_specified_file

#8 Updated by yfjiang over 3 years ago

The libreoffice-pyuno testing dependency on evolution server is verbose here. The key here is to test the libreoffice pyuno binding works.
A more concise way to do it is probably test the pyuno via pyuno based python script.

e.g.

  1. Launch writer
  2. Tools->Macros->Run Macro->Libreoffice Macro->pythonSamples->TableSample
  3. Choose "CreateTable" macro and click "Run"

=> A table will be created automatically in Writer with this pyuno binding sample.

P.S. The relevant python script got this testing implemented in included in libreoffice-pyuno package:

/usr/lib64/libreoffice/program/uno.py
/usr/lib64/libreoffice/share/Scripts/python/pythonSamples/TableSample.py

#9 Updated by yfjiang over 3 years ago

Hi Grace,

If you are not against the commment#8, let's change the test case without relying on the mail server.

#10 Updated by qkzhu over 3 years ago

gnote_rename_title and gnote_undo_redo are not stable in SLES15+WE:

The performance issue might be resolved by adding some wait_still_screen among the lines of:

type_string "new title-opensuse\n";
send_key "ctrl-tab"; #jump to toolbar
send_key "ctrl-tab" if is_sle('15+'); #jump to toolbar for SLED15

#11 Updated by yfjiang over 3 years ago

qkzhu wrote:

type_string "new title-opensuse\n";
send_key "ctrl-tab"; #jump to toolbar
send_key "ctrl-tab" if is_sle('15+'); #jump to toolbar for SLED15

Discussed with chingkai, this is probably due to the difference between how windows is drawn/canbe navigated by wayland and x11.

Probably we want to use the variable here:

os-autoinst-distri-opensuse/variables:95:WAYLAND

e.g. possibly lines like this would work (with proper SETTINGS for the wayland tests):

send_key "ctrl-tab";
if (get_var("WAYLAND")){
send_key "ctrl-tab";
}

#12 Updated by yfjiang over 3 years ago

  • Status changed from Blocked to Workable

#13 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: wayland-desktopapps-documentation
https://openqa.suse.de/tests/1676565

#14 Updated by GraceWang over 3 years ago

  • Status changed from Workable to In Progress

#15 Updated by GraceWang over 3 years ago

  • Status changed from In Progress to Resolved

All the sub-tasks are resolved.

Passed run on o.s.d
wayland: https://openqa.suse.de/tests/1718823
x11: https://openqa.suse.de/tests/1718531

Also available in: Atom PDF